This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 637319 - Anaconda stops at "checking storage devices" during preupgrade
Anaconda stops at "checking storage devices" during preupgrade
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
14
All Linux
low Severity high
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
:
: 637346 639656 (view as bug list)
Depends On:
Blocks: F14Blocker/F14FinalBlocker
  Show dependency treegraph
 
Reported: 2010-09-24 18:12 EDT by Attilio
Modified: 2010-10-21 02:22 EDT (History)
8 users (show)

See Also:
Fixed In Version: anaconda-14.22-1.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-21 02:22:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
screenshot of the setup messages (495.88 KB, image/jpeg)
2010-09-24 18:12 EDT, Attilio
no flags Details
information given by the lvm program (2.56 KB, text/plain)
2010-09-24 18:19 EDT, Attilio
no flags Details
log files in /tmp (41.72 KB, application/x-gzip)
2010-09-24 21:26 EDT, Attilio
no flags Details
updates against anaconda-14.17.4-1.fc14 to force read-only mount of ntfs (10.32 KB, application/octet-stream)
2010-10-04 13:08 EDT, David Lehman
no flags Details
Log files - boot with "updates-637319.img" (11.61 KB, application/x-gzip)
2010-10-05 06:45 EDT, Matthias
no flags Details
logs with the update applied (20.58 KB, application/zip)
2010-10-16 17:57 EDT, Julian Sikorski
no flags Details

  None (edit)
Description Attilio 2010-09-24 18:12:04 EDT
Created attachment 449526 [details]
screenshot of the setup messages

Description of problem: I can't upgrade from Fedora 13 to 14-alpha with preupgrade, after rebooting anaconda stops at "checking storage devices", "analisi dispositivi storage" in my Italian language setup.

How reproducible: always

Steps to Reproduce:
1.start preupgrade and select to install Fedora 14
2.reboot when asked
  
Actual results: Anaconda stops at the above-mentioned message, and nothing else happens. If I switch to VT 5 i see what's in the attached screenshot (sorry for the bad quality...), where the last messages are about finding 0 logical volumes, then a "Device does not exist" message and "Command failed".
I then tried to check if lvm correctly detected volumes in another VT, and all seems fine, except "LogVol02" is marked "NOT available", it is my swap partition.
I'm attaching the lvm info I copied from the running system.


Expected results: successful installation


Additional info: I also experienced 40~60 secs of a black screen with a blinking cursor before anaconda started, but this is probably unrelated.
Comment 1 Attilio 2010-09-24 18:16:46 EDT
I forgot to add that the vg_acer logical volume contains the system to upgrade, and that i already tried to rename it so that it doesn't have the underscore and nothing changes.
Comment 2 Attilio 2010-09-24 18:19:00 EDT
Created attachment 449528 [details]
information given by the lvm program
Comment 3 Brian Lane 2010-09-24 20:28:21 EDT
Could you switch to tty2 and copy all of the /tmp/*log files and attach them to this bug?
Comment 4 Attilio 2010-09-24 21:26:38 EDT
Created attachment 449550 [details]
log files in /tmp
Comment 5 Chris Lumens 2010-09-27 10:28:33 EDT
*** Bug 637346 has been marked as a duplicate of this bug. ***
Comment 6 Julian Sikorski 2010-10-03 11:38:57 EDT
Happened to me today as well. I do not have any lvm on this machine.
Comment 7 Chris Lumens 2010-10-04 09:54:16 EDT
*** Bug 639656 has been marked as a duplicate of this bug. ***
Comment 8 David Lehman 2010-10-04 13:08:04 EDT
Created attachment 451473 [details]
updates against anaconda-14.17.4-1.fc14 to force read-only mount of ntfs

Please test with the attached updates image as described here:

 http://fedoraproject.org/wiki/Anaconda/Updates#Updates_from_the_Network

and report back with results.

The image is also available for a limited time at on my fedora people page, so you can just add the following to the boot command line:

 updates=http://dlehman.fedorapeople.org/updates-637319.img


NOTE: updates don't work with live installs
Comment 9 Matthias 2010-10-05 06:45:40 EDT
Created attachment 451637 [details]
Log files - boot with "updates-637319.img"
Comment 10 Matthias 2010-10-05 06:49:20 EDT
I still get the same result. My machine gets stuck when it reaches the window "Examining storage devices". 

I attached the log files which I found in /tmp after booting with the option "updates=http://dlehman.fedorapeople.org/updates-637319.img". 

Log files from the same machine without the image file can be found in bug report 639656.
Comment 11 Julian Sikorski 2010-10-16 17:57:19 EDT
Created attachment 453885 [details]
logs with the update applied

I decided to try again today, but unfortunately the anaconda version currently on the mirrors is still the same (14.17.4). So I applied this update, and the upgrade process still failed.
Shouldn't this bug block the release anyway? If it is caused by the presence of ntfs partitions, a lot of users might be hit.
Comment 12 Attilio 2010-10-17 07:11:11 EDT
I've also tried the updates, to no avail. Killing mount.ntfs instead allowed the upgrade process to continue. If preupgrade 12>13 was working fine, this should help a lot in fixing the bug, at least for the release.
If this bug really hits all users with an NTFS partition, that's probably the vast majority of average Fedora users!
Comment 13 Adam Williamson 2010-10-18 17:55:35 EDT
Julian, the correct way to propose a bug as a release blocker is to mark it as blocking the release, otherwise it won't get reviewed for blocker status, which is what's happened in this case :( It's probably too late now, but marking as blocker for everyone to review.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 14 David Lehman 2010-10-19 19:23:47 EDT
Ok, I have uploaded a different proposed fix. Please try again with

  updates=http://dlehman.fedorapeople.org/updates-637319.img


This is against anaconda-14.19-1.fc14.

(Yes, same name/url. I forgot there was a previous version when I uploaded it.)
Comment 15 Fedora Update System 2010-10-19 21:12:10 EDT
anaconda-14.22-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/anaconda-14.22-1.fc14
Comment 16 Fedora Update System 2010-10-19 23:09:44 EDT
anaconda-14.22-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update anaconda'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/anaconda-14.22-1.fc14
Comment 17 Julian Sikorski 2010-10-20 03:13:03 EDT
Where can I find images composed with anaconda-14.19 or 14.22? And is it possible to test this with preupgrade before the update hits stable?
Comment 18 Adam Williamson 2010-10-20 03:36:25 EDT
you don't need to test with preupgrade. any upgrade will do.

i've already reproduced the bug and tested the fix, it works.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 19 Fedora Update System 2010-10-21 02:22:22 EDT
anaconda-14.22-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.