Bug 63737 - bug in /sbin/installkernel script
bug in /sbin/installkernel script
Status: CLOSED DUPLICATE of bug 53557
Product: Red Hat Linux
Classification: Retired
Component: mkinitrd (Show other bugs)
7.2
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Matt Wilson
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-18 01:18 EDT by Need Real Name
Modified: 2007-03-26 23:52 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-20 00:54:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-04-18 01:18:43 EDT
Description of Problem:

Service Request 203939 has been Updated

Incident Number: 203939
Customer Name:   DON KENNEDY
Customer Number: 389721
Date Opened:     Apr 06, 2002 04:15
Date Changed:    Apr 08, 2002 14:08
Red Hat Tech:    Philip

Your Red Hat product:    

Red Hat Linux 7.2 (RHF0044US)

Summary of your problem:

bug in /sbin/installkernel script

Description of your problem:

This is low priority for me, more of an irritant than an issue at this point.

My recent 7.2 install set Grub as the boot manager. A few days ago, I 
downloaded the kernel 2.4.9-31 source package so I could do a bit of tuning to 
my installed 2.4.9-31 kernel configuration. All went well until the "make 
install" step. This one did not finish cleanly - it wasn't able to run lilo (!) because 
/etc/lilo.conf didn't exist. Well, no kidding :-). 

After some digging in the build files in /usr/src/linux-2.4/arch/i386/boot, I 
found install.sh, which calls /sbin/installkernel if it exists. It does. Installekernel 
has as its last line 

if [ -x /sbin/lilo ]; then /sbin/lilo; else /etc/lilo/install; fi 

And that is the source of the failure. 

Why does /sbin/installkernel try to run lilo when the bootloader is Grub? It 
seems like the better test would be to see if /etc/lilo exists, and if not, then 
check for /boot/grub/menu.lst, and if *that* exists, modify it appropriately.

- Don Kennedy

Our latest response:

Re: kernel issue

Dear Sir,

I advice you to pass this to our developers. You are encouraged to post this 
issue to our bugzilla site, because that is where our developers are working on 
known issues and bugs on the system. The url is:

http://bugzilla.redhat.com/

Should you have other concerns, please feel free to write us back.

Regards,
Philip


Version-Release number of selected component (if applicable): kernel 2.4.9-31 
source package 

How Reproducible: Every time

Steps to Reproduce: See the above report.

Actual Results: kernel "make install" failed to run lilo.

Expected Results: "make install" would run without errors.

Additional Information: bootloader for 7.2 is Grub, not lilo.
Comment 1 Need Real Name 2002-04-20 00:54:04 EDT
The version of the mkinitrd package on my system is mkinitrd-3.2.6-1 .
Comment 2 Erik Troan 2002-05-21 18:34:41 EDT
installkernel in 7.3 supports (only) grub

this is only a partial fix, as lilo doesn't work now



*** This bug has been marked as a duplicate of 53557 ***

Note You need to log in before you can comment on or make changes to this bug.