Bug 63793 - at boot, modprobe: block-major-2 not found
at boot, modprobe: block-major-2 not found
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-18 15:40 EDT by Roy Kimbrell
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-18 17:33:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roy Kimbrell 2002-04-18 15:40:17 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
See bug 59353.  This occurs on a Sony Vaio with no /dev/fd0 - thus the message 
from modprobe at boot that block-major-2 can't be found.  However, there is a 
USB floppy attached and the BIOS supports booting from this device - the Linux 
kernel doesn't, I guess.  It would be nice to be able to turn off the 
many "block-major-2 not found" messages at boot time.  Since modprobe is 
reporting this, it would seem that this should be configurable without 
rebuilding the kernel.  Is that possible?

Version-Release number of selected component (if applicable): kernel 2.4.9-31


How reproducible:
Always

Steps to Reproduce:
1. Boot on a machine with no floppy (/dev/fd0)
2.
3.
	

Actual Results:  Get 10 or 15 of the following message:

modprobe: modeprobe: Can't locate module block-major-2

This occurs just after the USB modules have loaded and after each USB module 
loads (and other times as well), though I don't know if there's a relationship 
between the USB modules and modprobe's problem with block-major-2

Expected Results:  

1.  No "Can't locate module block-major-2" messages.

2.  Ability to boot from a USB floppy.

Additional info:  See bug 59353.
Comment 1 Arjan van de Ven 2002-04-18 15:42:30 EDT
add 

alias block-major-2 off

to the /etc/modules.conf file
that ought to get rid of the message
Comment 2 Roy Kimbrell 2002-04-18 16:21:46 EDT
Yeah, that worked just fine.  Thanks very much.  Guess I should have read the
modules.conf man page earlier.  I had checked modules.conf, but didn't think to
look for a man page.  

Is my understanding correct that the abilty to boot from a USB device not a part
of the kernel as yet?

Regards,
Roy
Comment 3 Arjan van de Ven 2002-04-18 16:29:36 EDT
booting is a bootloader issue (eg lilo/grub)
The bootloader needs to load the kernel, and uses the bios for that
I assume the bios emulation of a floppy is good enough

Once stuff is loaded, the kernel can use the usb floppy as usb; just needs
putting the usb drivers in the initrd I think
(haven't tried this though... I don't have such a fancy laptop ';)
Comment 4 Roy Kimbrell 2002-04-18 17:31:26 EDT
Grub - that's right, it's not the kernel.  I tried booting from the floppy, but
Grub didn't like it.  The USB floppy did get accessed (it made a noise, anyway),
but Grub couldn't find a boot image - this is with a boot floppy created during
the install.  I should try this with lilo some time - when I've got some time to
mess with it.  

Thanks for your help,
Roy
Comment 5 Roy Kimbrell 2002-04-18 17:33:16 EDT
By the way, I don't know if you want to close this or not.  I, personally, don't
need to be able to boot from a USB floppy (the cdrom is fine) and my
block-major-2 issue is fixed.  If you want to close it, please feel free.

Roy
Comment 6 Arjan van de Ven 2002-04-19 09:27:38 EDT
I rather close it; the "boot from usb floppy" doesn't have much to do with the
block-major-2 topic and should be in a separate bug really.

Note You need to log in before you can comment on or make changes to this bug.