Bug 63801 - Open Office 641d fails to run under KDE 3 desktop
Open Office 641d fails to run under KDE 3 desktop
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks: FC3BugWeekTracker
  Show dependency treegraph
 
Reported: 2002-04-18 16:33 EDT by Louis J. Rizzo
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-26 18:50:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Louis J. Rizzo 2002-04-18 16:33:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020408

Description of problem:
Open Office 641d binary installs without error, but will not run on KDE desktop.
Displays the Open Office Logo and an hour glass while attempting to start, but
never starts. Only part of app that works is the setup utility to repair, modify
or remove entire program. No error messages given to indicate reason for failure
to load.  Installation on different linux box, also running 7.2.93 Skipjack
Beta2, with different hardware, using same 641d binary downloaded from
OpenOffice.org website exhibits identical problem.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Clean install of Skipjack 7.2.93 Beta2
2.Download and install OpenOffice 641d binary in KDE 3.0 desktop as user.
3.Right click on binary and chose "extract to here"
4.CD to Normal folder and executed "setup"
5.Fill out registration info and accept default folder location.
6.Go to new folder (OpenOffice641) and select shortcut/link for "Soffice".
7. Program will display Blue OpenOffice logo for several seconds, but it will
never open up to the program interface. Eventually blue logo disappears.
	

Actual Results:  Program never runs and opens.

Expected Results:  Expected program to run just like it did in 7.2 with KDE 2.2.  

Additional info:
Comment 1 Ian Prowell 2002-04-19 13:27:06 EDT
This is likely related to the locale problemin the default install.  Check bug
62844.
Comment 2 Need Real Name 2002-04-28 08:54:53 EDT
It looks like not all of the steps recomended at
http://www.openoffice.org/dev_docs/setup-linux.html were followed.  Particularly
step 3.

Prerequisites

You want to make sure you have the latest JRE installed. It must be at least JRE
1.3. You can find the JRE for Linux at
http://www.blackdown.org/java-linux/mirrors.html - or might be included on the
installation media of your distro.

   1. Download the tarball from OpenOffice.org, and extract the tarball (.tar.gz
file) to a temporary directory. "/tmp" is a good place for example. For the
purpose of this example, I will assume you have downloaded the tarball to your
/tmp directory. Open a terminal, such as xterm or konsole. To extract the
tarball, change to the /tmp directory: cd /tmp and extract the tarball: "tar
-zxvf [tarball name]".

   2. This will create a directory "install". Change into this directory: "cd
install."

   3. Execute setup. This is done with the following command: "./setup -net"
This command will start the first step of the Linux setup process.

   4. Follow the instructions of the installation application. When asked where
to place your OpenOffice program files, you can choose "/opt/OpenOffice.org
[version number]" as a good place for your new home of OpenOffice.org. For
example, if your version is 641d, "/opt/ooo641d" would be a good place.

   5. When the installer is finished, you should execute the user-setup for
OpenOffice.org. To do so, first change into the program directory where you
installed OpenOffice.org: cd /opt/ooo641d.

   6. From this directory, execute the following command: "./setup [without the
-net, this time]".

   7. The user portion of setup will now execute. Tell setup to perform a normal
installation (should copy about 1.4 MB of files to your home directory) and tell
it to store the files in your user directory under ooo641d (for example:
"/home/billg/ooo641d"). Follow the instructions and fill in your contact
details, and tell OpenOffice.org where your Java installation lives. When setup
asks where to install the files for OpenOffice, Usually, OpenOffice.org will
find Java on its own, but sometimes it need you to give the path to Java. (tip:
if you don't know the path to your java setup, you can type in the command line:
whereis java - this will give the path to your java installation)

   8. When setup is done, the will want to setup your printer. You can do this
by executing the following command in the same directory (/opt/ooo641d): "./spadmin"
   9. When you have configured your printer, you can change into your home
directory: "/home/billg/ooo641d".

  10. type "./soffice" to start OpenOffice.org!

Please note that begnning with version 1.0, OpenOffice.org will create menus and
icons for GNOME and KDE during the setup, so step 9 and 10 will be redundant.
Comment 3 Louis J. Rizzo 2002-04-29 13:38:00 EDT
I tried the recommendation of  "bnctotman@ev1.net", i.e., to install JRE 1.3.1
before installing Open Office. After finding an RPM for JRE at FreshRPMs, I
installed JRE 1.3.1 and then followed the "Linux Set Up" written by Marijn
Dekkers at the OpenOffice.org website (except I did not do a network install -
./setup -net  since I don't use a network). During OO install, I also had to
point OO to the following directory in order to see JRE (/usr/java/jrel1.3.1;
the install apparently does not see or can not find Java by itself. With the
aforesaid path, OO installer indicated "Java runtime environment (version 1.3.1
verified)."

Sorry to report, my original bug report still stands. Open Office programs
(Soffice and Sadmin) do not work in RH 7.2.93 beta.

Tried this installation under KDE3 and Gnome with same results.
Comment 4 Bernhard Rosenkraenzer 2002-06-24 09:16:31 EDT
This is an openoffice problem, not a KDE problem.
Comment 5 Rik van Riel 2004-09-26 18:50:23 EDT
Inactive for 2 years, and fixed in a current release. Please reopen if
the problem persists.

Thanks to morte in #fedora-bugweek who tested this in a current release.

Note You need to log in before you can comment on or make changes to this bug.