Bug 63808 - root password not authenticated after installation
root password not authenticated after installation
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: pam (Show other bugs)
7.2
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Aaron Brown
:
: 63989 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-18 17:24 EDT by Hial Colburn
Modified: 2007-03-26 23:52 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-21 10:11:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Comment (105.13 KB, text/plain)
2002-04-18 17:24 EDT, Hial Colburn
no flags Details

  None (edit)
Description Hial Colburn 2002-04-18 17:24:07 EDT
Created attachment 915099 [details]
Comment

(This comment was longer than 65,535 characters and has been moved to an attachment by Red Hat Bugzilla).
Comment 1 Havoc Pennington 2002-04-18 18:58:30 EDT
If "su" doesn't work I doubt it's a gdm bug. Must be something in how
authentication is being done.
Comment 2 Havoc Pennington 2002-04-28 12:49:00 EDT
Be sure you're "up2date" on pam and usermode.
Comment 3 Need Real Name 2002-05-15 07:21:08 EDT
I have this same problem (also on an IBM Netfinity 3000).  I have tried to run 
the pam and usermode but of course you need to be root to do so - at least I 
get errors on dependencies when I try to run the rpm's.  Has this bug been 
resolved?

Koke
Comment 4 Hial Colburn 2002-08-15 09:14:08 EDT
I think I finally figured out what was happening...

During the installation, I de-selected MD5 and shadow password authentication, 
but then I entered a 9-digit root password.  The installer accepted this and 
pressed on.  As I understand MD5 (which is very little), passwords are limited 
to 8 characters or less.

Once I rebooted the box into single user mode and ran authconfig to turn on MD5 
and shadow, changed the root password and rebooted, I could login as root.

It seems to me that if you will allow users to NOT use MD5 password 
authentication, you need to perform a check on the number of characters in the  
root password to prevent this problem from occuring.

Hope this helps...
Comment 5 Mark J. Cox (Product Security) 2002-08-16 04:07:29 EDT
(downgrading from security severity)
Comment 6 Tomas Mraz 2004-10-21 10:10:08 EDT
*** Bug 63989 has been marked as a duplicate of this bug. ***
Comment 7 Tomas Mraz 2004-10-21 10:11:43 EDT
This works fine in Fedora Core 2.

Note You need to log in before you can comment on or make changes to this bug.