Bug 63989 - Long passwords are not recognised
Long passwords are not recognised
Status: CLOSED DUPLICATE of bug 63808
Product: Red Hat Linux
Classification: Retired
Component: pam (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-23 06:18 EDT by Martin Donnelly
Modified: 2007-04-18 12:42 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-21 10:10:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Donnelly 2002-04-23 06:18:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 4.0; T312461)

Description of problem:
I have a RH7.1 machine acting as an NIS server for a variety of
linux and solaris machine. I was adding some new machines to the domain - one 
of which was a RH7.2 box. Some users were unable to log into this machine. Upon 
investigation i tracked this down to a problem with passwords greater than 8 
characters long. All other machines ignore characters after the 8th one in the 
password while the RH7.2 box treats all characters as significant. Typing only 
the first eight characters of the password allows a user to log in.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Add an NIS client to an existing domain with a non RH7.2 NIS server
2. Try and log in with a password greater than 8 characters
	

Actual Results:  Login will fail

Expected Results:  Login should suceed since it should be backwards compatible 
with previous out of the box setups.

Additional info:

I have also seen the same problem reported on comp.os.linux.security

http://groups.google.com/groups?hl=en&threadm=kpWv8.16684%24A%253.149283%40ord-
read.news.verio.net&rnum=1&prev=/groups%3Fq%3DNIS%2Blong%2Bpassword%26hl%3Den%
26selm%3DkpWv8.16684%2524A%25253.149283%2540ord-read.news.verio.net%26rnum%3D1
Comment 1 Alexander Larsson 2002-04-23 13:03:20 EDT
Sounds more like a pam issue. Reassigning to nalin.
Comment 2 Tomas Mraz 2004-10-21 10:09:59 EDT

*** This bug has been marked as a duplicate of 63808 ***

Note You need to log in before you can comment on or make changes to this bug.