Bug 638244 - Key's defined using unicode hex codes has stopped working in some/all layouts (e.g. ir and af layouts)
Key's defined using unicode hex codes has stopped working in some/all layouts...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xkeyboard-config (Show other bugs)
14
All Linux
high Severity high
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
: Reopened
: 640915 (view as bug list)
Depends On:
Blocks: F14Target
  Show dependency treegraph
 
Reported: 2010-09-28 11:14 EDT by Hedayat Vatankhah
Modified: 2010-10-29 16:40 EDT (History)
7 users (show)

See Also:
Fixed In Version: xorg-x11-xkb-utils-7.4-9.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-29 16:40:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Fixes the bug (889 bytes, patch)
2010-09-30 17:01 EDT, Hedayat Vatankhah
no flags Details | Diff
A patch to make many keys working again (3.48 KB, patch)
2010-09-30 18:33 EDT, Hedayat Vatankhah
no flags Details | Diff
A patch which will fix the hex codes in ir layout (10.58 KB, patch)
2010-10-06 02:03 EDT, Hedayat Vatankhah
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 30548 None None None Never
FreeDesktop.org 30549 None None None Never

  None (edit)
Description Hedayat Vatankhah 2010-09-28 11:14:28 EDT
Description of problem:
I've installed Fedora 14 Beta RC3 (from DVD), now I want to enable additional keyboard layour (ir) but it says "error activating XKB configuration".

• The result of xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "evdev", "pc105+inet", "us", "", ""
_XKB_RULES_NAMES(STRING) = "evdev", "pc105+inet", "us", "", "grp:alt_shift_toggle"

 • The result of gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd
 layouts = [us,ir]
 options = [grp	grp:alt_shift_toggle,grp	grp:caps_switch]
 model = 


How reproducible:
100%

Steps to Reproduce:
1. install Fedora 14 Beta RC3
2. Try to add a new keyboard layout
  
Actual results:
Error window appears and it doesn't work

Expected results:
You should be able to switch to additional layouts.

Additional info:
Comment 1 Hedayat Vatankhah 2010-09-30 16:36:53 EDT
Apparently there is a bug in the current Iranian layout:
[hedayat@localhost xkb]$ setxkbmap ir
Error loading new keyboard description
Comment 2 Hedayat Vatankhah 2010-09-30 17:01:32 EDT
Created attachment 450888 [details]
Fixes the bug

This small patch fixes the problem. it is caused by extra semicolons.
Comment 3 Hedayat Vatankhah 2010-09-30 18:33:42 EDT
Created attachment 450902 [details]
A patch to make many keys working again

There is still a problem. Apparently, character codes in the symbols files do not work any longer. I've created a patch to make many essential keys working again (using character names instead of their code), but there are still some remaining. Also, this issue does not affect the Iranian keyboard layout only, and it'll probably affect many others too. IMHO, this bug does really need a serious consideration.
Comment 4 Fedora Update System 2010-10-02 16:30:20 EDT
xkeyboard-config-1.9-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/xkeyboard-config-1.9-2.fc14
Comment 5 Jens Petersen 2010-10-04 01:31:14 EDT
I believe this is all fixed upstream in 2.0.

Can we have 2.0 in f14?
Comment 6 Peter Hutterer 2010-10-04 21:02:53 EDT
the two patches that affected anything are in 1.9-2 now. 2.0 includes a bunch of other stuff too, at this point I'd rather not rebase. 2.0 is in rawhide though.
Comment 7 Fedora Update System 2010-10-04 21:23:53 EDT
xkeyboard-config-1.9-3.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/xkeyboard-config-1.9-3.fc14
Comment 8 Peter Hutterer 2010-10-04 21:35:47 EDT
at least in the german keyboard layout, xkeyboard-config-1.9-3.fc14.noarch seem to work for hex codes. This is not the case for you? If so, I need some more specific tests please, my knowledge of the iranian layout is non-existent and I can't tell what's broken.
Comment 9 Fedora Update System 2010-10-05 01:20:58 EDT
xkeyboard-config-1.9-3.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xkeyboard-config'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/xkeyboard-config-1.9-3.fc14
Comment 10 Fedora Update System 2010-10-05 20:34:50 EDT
xkeyboard-config-1.9-6.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/xkeyboard-config-1.9-6.fc14
Comment 11 Hedayat Vatankhah 2010-10-06 01:51:28 EDT
Well, I had a look at the german layout. The german layout uses the hex codes in the form of UXXXX (e.g. U01E9), while in ir layout and many others, these codes are in the form 0x100XXXX. I replaced some 0x100XXXX codes with the equivalent UXXXX code, and it worked fine in ir layout too. I've tried some other layouts with 0x100XXXX hex codes, and they do not work fine too (e.g. try pressing "m" in tj layout. it generates an "m" istead of "ӣ" character. By replacing 0x10004e3 code with U04e3, the correct character is used).

So, it seems that all "0x100" strings should be replaced with "U" in key hex codes of all layouts (probably a sed -i "s/0x100/U/g" symbols/* except for the comments could do the job safely. But it should not corrupt comments either, so IMHO that's somewhat safe to do.)
Comment 12 Hedayat Vatankhah 2010-10-06 02:03:53 EDT
Created attachment 451810 [details]
A patch which will fix the hex codes in ir layout
Comment 13 Fedora Update System 2010-10-08 08:42:08 EDT
xkeyboard-config-1.9-6.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Hedayat Vatankhah 2010-10-08 18:39:00 EDT
IMHO, The problem mentioned in comments #11 and #12 is still there. But maybe it should be reported against another component?!
Comment 15 Hedayat Vatankhah 2010-10-10 03:45:08 EDT
Reopened since the main bug is still there: key codes defined using 0x100XXXX hex codes in *ANY* keyboard layout are broken. Either all 0x100XXXX codes should be replaced with UXXXX codes or the bug should be resolved, or Fedora 14 will be shipped with broken keyboard layouts.
Comment 16 Fedora Update System 2010-10-10 22:05:53 EDT
xorg-x11-xkb-utils-7.4-9.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/xorg-x11-xkb-utils-7.4-9.fc14
Comment 17 Peter Hutterer 2010-10-10 22:07:49 EDT
*** Bug 640915 has been marked as a duplicate of this bug. ***
Comment 18 Fedora Update System 2010-10-10 23:45:08 EDT
xorg-x11-xkb-utils-7.4-9.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xorg-x11-xkb-utils'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/xorg-x11-xkb-utils-7.4-9.fc14
Comment 19 Hedayat Vatankhah 2010-10-11 06:47:13 EDT
Thanks. It's fixed for me using xorg-x11-xkb-utils-7.4-9.
Comment 20 Zdenek Kabelac 2010-10-15 09:34:31 EDT
I'd like to point out - that my rawhide with xkeyboard-config-2.0-1.fc15.noarch still gives me this warning - so is there going to be clone for rawhide?


gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd
 layouts = [us,cz	qwerty]
 options = [grp	grp:alts_toggle,terminate	terminate:ctrl_alt_bksp,grp	grp:rwin_switch,grp_led	grp_led:scroll]
 model = 


xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "evdev", "evdev", "us", "", "terminate:ctrl_alt_bksp"
_XKB_RULES_NAMES(STRING) = "evdev", "evdev", "us", "", "terminate:ctrl_alt_bksp"
Comment 21 Peter Hutterer 2010-10-17 18:22:23 EDT
(In reply to comment #20)
> I'd like to point out - that my rawhide with xkeyboard-config-2.0-1.fc15.noarch
> still gives me this warning - so is there going to be clone for rawhide?

whoops, sorry. forgot about that one. done.

http://koji.fedoraproject.org/koji/taskinfo?taskID=2539675
Comment 22 Zdenek Kabelac 2010-10-18 07:18:44 EDT
Used as update - and still getting this popup widget activation xkb error.

xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "evdev", "evdev", "us", "", "terminate:ctrl_alt_bksp"
_XKB_RULES_NAMES(STRING) = "evdev", "evdev", "us", "", "terminate:ctrl_alt_bksp"


gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd
 layouts = [us,cz	qwerty]
 options = [grp	grp:alts_toggle,terminate	terminate:ctrl_alt_bksp,grp	grp:rwin_switch,grp_led	grp_led:scroll]
 model = 


rpm -qa | grep org-x11-xkb 
xorg-x11-xkb-utils-7.4-9.fc15.x86_64


(Using todays up-to-date Fedora Rawhide)
Comment 23 Peter Hutterer 2010-10-21 22:27:55 EDT
trying to reproduce, but my g-s-d keeps segfaulting (and the control-center too)
Comment 24 Fedora Update System 2010-10-29 16:40:06 EDT
xorg-x11-xkb-utils-7.4-9.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.