Bug 638591 - Ambiguity in logrotate man page (definition of "size" parameter)
Ambiguity in logrotate man page (definition of "size" parameter)
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: logrotate (Show other bugs)
5.3
All Linux
low Severity low
: rc
: ---
Assigned To: Jan Kaluža
qe-baseos-daemons
: ManPageChange
Depends On:
Blocks: 638625 638629 659713
  Show dependency treegraph
 
Reported: 2010-09-29 08:50 EDT by Stanislas RENAN
Modified: 2013-04-12 16:45 EDT (History)
3 users (show)

See Also:
Fixed In Version: logrotate-3.7.4-12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 638625 638629 (view as bug list)
Environment:
Last Closed: 2011-05-18 10:58:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
proposed patch (575 bytes, patch)
2010-09-29 10:35 EDT, Jan Kaluža
no flags Details | Diff

  None (edit)
Description Stanislas RENAN 2010-09-29 08:50:00 EDT
The definition of "size" parameter is ambiguous.

It is defined as :
"Log files are rotated when they grow bigger then size bytes."

It appears the the behaviour is :
"Log files are rotated only if they grow bigger then size bytes."


First definition does not mean that if the file size is below _size_ bytes, it won't be rotated.
Second definition means that if the file size is below _size_ bytes, it won't be rotated.

I find the second definition less confusing and closer to the actual behaviour of logrotate.

I think that the "minsize" parameter may also benefit from a disambiguation.
Comment 1 Jan Kaluža 2010-09-29 10:35:15 EDT
Created attachment 450489 [details]
proposed patch
Comment 2 Jan Kaluža 2010-09-29 10:36:06 EDT
Thank you. Attached patch corrects the man page.
Comment 3 RHEL Product and Program Management 2011-01-11 15:38:00 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 4 RHEL Product and Program Management 2011-01-11 18:01:55 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 9 errata-xmlrpc 2011-05-18 10:58:39 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0816.html

Note You need to log in before you can comment on or make changes to this bug.