Bug 638634 - computer name does not stick on Live CD
computer name does not stick on Live CD
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Radek Vykydal
Fedora Extras Quality Assurance
AcceptedNTH
:
Depends On:
Blocks: F14-accepted/F14FinalFreezeExcept F14AnacondaBlocker
  Show dependency treegraph
 
Reported: 2010-09-29 10:39 EDT by Piscium
Modified: 2013-01-10 01:14 EST (History)
8 users (show)

See Also:
Fixed In Version: anaconda-14.21-1.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-19 18:24:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log (3.94 KB, application/x-lzma)
2010-09-30 15:13 EDT, Piscium
no flags Details
anaconda.program.log (7.92 KB, application/x-lzma)
2010-09-30 15:14 EDT, Piscium
no flags Details

  None (edit)
Description Piscium 2010-09-29 10:39:39 EDT
Description of problem:

Computer name entered during installation is not kept properly. Once installation is complete it reverts to default (localhost).

Version-Release number of selected component (if applicable):

F14 beta, KDE spin, 32 bits.

How reproducible:

I am not sure, I only tried to install this version once. In the Fedora forums another user reported also having this issue.

Steps to Reproduce:
1. During installation choose a computer name other than the default.
2. After installation is complete enter "uname -n"

Actual results:

The name reverts to "localhost".

Expected results:

The name should be what I set it to.
Comment 1 Chris Lumens 2010-09-29 10:45:20 EDT
The name you enter gets written out to a file on the installed system so when you reboot post-installation, it should be fine.  It's not meant to modify the hostname on the running live system.  If you reboot, do you see the proper hostname?
Comment 2 Piscium 2010-09-29 11:02:41 EDT
>        If you reboot, do you see the proper hostname?

No.

---
My bug description could be improved. My second attempt:

Steps to Reproduce:
1. During installation choose a computer name other than the default.
2. Reboot
3. Enter "uname -n" on a terminal
4. See what happens

Actually you don't need even uname. When I started a terminal after reboot the prompt was       
  my_name@localhost 
instead of 
  my_name@the_name_i_gave_to_my_computer_durint_install
Comment 3 Radek Vykydal 2010-09-30 12:51:03 EDT
I am not able to reproduce.
Could you post content of /etc/sysconfig/network, and attach /var/log/anaconda.syslog and /var/log/anaconda.log from installed ststem?
Comment 4 Piscium 2010-09-30 15:10:28 EDT
Today I created a brand new partition, reinstalled the same OS as before (I have it in a USB stick), and got exactly the same issue. So it is reproducible for me (or so it seems after two tests).

---------------

/etc/sysconfig/network:

NETWORKING=yes
NETWORKING_IPV6=no
HOSTNAME=localhost.localdomain
NTPSERVERARGS=iburst

OK, so there is a little inconsistency in my bug description. If I do "uname -n" I get "localhost.localdomain" but the prompt still says for example "root@localhost" as I reported.

------------

/var/log/anaconda.syslog - there is no such file
/var/log/anaconda.log - attached, plus I attached another another log.

------------

I looked at anaconda.log (attached) and found the following line:

==
19:20:10,135 DEBUG anaconda: Exception caught trying to get host name of 192.168.1.3: [Errno 2] Host name lookup failure
==

This might be related to the issue at hand. I looked at the same file in my F13 install and there is no such error message. 192.168.1.3 is the IP address of the PC (the next available from the DNS server which happens to be my DSL router at home).
Comment 5 Piscium 2010-09-30 15:13:27 EDT
Created attachment 450842 [details]
anaconda.log

see comment #4
Comment 6 Piscium 2010-09-30 15:14:32 EDT
Created attachment 450844 [details]
anaconda.program.log

see comment #4
Comment 7 Piscium 2010-09-30 19:24:53 EDT
> This might be related to the issue at hand. I looked at the same file in my F13
> install and there is no such error message. 192.168.1.3 is the IP address of
> the PC (the next available from the DNS server which happens to be my DSL
> router at home).

Oops, I meant _DHCP_ server, obviously.
Comment 8 Radek Vykydal 2010-10-01 12:04:51 EDT
This is on Live CDs only, I sent a patch with fix to anaconda-devel-list.
Comment 9 Scott Dowdle 2010-10-04 11:31:44 EDT
I was seeing this too (hostname entered during install from Live media was ignored) and I'm glad to see both a bug report and a fix already available.
Comment 10 Radek Vykydal 2010-10-06 07:23:44 EDT
Fixed in master (anaconda-15.1-1). For F14, the bug would need to be approved as F14 Blocker.
Comment 11 Piscium 2010-10-06 14:20:36 EDT
I don't think this is a show stopper as it is easily corrected, however it might be worthwhile to mention it in the F14 release notes as a known issue, just so that people don't lose time on it. 

Alternatively it could be worthwhile to post a note about it on one of the mailing lists (devel or test) to see if sysadmins would consider this an important bug, because I think they would be most affected by it (I am not a sysadmin so I cannot judge that).
Comment 12 Adam Williamson 2010-10-06 22:49:35 EDT
"For F14, the bug would need to be approved as F14 Blocker."

No, it doesn't, you can put the fix in 14.18 or 14.19 if you think it's a good thing to have in F14, we are not yet at the point where we only accept blocker fixes.
Comment 13 Scott Dowdle 2010-10-06 23:29:10 EDT
Please backport the fix if at all possible because if the live media installer can't set a hostname it will reflect very poorly on Fedora and make it appear that it can't do even a simple, basic function properly.
Comment 14 Radek Vykydal 2010-10-07 05:03:20 EDT
(In reply to comment #12)
> "For F14, the bug would need to be approved as F14 Blocker."
> 
> No, it doesn't, you can put the fix in 14.18 or 14.19 if you think it's a good
> thing to have in F14, we are not yet at the point where we only accept blocker
> fixes.

Ok, I probably confused it with internal anaconda policy. Anyway I'll ask David Lehman the F14 anaconda gatekeeper if we can get it into the release.
Comment 15 Adam Williamson 2010-10-07 11:32:11 EDT
radek: sure, I know anaconda team has its own policies, let me know if you have one which would block taking this fix. we can propose the bug as a nice-to-have if necessary.
Comment 16 Radek Vykydal 2010-10-08 07:19:00 EDT
Proposing as F14 Blocker with hope for Nice To Have.

The patch in master:

http://git.fedorahosted.org/git/?p=anaconda.git;a=commit;h=5161a324ad2cf2be636a6cd330390e7f05971
Comment 17 Radek Vykydal 2010-10-08 08:45:06 EDT
Proposing as nice-to-have.
Comment 18 Adam Williamson 2010-10-08 11:41:41 EDT
+1 from me.
Comment 19 Adam Williamson 2010-10-08 14:25:08 EDT
Discussed at 2010-10-08 blocker/NTH review meeting, accepted as NTH. Please take the fix into the F14 anaconda branch.
Comment 20 Nathan Thomas 2010-10-09 11:38:35 EDT
I am also experiencing this bug, it's good to know a fix is in the works!

Is there any way to fix the problem on an already installed system? I tried using the hostname command to change the computer name, but on reboot this still reverted back to localhost.

Best wishes
Nathan
Comment 21 Adam Williamson 2010-10-09 13:01:42 EDT
system-config-network , DNS tab.
Comment 22 Piscium 2010-10-09 17:37:22 EDT
(In reply to comment #21)
> system-config-network , DNS tab.

Besides the above I would suggest taking a look at /etc/hosts, due to a bug in NetworkManager (I am not sure if it has been fixed yet).
Comment 23 Radek Vykydal 2010-10-11 08:24:42 EDT
This should be fixed in anaconda 14.19-1.
Comment 24 Piscium 2010-10-11 14:53:17 EDT
(In reply to comment #23)
> This should be fixed in anaconda 14.19-1.

Good that it was fixed. As the saying goes, one has only one chance to make a good first impression, and if something goes funny in anaconda that's not nice for first time users, even if it is just a minority that chooses a host name.

And thanks to Adam for taking the issue to the bug review meeting and taking care of it.
Comment 25 Fedora Update System 2010-10-11 17:46:49 EDT
anaconda-14.19-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/anaconda-14.19-1.fc14
Comment 26 Fedora Update System 2010-10-11 22:38:11 EDT
anaconda-14.19-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update anaconda'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/anaconda-14.19-1.fc14
Comment 27 Sandro Mathys 2010-10-14 16:26:14 EDT
I can confirm this is fixed in the F14 Final TC1.1 x86_64 KDE LiveCD. uname -n returns the hostname I set manually within anaconda.
Comment 28 Fedora Update System 2010-10-14 19:57:21 EDT
anaconda-14.20-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/anaconda-14.20-1.fc14
Comment 29 Fedora Update System 2010-10-15 00:09:06 EDT
anaconda-14.20-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update anaconda'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/anaconda-14.20-1.fc14
Comment 30 Adam Williamson 2010-10-18 21:04:23 EDT
The fix is confirmed, setting VERIFIED, can be closed when anaconda goes stable.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 31 Fedora Update System 2010-10-18 23:23:05 EDT
anaconda-14.21-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/anaconda-14.21-1.fc14
Comment 32 Fedora Update System 2010-10-19 05:07:22 EDT
anaconda-14.21-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update anaconda'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/anaconda-14.21-1.fc14
Comment 33 Fedora Update System 2010-10-19 18:23:57 EDT
anaconda-14.21-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 34 Scott Dowdle 2010-10-20 18:13:47 EDT
Just rebuilt my Fedora 14 (devel) remix with all of the updates and noticed that the bug is fixed... and works for me.  Also noticed a number other other bug fixes (default background in KDE is no longer solid black).  Good job.

Thanks for fixing this bug in time for release!

Note You need to log in before you can comment on or make changes to this bug.