Bug 638673 - Evince Slow and cannot read PDF files
Summary: Evince Slow and cannot read PDF files
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dconf
Version: 14
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 638708
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-09-29 15:53 UTC by JCHuynh
Modified: 2010-10-01 12:21 UTC (History)
7 users (show)

Fixed In Version: dconf-0.5.1-1.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-10-01 12:21:42 UTC


Attachments (Terms of Use)

Description JCHuynh 2010-09-29 15:53:58 UTC
Description of problem:
Start program very slow and cannot open pdf (need to force quitting).

Version-Release number of selected component (if applicable):
Document Viewer 2.31.92

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:
Very slow and cannot read pdf files

Expected results:
Fast as it does on Fedora 13

Additional info:

Comment 1 Michael Schwendt 2010-09-29 18:46:32 UTC
Reproducible with i686 installation. 

Encountered after Sep 29th [test-]updates. I'm sure it had worked a day before that.

Terminal is filled with lots of:

(evince:3941): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed

** (evince:3941): WARNING **: Error registering document: Timeout was reached

GConf Error: Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://projects.gnome.org/gconf/ for information. (Details -  1: GetIOR failed: Timeout was reached)

Comment 2 Tomáš Bžatek 2010-09-30 14:21:52 UTC
(In reply to comment #1)
> (evince:3941): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT
> (object)' failed
> 
> ** (evince:3941): WARNING **: Error registering document: Timeout was reached
> 
> GConf Error: Failed to contact configuration server; some possible causes are
> that you need to enable TCP/IP networking for ORBit, or you have stale NFS
> locks due to a system crash. See http://projects.gnome.org/gconf/ for
> information. (Details -  1: GetIOR failed: Timeout was reached)

Can you break at g_log in gdb and grab a backtrace?

Comment 3 Bill Nottingham 2010-09-30 17:53:00 UTC
#0  g_log (log_domain=0x7ffff7000344 "GLib-GObject", log_level=G_LOG_LEVEL_CRITICAL, 
    format=0x7ffff653c838 "%s: assertion `%s' failed") at gmessages.c:573
#1  0x00007ffff72b9715 in message_to_write_data_free (data=0x8b2900)
    at gdbusprivate.c:879
#2  0x00007ffff72bb592 in maybe_write_next_message (worker=0x6eac30)
    at gdbusprivate.c:1305
#3  0x00007ffff72bb653 in write_message_in_idle_cb (user_data=<value optimized out>)
    at gdbusprivate.c:1347
#4  0x00007ffff64d1e33 in g_main_dispatch (context=0x6eb760) at gmain.c:2149
#5  g_main_context_dispatch (context=0x6eb760) at gmain.c:2702
#6  0x00007ffff64d2610 in g_main_context_iterate (context=0x6eb760, block=1, 
    dispatch=1, self=<value optimized out>) at gmain.c:2780
#7  0x00007ffff64d2c82 in g_main_loop_run (loop=0x703920) at gmain.c:2988
#8  0x00007ffff72b9774 in gdbus_shared_thread_func (data=<value optimized out>)
    at gdbusprivate.c:277
#9  0x00007ffff64f9446 in g_thread_create_proxy (data=0x6eb840) at gthread.c:1897
#10 0x00007ffff5ff5d5b in start_thread (arg=0x7fffeecd6710) at pthread_create.c:301
#11 0x00007ffff5d2fe1d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Comment 4 Bill Nottingham 2010-09-30 18:18:48 UTC
This is due to:

static void
message_to_write_data_free (MessageToWriteData *data)
{
  _g_dbus_worker_unref (data->worker);
  g_object_unref (data->message);  
  g_free (data->blob);
  g_free (data);
}

...

     else if (data->message == NULL)
        {
...
          message_to_write_data_free (data);
...

but I don't think this is what's causing the problem.

Comment 5 Bill Nottingham 2010-09-30 19:26:00 UTC
git bisect narrows down the failure to:

c3371efcaa47b03941c6c8148687b0a21d18dfbe is the first bad commit
commit c3371efcaa47b03941c6c8148687b0a21d18dfbe
Author: David Zeuthen <davidz@redhat.com>
Date:   Thu Sep 9 13:21:35 2010 -0400

    Bug 624546 – Modification of GDBusMessage in filter function
    
    Rework filter functions as per
    
     https://bugzilla.gnome.org/show_bug.cgi?id=624546#c8
    
    This commit breaks ABI. However, this ABI break affects only
    applications using filter functions. The only known user of is dconf.
    
    Signed-off-by: David Zeuthen <davidz@redhat.com>

Comment 6 Bill Nottingham 2010-09-30 19:34:50 UTC
Hah. 'The only known user of is dconf'.

Updating to dconf-0.5.1 fixes this. In progress..

Comment 7 Fedora Update System 2010-09-30 20:08:58 UTC
glib2-2.26.0-2.fc14,dconf-0.5.1-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/glib2-2.26.0-2.fc14,dconf-0.5.1-1.fc14

Comment 8 Fedora Update System 2010-09-30 21:18:11 UTC
dconf-0.5.1-1.fc14, glib2-2.26.0-2.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update dconf glib2'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/glib2-2.26.0-2.fc14,dconf-0.5.1-1.fc14

Comment 9 Fedora Update System 2010-10-01 12:21:32 UTC
dconf-0.5.1-1.fc14, glib2-2.26.0-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.