Bug 638708 - glib2 2.26.0-1.fc14 broke evince
Summary: glib2 2.26.0-1.fc14 broke evince
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: glib2
Version: 14
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 639038 (view as bug list)
Depends On:
Blocks: 638673
TreeView+ depends on / blocked
 
Reported: 2010-09-29 17:55 UTC by hannes
Modified: 2018-04-11 06:58 UTC (History)
7 users (show)

Fixed In Version: dconf-0.5.1-1.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-10-01 12:21:38 UTC


Attachments (Terms of Use)

Description hannes 2010-09-29 17:55:37 UTC
Description of problem:
Since the update to this version evince wasn't able to open up quick and display pdfs. The following output was generated by a start of evince:
evince wbt01.pdf 

(evince:2186): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed

(evince:2186): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed

(evince:2186): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed

(evince:2186): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed



Version-Release number of selected component (if applicable):
2.26.0-1.fc14

How reproducible:
Everytime

Steps to Reproduce:
Opening of any pdf file.
  
Actual results:
Slow and sometimes no loading of any pdf.

Expected results:
Fast and reliable start with any pdf

Additional info:
After I downgraded to glib2.x86_64 0:2.25.15-1.fc14 with yum downgrade glib2* everything works as before.

Comment 1 hannes 2010-09-30 05:31:52 UTC
I installed evince from koji: http://koji.fedoraproject.org/koji/buildinfo?buildID=197416 

After that I updated glib2 once again but the issue persisted.

Comment 2 Aron Parsons 2010-09-30 14:45:45 UTC
Same issue here.  Downgrading to 2.25.15-1 fixed the issue for me as well.

Comment 3 Fedora Update System 2010-09-30 19:14:28 UTC
glib2-2.26.0-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/glib2-2.26.0-2.fc14

Comment 4 Fedora Update System 2010-09-30 21:18:06 UTC
dconf-0.5.1-1.fc14, glib2-2.26.0-2.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update dconf glib2'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/glib2-2.26.0-2.fc14,dconf-0.5.1-1.fc14

Comment 5 Matěj Cepl 2010-10-01 06:23:03 UTC
*** Bug 639038 has been marked as a duplicate of this bug. ***

Comment 6 Fedora Update System 2010-10-01 12:21:28 UTC
dconf-0.5.1-1.fc14, glib2-2.26.0-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.