This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 638694 - Assertion head_size <= 63 at dos.c:678 in function probe_partition_for_geom()
Assertion head_size <= 63 at dos.c:678 in function probe_partition_for_geom()
Status: CLOSED DUPLICATE of bug 585468
Product: Fedora
Classification: Fedora
Component: parted (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-29 12:58 EDT by Brian Lane
Modified: 2010-09-30 11:26 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-30 11:26:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Brian Lane 2010-09-29 12:58:29 EDT
Description of problem:
Running parted on a USB Flash drive failed with this:


[bcl@lister ~]$ sudo parted /dev/sdd unit co print unit s print
Backtrace has 13 calls on stack:
  13: /lib64/libparted-2.1.so.0(ped_assert+0x31) [0x33f3e11fb1]
  12: /lib64/libparted-2.1.so.0() [0x33f3e3b6f6]
  11: /lib64/libparted-2.1.so.0() [0x33f3e3be6e]
  10: /lib64/libparted-2.1.so.0() [0x33f3e3cb0d]
  9: /lib64/libparted-2.1.so.0(ped_disk_add_partition+0x1cb) [0x33f3e1864b]
  8: /lib64/libparted-2.1.so.0() [0x33f3e3df85]
  7: /lib64/libparted-2.1.so.0() [0x33f3e3e155]
  6: /lib64/libparted-2.1.so.0(ped_disk_new+0x75) [0x33f3e19115]
  5: parted() [0x40692c]
  4: parted(non_interactive_mode+0x8c) [0x40c73c]
  3: parted(main+0x63) [0x40aaa3]
  2: /lib64/libc.so.6(__libc_start_main+0xfd) [0x33f2e1ec5d]
  1: parted() [0x404f49]
                                                                          
fdisk shows this about the device:

[bcl@lister ~]$ sudo fdisk /dev/sdd

WARNING: DOS-compatible mode is deprecated. It's strongly recommended to
         switch off the mode (command 'c') and change display units to
         sectors (command 'u').

Command (m for help): p

Disk /dev/sdd: 4005 MB, 4005560320 bytes
21 heads, 21 sectors/track, 17740 cylinders
Units = cylinders of 441 * 512 = 225792 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xeb7cdde8

   Device Boot      Start         End      Blocks   Id  System
/dev/sdd1   *          19       17741     3907648    c  W95 FAT32 (LBA)


Version-Release number of selected component (if applicable):
parted-2.1-8.fc13.x86_64

How reproducible:
Unable to reproduce. Once I removed the partition parted read it w/o crashing.
Comment 1 Fedora Admin XMLRPC Client 2010-09-30 09:37:48 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 2 Brian Lane 2010-09-30 11:26:43 EDT

*** This bug has been marked as a duplicate of bug 585468 ***

Note You need to log in before you can comment on or make changes to this bug.