Bug 585468 - Assertion head_size <= 63 at dos.c:678 in function probe_partition_for_geom()
Summary: Assertion head_size <= 63 at dos.c:678 in function probe_partition_for_geom()
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: parted   
(Show other bugs)
Version: 13
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Brian Lane
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 638694 675138 684399 702654 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-24 08:54 UTC by Florian Sievert
Modified: 2011-06-14 23:25 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-12 01:36:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Florian Sievert 2010-04-24 08:54:56 UTC
Description of problem:
when using gparted or parted on a fresh usb stick, it crashs with the following trace:
gparted /dev/sdf 
======================
libparted : 2.1
======================
Backtrace has 15 calls on stack:
  15: /lib64/libparted-2.1.so.0(ped_assert+0x31) [0x37f4011f61]
  14: /lib64/libparted-2.1.so.0() [0x37f403b6a6]
  13: /lib64/libparted-2.1.so.0() [0x37f403be1e]
  12: /lib64/libparted-2.1.so.0() [0x37f403cabd]
  11: /lib64/libparted-2.1.so.0(ped_disk_add_partition+0x1cb) [0x37f40185fb]
  10: /lib64/libparted-2.1.so.0() [0x37f403df31]
  9: /lib64/libparted-2.1.so.0() [0x37f403e0d5]
  8: /lib64/libparted-2.1.so.0(ped_disk_new+0x75) [0x37f40190c5]
  7: /usr/sbin/gpartedbin() [0x446b44]
  6: /usr/sbin/gpartedbin() [0x45644c]
  5: /usr/sbin/gpartedbin() [0x46fd07]
  4: /usr/lib64/libglibmm-2.4.so.1() [0x37f5434acd]
  3: /lib64/libglib-2.0.so.0() [0x37edc64e84]
  2: /lib64/libpthread.so.0() [0x37ecc07951]
  1: /lib64/libc.so.6(clone+0x6d) [0x37ec4e4d3d]
Assertion (head_size <= 63) at dos.c:677 in function probe_partition_for_geom() failed.


GParted crashs immedently, parted crashs after an operation like toogle.

Version-Release number of selected component (if applicable):
gparted.x86_64                                                                                    0.5.2-1.fc13                                                                                @fedora         
parted.x86_64                                                                                     2.1-7.fc13                                                                                  @updates-testing

How reproducible:
Always

Steps to Reproduce:
1. gparted /dev/sdf (an 4 GB usb stick)
  
Actual results:
Gparted crashs

Expected results:
Gparted shows up

Additional info:
The problem is not reproducable when being performed on the harddisks of the system.

Disk /dev/sdf: 4007 MB, 4007657472 bytes
86 heads, 22 sectors/track, 4137 cylinders
Units = cylinders of 1892 * 512 = 968704 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

   Device Boot      Start         End      Blocks   Id  System
/dev/sdf1               5        4138     3909696    c  W95 FAT32 (LBA)

Comment 1 Deji Akingunola 2010-07-20 15:13:17 UTC
Sorry for not noticing this much much earlier. Seems to be a parted bug (?), re-assigning.

Comment 2 Hans de Goede 2010-07-20 15:18:47 UTC
The problem is that this usb stick is reporting 86 heads, which is just plain out of spec, a disk cannot have more then 63 heads.

This is likely caused by some bogus partition table on there, try:
dd if=/dev/zero of=/dev/sdf bs=1024 count=1024

Then unplug and replug the usb stick, and see if things are better now.

Note this will destroy the partition table and thus any data on the stick!!

Comment 3 Fedora Admin XMLRPC Client 2010-09-30 13:37:50 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 4 Brian Lane 2010-09-30 15:26:43 UTC
*** Bug 638694 has been marked as a duplicate of this bug. ***

Comment 5 Brian Lane 2011-02-09 19:04:08 UTC
*** Bug 675138 has been marked as a duplicate of this bug. ***

Comment 6 Brian Lane 2011-03-01 00:22:17 UTC
parted needs to stop using PED_ASSERT for partitions where it cannot calculate a CHS value. See http://lists.alioth.debian.org/pipermail/parted-devel/2011-February/003805.html

Comment 7 Brian Lane 2011-03-12 15:29:57 UTC
*** Bug 684399 has been marked as a duplicate of this bug. ***

Comment 8 Fedora Update System 2011-05-26 21:06:59 UTC
parted-2.3-9.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/parted-2.3-9.fc15

Comment 9 Brian Lane 2011-06-14 23:25:10 UTC
*** Bug 702654 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.