Bug 638788 - anaconda claims no repo on hard disk install
anaconda claims no repo on hard disk install
Status: CLOSED DUPLICATE of bug 627789
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-29 18:55 EDT by Tom Horsley
Modified: 2010-09-30 09:59 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-30 09:59:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log (11.18 KB, text/plain)
2010-09-29 18:57 EDT, Tom Horsley
no flags Details
anaconda-yum.conf (367 bytes, text/plain)
2010-09-29 18:58 EDT, Tom Horsley
no flags Details
program.log (83.93 KB, text/plain)
2010-09-29 18:58 EDT, Tom Horsley
no flags Details
storage.log (251.57 KB, text/plain)
2010-09-29 18:59 EDT, Tom Horsley
no flags Details
storage.state (28.00 KB, text/plain)
2010-09-29 18:59 EDT, Tom Horsley
no flags Details
syslog (85.43 KB, text/plain)
2010-09-29 18:59 EDT, Tom Horsley
no flags Details
yum.log (946 bytes, text/plain)
2010-09-29 19:01 EDT, Tom Horsley
no flags Details

  None (edit)
Description Tom Horsley 2010-09-29 18:55:01 EDT
Description of problem:

Trying to do a hard disk install of released F14 Beta x86_64 DVD iso image,
I get a ways into the install process, formatting the partition and selecting
the grub install location, then I get an error popup that says:

Error Setting Up Repository
(16,'Device or resource busy')
Please provide correct information for installing Fedora
                           [OK]

I hit OK (not because it is OK, but because it is my only choice :-).

That takes me to a Edit Repository dialog which only offers HTTP/FTP,
CD/DVD, and NFS as choices (so I have no idea how to tell it the hard
disk repo location).

The grub entry I booted to start the installer looks like:

title Install Fedora 14 Beta x86_64
	root (hd0,6)
	kernel /boot/f14x/vmlinuz repo=hd:LABEL=BACKUP:/iso-images/Fedora-14-Beta-x86_64-DVD/
	initrd /boot/f14x/initrd.img

The directory on the BACKUP disk looks like:

[root@zooty ~]# ls -lR /backup/iso-images/Fedora-14-Beta-x86_64-DVD/
/backup/iso-images/Fedora-14-Beta-x86_64-DVD/:
total 3496032
-rw-r--r-- 1 tom users       1616 Sep 28 17:13 Fedora-14-Beta-x86_64-CHECKSUM
-rw-r--r-- 1 tom users 3579226112 Sep 28 20:52 Fedora-14-Beta-x86_64-DVD.iso
drwxr-xr-x 2 tom users       4096 Sep 29 18:07 images/

/backup/iso-images/Fedora-14-Beta-x86_64-DVD/images:
total 153816
-rw-r--r-- 1 tom users 157347840 Sep 29 18:07 install.img

Version-Release number of selected component (if applicable):

Whatever was shipped on the f14 beta x86_64 DVD.

How reproducible:

Only tried it once, but it sure looks like it would happen again.

Steps to Reproduce:
1.see above
2.
3.
  
Actual results:
error dialog

Expected results:
installing fedora from hard disk

Additional info:
The LABEL=BACKUP disk is a external USB hard disk. Maybe it failed to wait for
the disk to spin up? I'll try it again with the iso and images directory
on one of my sata disks.

I copied all the logs out of /tmp before rebooting out of the installer. I'll
attach them.
Comment 1 Tom Horsley 2010-09-29 18:57:31 EDT
Created attachment 450614 [details]
anaconda.log
Comment 2 Tom Horsley 2010-09-29 18:58:05 EDT
Created attachment 450615 [details]
anaconda-yum.conf
Comment 3 Tom Horsley 2010-09-29 18:58:33 EDT
Created attachment 450616 [details]
program.log
Comment 4 Tom Horsley 2010-09-29 18:59:01 EDT
Created attachment 450617 [details]
storage.log
Comment 5 Tom Horsley 2010-09-29 18:59:26 EDT
Created attachment 450618 [details]
storage.state
Comment 6 Tom Horsley 2010-09-29 18:59:48 EDT
Created attachment 450619 [details]
syslog
Comment 7 Tom Horsley 2010-09-29 19:01:59 EDT
Created attachment 450620 [details]
yum.log
Comment 8 Tom Horsley 2010-09-29 19:17:58 EDT
I just tried the same install from my sata disk and got same results, so I guess
USB hard disk has nothing to do with it.
Comment 9 Tom Horsley 2010-09-29 21:17:45 EDT
This thread:

http://lists.fedoraproject.org/pipermail/test/2010-September/093949.html

Looks like the same problem. I didn't setup the network, so it didn't
fall back on any network repo.

I finally did install via mounting the DVD iso in /var/www/http on another
system and doing a network install from there.
Comment 10 Chris Lumens 2010-09-30 09:59:15 EDT

*** This bug has been marked as a duplicate of bug 627789 ***

Note You need to log in before you can comment on or make changes to this bug.