Bug 638811 - Publican documentation: missing language argument in 6.2. The home page.
Summary: Publican documentation: missing language argument in 6.2. The home page.
Status: CLOSED DUPLICATE of bug 614259
Alias: None
Product: Publican
Classification: Community
Component: publican (Show other bugs)
(Show other bugs)
Version: 1.6
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Ruediger Landmann
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-09-30 01:58 UTC by Andrew Ross
Modified: 2013-10-20 22:20 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-01 00:40:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Andrew Ross 2010-09-30 01:58:02 UTC
Description of problem: Step 8 fails due to missing langs arg.

" If you are building your website manually, build the home page in single-page HTML format with the --embedtoc option and install it in your website structure. For example:

publican build --publish --formats html-single --embedtoc"

ERROR: $ publican build --publish --formats html-single --embedtoc 
langs is a mandatory argument at /usr/bin/publican line 622

FIX: add "--langs en-US" (or other suitable lang)

Version-Release number of selected component (if applicable):
publican-doc-2.1-0.fc13.noarch

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Andrew Ross 2010-09-30 02:29:15 UTC
Missing html as a format :)

6.3.1. Installing, updating and removing documents manually

"optionally, include any or all of the following formats in a comma-separated list: html-single, pdf, and epub. "

Comment 2 Ruediger Landmann 2010-09-30 04:42:26 UTC
(In reply to comment #1)
> Missing html as a format :)
> 
> 6.3.1. Installing, updating and removing documents manually
> 
> "optionally, include any or all of the following formats in a comma-separated
> list: html-single, pdf, and epub. "

No, this is in the previous sentence:

"You must include html as one of the formats in the publican build; optionally, include any or all of the following formats in a comma-separated list: html-single, pdf, and epub. "

Comment 4 Ruediger Landmann 2010-10-01 00:40:10 UTC

*** This bug has been marked as a duplicate of bug 614259 ***


Note You need to log in before you can comment on or make changes to this bug.