This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 638995 - abrt-hook-ccpp[7975]: segfault at 0 ip 009b37f0 sp bffce538 error 4 in libc-2.12.1.so[93c000+185000]
abrt-hook-ccpp[7975]: segfault at 0 ip 009b37f0 sp bffce538 error 4 in libc-2...
Status: CLOSED DUPLICATE of bug 652338
Product: Fedora
Classification: Fedora
Component: abrt (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Jiri Moskovcak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-30 11:09 EDT by Orion Poplawski
Modified: 2015-02-01 17:52 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-15 13:35:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2010-09-30 11:09:10 EDT
Description of problem:

A segfault in a local package of ours seems to be triggering a segfault in abrt-hook-ccpp:

Sep 29 15:42:35 marie kernel: kftp[7813]: segfault at 4 ip 0806ab42 sp bfe88cb8 error 4 in kftp[8048000+163000]
Sep 29 15:42:35 marie kernel: abrt-hook-ccpp[7817]: segfault at 0 ip 009b37f0 sp bf9c21e8 error 4 in libc-2.12.1.so[93c000+185000]
Sep 29 15:42:35 marie kernel: Process 7817(abrt-hook-ccpp) has RLIMIT_CORE set to 1
Sep 29 15:42:35 marie kernel: Aborting core
Sep 29 15:42:36 marie abrt[7859]: saved core dump of pid 7857 (/opt/krb5/bin/kftp) to /var/spool/abrt/ccpp-1285796556-7857.new/coredump (516096 bytes)
Sep 29 15:42:36 marie abrtd: Directory 'ccpp-1285796556-7857' creation detected
Sep 29 15:42:36 marie abrtd: Package 'hpcmp-krb5' isn't signed with proper key
Sep 29 15:42:36 marie abrtd: Corrupted or bad crash /var/spool/abrt/ccpp-1285796556-7857 (res:5), deleting
Sep 29 15:42:36 marie abrt[7900]: not dumping repeating crash in '/opt/krb5/bin/kftp'
Sep 29 15:42:37 marie kernel: kftp[7973]: segfault at 4 ip 0806ab42 sp bfee3658 error 4 in kftp[8048000+163000]
Sep 29 15:42:37 marie kernel: abrt-hook-ccpp[7975]: segfault at 0 ip 009b37f0 sp bffce538 error 4 in libc-2.12.1.so[93c000+185000]
Sep 29 15:42:37 marie kernel: Process 7975(abrt-hook-ccpp) has RLIMIT_CORE set to 1
Sep 29 15:42:37 marie kernel: Aborting core
Sep 29 15:42:38 marie kernel: kftp[8017]: segfault at 4 ip 0806ab42 sp bfc505e8 error 4 in kftp[8048000+163000]
Sep 29 15:42:38 marie abrt[8019]: not dumping repeating crash in '/opt/krb5/bin/kftp'
Sep 29 15:42:39 marie abrt[8062]: not dumping repeating crash in '/opt/krb5/bin/kftp'
Sep 29 15:42:39 marie abrt[8102]: not dumping repeating crash in '/opt/krb5/bin/kftp'

Version-Release number of selected component (if applicable):
abrt-1.1.13-2.fc13.i686
Comment 1 Brian 2010-11-14 22:52:39 EST
Orion, abrt is the "Automatic Bug Reporting Tool" and it picked up on the dump of your kftp binary which crashed.

kftp wasn't part of an RPM signed by the Fedora gpg keys, so it did not report the crash back to the Fedora Project.

Look at the config in /etc/abrt/abrt.conf to learn more.

Now here is where I'd normally tell you to look at your kftp app and find out what it's doing wrong or to update it, but I'm having this libc-2.12.1.so crash as well with different applications as well in Fedora 13.  So far, zfs-fuse and libvirtd.

http://groups.google.com/group/zfs-fuse/browse_thread/thread/7e897ebf6acadc82


What hardware is this on?
Comment 2 Orion Poplawski 2010-11-15 11:20:58 EST
Dell Precision WorkStation 360

cpu family      : 15
model           : 2
model name      : Intel(R) Pentium(R) 4 CPU 2.40GHz
stepping        : 9
cpu MHz         : 2400.000
Comment 3 Brian 2010-11-15 13:28:38 EST
Well, that's a dead end.

The only odd thing that I'm doing is running a 2.6.36.1 kernel.  Is there any chance you're running 2.6.36 ?
Comment 4 Orion Poplawski 2010-11-15 13:35:01 EST
Looks like it is fixed as of Oct 20.
Comment 5 Jiri Moskovcak 2010-11-15 13:41:19 EST

*** This bug has been marked as a duplicate of bug 652338 ***

Note You need to log in before you can comment on or make changes to this bug.