Bug 652338 - Machine keeps crashing out of X and resetting to logon screen - abrt-hook-ccpp against libc-2.12.90 in dmesg
Machine keeps crashing out of X and resetting to logon screen - abrt-hook-ccp...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
14
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Jiri Moskovcak
Fedora Extras Quality Assurance
:
: 638995 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-11 12:01 EST by Anthony Name
Modified: 2015-02-01 17:53 EST (History)
11 users (show)

See Also:
Fixed In Version: abrt-1.1.14-1.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-19 08:06:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Zipped file of Xorg crash (12.19 KB, application/zip)
2010-11-19 01:42 EST, Anthony Name
no flags Details

  None (edit)
Description Anthony Name 2010-11-11 12:01:03 EST
Description of problem:
New Fedora 14 Build keeps crashing out of X and resetting to logon screen.

Version-Release number of selected component (if applicable):
glibc 2-12-89.18

How reproducible:
Login and wait for between 30 and 90 seconds, machine resets to logon screen.

Steps to Reproduce:
1. Login
2. Wait
3.
  
Actual results:
Constant resets of X

Expected results:
Should be able to stay in a session.

Additional info:

[  248.795723] fuse init (API version 7.14)
[  248.811237] SELinux: initialized (dev fusectl, type fusectl), uses genfs_contexts
[  248.854981] SELinux: initialized (dev fuse, type fuse), uses genfs_contexts
[  303.652627] abrt-hook-ccpp[2285]: segfault at 0 ip 0000003bc892d5df sp 00007fff170795d8 error 4 in libc-2.12.90.so[3bc8800000+199000]
[  303.652666] Process 2285(abrt-hook-ccpp) has RLIMIT_CORE set to 1
[  303.652670] Aborting core
[  330.936268] SELinux: initialized (dev fuse, type fuse), uses genfs_contexts
[  384.247167] abrt-hook-ccpp[2773]: segfault at 0 ip 0000003bc892d5df sp 00007fffaf57d538 error 4 in libc-2.12.90.so[3bc8800000+199000]
[  384.247189] Process 2773(abrt-hook-ccpp) has RLIMIT_CORE set to 1
[  384.247190] Aborting core
[  407.814651] SELinux: initialized (dev fuse, type fuse), uses genfs_contexts
[  531.218084] abrt-hook-ccpp[3274]: segfault at 0 ip 0000003bc892d5df sp 00007ffff993dff8 error 4 in libc-2.12.90.so[3bc8800000+199000]
[  531.218123] Process 3274(abrt-hook-ccpp) has RLIMIT_CORE set to 1
[  531.218126] Aborting core
[  559.775928] SELinux: initialized (dev fuse, type fuse), uses genfs_contexts
[  613.704335] abrt-hook-ccpp[3775]: segfault at 0 ip 0000003bc892d5df sp 00007fff711d66a8 error 4 in libc-2.12.90.so[3bc8800000+199000]
[  613.704373] Process 3775(abrt-hook-ccpp) has RLIMIT_CORE set to 1
[  613.704375] Aborting core
[  687.485981] SELinux: initialized (dev fuse, type fuse), uses genfs_contexts
[  800.333427] abrt-hook-ccpp[4303]: segfault at 0 ip 0000003bc892d5df sp 00007fff8289aed8 error 4 in libc-2.12.90.so[3bc8800000+199000]
[  800.333463] Process 4303(abrt-hook-ccpp) has RLIMIT_CORE set to 1
[  800.333466] Aborting core
[  985.914071] SELinux: initialized (dev fuse, type fuse), uses genfs_contexts
[ 1112.959985] abrt-hook-ccpp[4830]: segfault at 0 ip 0000003bc892d5df sp 00007fffabfb7418 error 4 in libc-2.12.90.so[3bc8800000+199000]
[ 1112.960006] Process 4830(abrt-hook-ccpp) has RLIMIT_CORE set to 1
[ 1112.960007] Aborting core
Comment 1 Anthony Name 2010-11-11 12:05:28 EST
Apologies a typo in above....

glibc 2-12-89.18  should read glibc 2-12-90.18
Comment 2 Jiri Moskovcak 2010-11-12 07:01:54 EST
This is a known bug and we have a fix for it, should be in a repo soon.
Comment 3 Anthony Name 2010-11-12 08:37:42 EST
Jim

Could you let me know which bug it's a duplicate of and I'll track both.

Thanks
Comment 4 Anthony Name 2010-11-15 07:52:19 EST
Jiri (sorry I misread your name previously)

I've tried the glibc 2-12-90.19 from testing repo as suggested in the other bug report and it has NOT fixed my problem.

I'm going to post this in the other bug report as well.

Regards
Comment 5 Jiri Moskovcak 2010-11-15 13:41:20 EST
*** Bug 638995 has been marked as a duplicate of this bug. ***
Comment 6 Jiri Moskovcak 2010-11-15 13:46:46 EST
This is not a glibc problem, it's a bug in abrt-hook-ccpp, it doesn't handle the situation when /proc/<PID>/exe doesn't exist.

If I remember it correctly, /proc/<PID>/exe should exist until the hook exits,
but there has to be a non-zero value in /proc/sys/kernel/core_pipe_limit and
the number of the hooks running simultaneously must not be bigger then the
value of core_pipe_limit. But abrt-hook-ccpp should handle this situation
gracefully.
Comment 7 Anthony Name 2010-11-15 16:08:54 EST
OK

But surely the abrt is getting called by an underlying bug?  I thought abrt was the bug reporting system?

Is there anything I can do to add useful information to the report?

Regards
Comment 8 Jiri Moskovcak 2010-11-16 05:03:21 EST
(In reply to comment #7)
> OK
> 
> But surely the abrt is getting called by an underlying bug?  I thought abrt was
> the bug reporting system?
> 

Yes, the problem is, that abrt is trying to read /proc/<PID>/exe where <PID> is pid of the crashed process and if there is more crashing programs then the limit set in /proc/sys/kernel/core_pipe_limit (4 by default) then kernel doesn't wait for abrt and removes the /proc/<PID>/ directory and abrt crashes because it expect that directory to be there and doesn't handle that situation well.

> Is there anything I can do to add useful information to the report?

We have a fix for this already and I will create an update asap (probably today) so then you can give it some karma if you want to test it..

> 
> Regards
Comment 9 Anthony Name 2010-11-16 11:33:07 EST
OK

Let me know if yu want me to test it, the box is currently pretty uncontaminated with regards to non core applications.

Regards
Comment 10 Fedora Update System 2010-11-17 15:04:51 EST
abrt-1.1.14-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/abrt-1.1.14-1.fc14
Comment 11 Fedora Update System 2010-11-17 15:27:00 EST
abrt-1.1.14-1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/abrt-1.1.14-1.fc13
Comment 12 Fedora Update System 2010-11-18 19:07:00 EST
abrt-1.1.14-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update abrt'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/abrt-1.1.14-1.fc14
Comment 13 Anthony Name 2010-11-19 00:27:16 EST
OK I installed the abrt update above.  This has stopped the error message but hasn't got rid of the underlying problem.

Now I get nothing in dmesg after crashing out of Xorg, also there's nothing in Xorg.0.log.  However /var/log/messages throws the following where there is an abrt message about halfway down the list.  I logged into the Xorg session here at 04:57:54 and got thrown out at the end of this message block.

Any ideas?

Nov 19 04:45:27 thismachine rtkit-daemon[1781]: Successfully made thread 2938 of process 2935 (/usr/bin/pulseaudio) owned by '42' RT at priority 5.
Nov 19 04:45:27 thismachine gdm-simple-greeter[2925]: Gtk-WARNING: gtkwidget.c:5691: widget not within a GtkWindow
Nov 19 04:45:27 thismachine gdm-simple-greeter[2925]: WARNING: Unable to load CK history: no seat-id found
Nov 19 04:45:27 thismachine rtkit-daemon[1781]: Successfully made thread 2944 of process 2935 (/usr/bin/pulseaudio) owned by '42' RT at priority 5.
Nov 19 04:45:27 thismachine rtkit-daemon[1781]: Successfully made thread 2945 of process 2935 (/usr/bin/pulseaudio) owned by '42' RT at priority 5.
Nov 19 04:57:26 thismachine ntpd[1487]: 0.0.0.0 c612 02 freq_set kernel -455.702 PPM
Nov 19 04:57:26 thismachine ntpd[1487]: 0.0.0.0 c61c 0c clock_step -0.355393 s
Nov 19 04:57:27 thismachine ntpd[1487]: 0.0.0.0 c618 08 no_sys_peer
Nov 19 04:57:54 thismachine gdm-simple-greeter[2925]: WARNING: Failed to send buffer
Nov 19 04:57:55 thismachine NetworkManager[1230]: <error> [1290142675.386575] [nm-manager.c:1332] user_proxy_init(): could not init user settings proxy: (3) Could not get owner of name 'org.freedesktop.NetworkManagerUserSettings': no such name
Nov 19 04:57:55 thismachine NetworkManager[1230]: <error> [1290142675.387428] [nm-manager.c:1332] user_proxy_init(): could not init user settings proxy: (3) Could not get owner of name 'org.freedesktop.NetworkManagerUserSettings': no such name
Nov 19 04:57:55 thismachine NetworkManager[1230]: <error> [1290142675.387643] [nm-manager.c:1332] user_proxy_init(): could not init user settings proxy: (3) Could not get owner of name 'org.freedesktop.NetworkManagerUserSettings': no such name
Nov 19 04:57:55 thismachine NetworkManager[1230]: <error> [1290142675.387948] [nm-manager.c:1332] user_proxy_init(): could not init user settings proxy: (3) Could not get owner of name 'org.freedesktop.NetworkManagerUserSettings': no such name
Nov 19 04:57:55 thismachine NetworkManager[1230]: <error> [1290142675.388203] [nm-manager.c:1332] user_proxy_init(): could not init user settings proxy: (3) Could not get owner of name 'org.freedesktop.NetworkManagerUserSettings': no such name
Nov 19 04:57:56 thismachine rtkit-daemon[1781]: Successfully made thread 3102 of process 3102 (/usr/bin/pulseaudio) owned by '500' high priority at nice level -11.
Nov 19 04:57:56 thismachine pulseaudio[3102]: pid.c: Stale PID file, overwriting.
Nov 19 04:57:56 thismachine rtkit-daemon[1781]: Successfully made thread 3106 of process 3102 (/usr/bin/pulseaudio) owned by '500' RT at priority 5.
Nov 19 04:57:56 thismachine rtkit-daemon[1781]: Successfully made thread 3279 of process 3102 (/usr/bin/pulseaudio) owned by '500' RT at priority 5.
Nov 19 04:57:56 thismachine rtkit-daemon[1781]: Successfully made thread 3298 of process 3102 (/usr/bin/pulseaudio) owned by '500' RT at priority 5.
Nov 19 04:57:56 thismachine pulseaudio[3102]: bluetooth-util.c: Error from ListAdapters reply: org.freedesktop.DBus.Error.Spawn.ChildExited
Nov 19 04:57:56 thismachine rtkit-daemon[1781]: Successfully made thread 3322 of process 3322 (/usr/bin/pulseaudio) owned by '500' high priority at nice level -11.
Nov 19 04:57:56 thismachine pulseaudio[3322]: pid.c: Daemon already running.
Nov 19 04:57:56 thismachine dbus: [system] Rejected send message, 2 matched rules; type="method_call", sender=":1.123" (uid=500 pid=3107 comm="nautilus) interface="org.freedesktop.DBus.Properties" member="GetAll" error name="(unset)" requested_reply=0 destination=":1.16" (uid=0 pid=1705 comm="/usr/sbin/console-kit-daemon))
Nov 19 04:59:01 thismachine abrt[3423]: can't read /proc/2876/exe link
Nov 19 04:59:01 thismachine gnome-keyring-daemon[2989]: dbus failure unregistering from session: Connection is closed
Nov 19 04:59:01 thismachine gnome-keyring-daemon[2989]: dbus failure unregistering from session: Connection is closed
Nov 19 04:59:02 thismachine NetworkManager[1230]: <error> [1290142742.167552] [nm-manager.c:1332] user_proxy_init(): could not init user settings proxy: (3) Could not get owner of name 'org.freedesktop.NetworkManagerUserSettings': no such name
Nov 19 04:59:02 thismachine NetworkManager[1230]: <error> [1290142742.167887] [nm-manager.c:1332] user_proxy_init(): could not init user settings proxy: (3) Could not get owner of name 'org.freedesktop.NetworkManagerUserSettings': no such name
Nov 19 04:59:02 thismachine NetworkManager[1230]: <error> [1290142742.168125] [nm-manager.c:1332] user_proxy_init(): could not init user settings proxy: (3) Could not get owner of name 'org.freedesktop.NetworkManagerUserSettings': no such name
Nov 19 04:59:02 thismachine NetworkManager[1230]: <error> [1290142742.168396] [nm-manager.c:1332] user_proxy_init(): could not init user settings proxy: (3) Could not get owner of name 'org.freedesktop.NetworkManagerUserSettings': no such name
Nov 19 04:59:02 thismachine NetworkManager[1230]: <error> [1290142742.168669] [nm-manager.c:1332] user_proxy_init(): could not init user settings proxy: (3) Could not get owner of name 'org.freedesktop.NetworkManagerUserSettings': no such name
Nov 19 04:59:03 thismachine rtkit-daemon[1781]: Successfully made thread 3492 of process 3492 (/usr/bin/pulseaudio) owned by '42' high priority at nice level -11.
Nov 19 04:59:03 thismachine gdm-simple-greeter[3482]: Gtk-WARNING: gtkwidget.c:5691: widget not within a GtkWindow
Nov 19 04:59:03 thismachine rtkit-daemon[1781]: Successfully made thread 3495 of process 3492 (/usr/bin/pulseaudio) owned by '42' RT at priority 5.
Nov 19 04:59:03 thismachine gdm-simple-greeter[3482]: WARNING: Unable to load CK history: no seat-id found
Nov 19 04:59:03 thismachine rtkit-daemon[1781]: Successfully made thread 3501 of process 3492 (/usr/bin/pulseaudio) owned by '42' RT at priority 5.
Nov 19 04:59:03 thismachine rtkit-daemon[1781]: Successfully made thread 3502 of process 3492 (/usr/bin/pulseaudio) owned by '42' RT at priority 5.
Nov 19 05:12:32 thismachine ntpd[1487]: 0.0.0.0 c612 02 freq_set kernel -329.382 PPM
Nov 19 05:12:32 thismachine ntpd[1487]: 0.0.0.0 c615 05 clock_sync
Comment 14 Anthony Name 2010-11-19 01:42:12 EST
Created attachment 461470 [details]
Zipped file of Xorg crash
Comment 15 Anthony Name 2010-11-19 01:44:29 EST
I suspect this now needs to get re-assigned as a Xorg bug, however I would have though abrt would be catching this automatically and it's not.
Comment 16 Jiri Moskovcak 2010-11-19 04:05:15 EST
(In reply to comment #15)
> I suspect this now needs to get re-assigned as a Xorg bug, 
however I would have

- yes

> though abrt would be catching this automatically and it's not.

- it is, otherwise you wouldn't find it in /var/spool/abrt, the problem is you X server is running under root, so you can't see it in abrt window, you would have to run is as root to see all the crashes. Unfortunately a lot of X server crashes has stripped coredump which leads to unusable backtrace which makes ABRT to refuse reporting it to bz...
Comment 17 Anthony Name 2010-11-19 08:01:33 EST
Jiri

Can I just re-assign this bug to Xorg or should I generate a new bug?
Comment 18 Anthony Name 2010-11-19 08:06:31 EST
Jiri

Ignore the above, I'll just generate a new bug as it's now becoming a show stopper.

Thanks for your help.
Comment 19 Fedora Update System 2010-11-22 17:23:11 EST
abrt-1.1.14-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 20 Fedora Update System 2010-11-26 16:09:47 EST
abrt-1.1.14-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.