Bug 639144 - External display disabled on start
Summary: External display disabled on start
Status: CLOSED DUPLICATE of bug 623824
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-settings-daemon
Version: 14
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Bastien Nocera
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Triaged
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-09-30 22:19 UTC by Kamil Páral
Modified: 2018-04-11 07:28 UTC (History)
7 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2010-10-12 20:15:54 UTC


Attachments (Terms of Use)
dmesg (122.94 KB, text/plain)
2010-10-05 07:26 UTC, Kamil Páral
no flags Details
messages (2.42 MB, text/plain)
2010-10-05 07:26 UTC, Kamil Páral
no flags Details
Xorg log (225.05 KB, text/plain)
2010-10-05 07:27 UTC, Kamil Páral
no flags Details

Description Kamil Páral 2010-09-30 22:19:29 UTC
Description of problem:
Followed:
https://fedoraproject.org/wiki/QA:Testcase_intelvideo_multihead

When I boot my Thinkpad T500 with external display connected via VGA, in plymouth I have image on both screens. But as soon as GDM starts up, the VGA display is disabled (displays "no signal" message) and only laptop display is used.

Version-Release number of selected component (if applicable):
gdm-2.31.90-7.fc14.x86_64
xorg-x11-drv-intel-2.12.0-6.fc14.x86_64
Smolt: http://www.smolts.org/client/show/pub_bdc5d4b2-09d8-4e88-a38d-e85817c3bc84

How reproducible:
always

Comment 1 Kamil Páral 2010-09-30 22:21:20 UTC
(VGA display is disabled)

[kparal@f14 ~]$ xrandr 
Screen 0: minimum 320 x 200, current 1680 x 1050, maximum 8192 x 8192
LVDS1 connected 1680x1050+0+0 (normal left inverted right x axis y axis) 331mm x 207mm
   1680x1050      60.1*+   50.1  
   1400x1050      60.0  
   1280x1024      60.0  
   1280x960       60.0  
   1024x768       60.0  
   800x600        60.3     56.2  
   640x480        59.9  
VGA1 connected (normal left inverted right x axis y axis)
   1680x1050      59.9 +
   1280x1024      75.0     60.0  
   1280x960       60.0  
   1152x864       75.0  
   1024x768       75.1     70.1     60.0  
   832x624        74.6  
   800x600        72.2     75.0     60.3     56.2  
   640x480        72.8     75.0     66.7     60.0  
   720x400        70.1  
HDMI1 disconnected (normal left inverted right x axis y axis)
DP1 disconnected (normal left inverted right x axis y axis)
HDMI2 disconnected (normal left inverted right x axis y axis)
DP2 disconnected (normal left inverted right x axis y axis)
DP3 disconnected (normal left inverted right x axis y axis)

Comment 2 Kamil Páral 2010-09-30 22:27:47 UTC
When I use gnome-display-properties, I can enable the VGA display and it works just fine. But after clean boot it is again disabled.

Comment 3 Matěj Cepl 2010-10-04 11:52:07 UTC
... and "Make Default" button doesn't work?

Comment 4 Kamil Páral 2010-10-04 13:20:02 UTC
(In reply to comment #3)
> ... and "Make Default" button doesn't work?

I don't know, I can test it if required. But this bug is reported against the default behavior (that is 'display powered off'), which breaks this test case requirement:

"4. Verify that the graphical environment starts correctly and is spanned across all connected displays (Fedora 12 and later) or shows the same output on all displays (Fedora 11 and earlier) "

Comment 5 Matěj Cepl 2010-10-04 14:35:18 UTC
(In reply to comment #2)
> But after clean boot it is again disabled.

Sure, I am not trying to make this NOTABUG, just tryng to get a clarification on this. And of course I would need standard logs set:

Please add drm.debug=0x04 to the kernel command line, restart computer, and attach

* your X server config file (/etc/X11/xorg.conf, if available),
* X server log file (/var/log/Xorg.*.log)
* output of the dmesg command, and
* system log (/var/log/messages)

to the bug report as individual uncompressed file attachments using the bugzilla file attachment link above.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.

Comment 6 Kamil Páral 2010-10-05 07:26:34 UTC
Created attachment 451596 [details]
dmesg

Comment 7 Kamil Páral 2010-10-05 07:26:58 UTC
Created attachment 451597 [details]
messages

Comment 8 Kamil Páral 2010-10-05 07:27:14 UTC
Created attachment 451598 [details]
Xorg log

Comment 9 Kamil Páral 2010-10-05 07:28:56 UTC
There is a short time when starting X server when I see (halves of) mouse cursor on both monitors. But as soon as GDM is about to show, the external monitor is disabled. After login it is enabled again.

Comment 10 Adam Williamson 2010-10-06 23:13:30 UTC
was this a clean test installation, or have you used the system before? You may perhaps have stored a config with the external monitor disabled, and forgotten about it...



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 11 Kamil Páral 2010-10-07 07:57:46 UTC
(In reply to comment #10)
> was this a clean test installation, or have you used the system before? You may
> perhaps have stored a config with the external monitor disabled, and forgotten
> about it...

This was a clean installation. Also, there is no xorg.conf present.

Comment 12 Adam Williamson 2010-10-07 15:35:14 UTC
GDM/GNOME seem to store their configuration of the monitor layout somewhere other than xorg.conf. I haven't figured out where, yet.

Comment 13 Kamil Páral 2010-10-07 16:02:50 UTC
I have confirmed this problem even with F14 Beta Live.

1. Plymouth runs on both monitors.
2. When GDM starts, external display is disabled.
3. After logging in, external display is enabled.
4. You can use gnome-display-properties to enable external monitor. The setting is remembered.
5. After logging out into GDM, external display is disabled again.
6. After logging in, external display is enabled. (remembered from step 4).

Comment 14 Kamil Páral 2010-10-07 16:03:46 UTC
This should be probably reassigned to GDM component, what do you think?

Comment 15 Matěj Cepl 2010-10-07 16:12:01 UTC
Looks similar to bug 595644, not the same though. Anyway, passing to ajax, and he wants to close it as duplicate of bug 595644 (or anything else), his call.

Comment 16 Mamoru TASAKA 2010-10-10 16:47:53 UTC
Maybe this is the same issue as bug 623824 comment 15.

Comment 17 Kamil Páral 2010-10-12 16:07:43 UTC
(In reply to comment #16)
> Maybe this is the same issue as bug 623824 comment 15.

Oh, very nice. I enabled /apps/gnome_settings_daemon/xrandr/turn_on_external_monitors_at_startup as root as used "Set as Default". After that external monitor is truly enabled in GDM, showing in cloned mode.

Re-assigning to gnome-settings-daemon.

Comment 18 Adam Williamson 2010-10-12 20:15:54 UTC

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 623824 ***


Note You need to log in before you can comment on or make changes to this bug.