Bug 623824 - (F14nodualhead) Won't display on VGA-connected monitor
Won't display on VGA-connected monitor
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-settings-daemon (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
https://fedoraproject.org/wiki/Common...
: CommonBugs
: 639144 651378 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-12 17:29 EDT by Mamoru TASAKA
Modified: 2018-04-11 03:14 EDT (History)
8 users (show)

See Also:
Fixed In Version: gnome-settings-daemon-2.32.0-2.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-08 17:36:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (54.98 KB, text/plain)
2010-08-12 17:30 EDT, Mamoru TASAKA
no flags Details
dmesg (34.42 KB, text/plain)
2010-08-12 17:31 EDT, Mamoru TASAKA
no flags Details
xorg.conf (342 bytes, text/plain)
2010-08-12 17:31 EDT, Mamoru TASAKA
no flags Details
xrandr output with g-s-d 2.30.1 (603 bytes, text/plain)
2010-08-12 17:32 EDT, Mamoru TASAKA
no flags Details
dmesg (2.6.35.4-18.fc14.i686) (37.57 KB, text/plain)
2010-09-13 15:36 EDT, Mamoru TASAKA
no flags Details
Xorg.0.log (1.9.0-4.fc14) (56.58 KB, text/plain)
2010-09-13 15:37 EDT, Mamoru TASAKA
no flags Details
Patch to make external display on by default (674 bytes, patch)
2010-10-10 12:46 EDT, Mamoru TASAKA
no flags Details | Diff

  None (edit)
Description Mamoru TASAKA 2010-08-12 17:29:22 EDT
Description of problem:
With using TOSHIBA LX3516 laptop with another monitor connented
with VGA, when I
- boot the computer (now using init=/sbin/upstart for some reason)
  with runlevel 3
- On tty1 login as root
- type init 5

Then
- GUI launches. At first display is shown on both laptop window and
  the monitor connected with VGA
- But with another few seconds, suddenly display on the monitor
  connected with VGA disappears and it becomes totally black
- And gdm login window only appears on LVDS window

Version-Release number of selected component (if applicable):
gnome-settings-daemon-2.31.6-1.fc14
(actually 2.31.2? - 2.31.6)

How reproducible:
100%

Additional info:
gnome-settings-daemon-2.30.1-6.fc13 works.
Note that I still use F-13 packages for kernel, xorg-x11-server-XXX,
xorg-x11-drv-XXX and mesa. The rest rpms are F-14 ones.
Comment 1 Mamoru TASAKA 2010-08-12 17:30:51 EDT
Created attachment 438536 [details]
Xorg.0.log
Comment 2 Mamoru TASAKA 2010-08-12 17:31:22 EDT
Created attachment 438537 [details]
dmesg
Comment 3 Mamoru TASAKA 2010-08-12 17:31:44 EDT
Created attachment 438538 [details]
xorg.conf
Comment 4 Mamoru TASAKA 2010-08-12 17:32:24 EDT
Created attachment 438539 [details]
xrandr output with g-s-d 2.30.1
Comment 5 Mamoru TASAKA 2010-08-23 12:19:55 EDT
Still reproducible with gnome-settings-daemon-2.31.6-1.fc14 and

kernel-2.6.35.2-9.fc14.i686
xorg-x11-server-Xorg-1.9.0-1.fc14.i686
xorg-x11-drv-intel-2.12.0-4.fc14.i686
Comment 6 Mamoru TASAKA 2010-09-01 11:38:51 EDT
Still no good with gnome-settings-daemon-2.31.91-1.fc14

gnome-settings-daemon-2.30.1-6.fc13 works.
Comment 7 Adam Jackson 2010-09-13 14:22:26 EDT
If you're using the F13 packages for everything that could possibly have to do with output setup, then there's no possible way we can tell if it works in F14.  Removing from F14Blocker.
Comment 8 Mamoru TASAKA 2010-09-13 14:50:59 EDT
What I am saying is that
- I am now using F-14 branch
- "Only" F-14 gnome-settings-daemon does not work (i.e. again
  I use F-14 packages except for gnome-settings-daemon).
Comment 9 Mamoru TASAKA 2010-09-13 15:33:54 EDT
Still no good with

xorg-x11-server-Xorg-1.9.0-4.fc14.i686
gdm-2.31.90-4.fc14.i686
gnome-settings-daemon-2.31.91-2.fc14.i686
kernel-2.6.35.4-18.fc14.i686
Comment 10 Mamoru TASAKA 2010-09-13 15:36:21 EDT
Created attachment 447023 [details]
dmesg (2.6.35.4-18.fc14.i686)
Comment 11 Mamoru TASAKA 2010-09-13 15:37:17 EDT
Created attachment 447024 [details]
Xorg.0.log (1.9.0-4.fc14)

Now xorg.conf does not exist
Comment 12 Mamoru TASAKA 2010-09-13 15:40:28 EDT
(In reply to comment #7)
> If you're using the F13 packages for everything that could possibly have to do
> with output setup,

Now xorg.conf does not exist, and I don't think I am doing some special
setup for output.
Comment 13 Mamoru TASAKA 2010-09-30 05:13:08 EDT
Okay, now I tried Fedora 14 Beta Live Image and this issue still
remains.

Using F-14beta Live + downloading gnome-setings-daemon to
2.30.1-8.fc13.i686 solves my problem.
Comment 14 Adam Williamson 2010-10-01 13:24:50 EDT
This was discussed at the blocker review meeting of 2010-10-01. We agreed it is not a blocker as we do not cover multi-head configurations, and this seems to be a single system issue (several of us have dual head configs and they work fine).
Comment 15 Mamoru TASAKA 2010-10-10 12:46:26 EDT
Created attachment 452598 [details]
Patch to make external display on by default

So I compared the source of gnome-settings-daemon between
2.30.1 and 2.31.2, and it seems that actually with gnome-settings-daemon
>= 2.31.2 external display is explicity disabled by default,
in ./data/apps_gnome_settings_daemon_xrandr.schemas.in :

----------------------------------------------------
    17          <schema>
    18              <key>/schemas/apps/gnome_settings_daemon/xrandr/turn_on_external_monitors_at_startup</key>
    19              <applyto>/apps/gnome_settings_daemon/xrandr/turn_on_external_monitors_at_startup</applyto>
    20              <owner>gnome</owner>
    21              <type>bool</type> <====================================
    22              <default>false</default>
    23              <locale name="C">
    24                  <short>Turn on external monitor after system boot</short>
    25                  <long>Turn on external monitor after system boot if user plugs in
    26                  external monitor on system boot.
    27                  </long>
    28              </locale>
    29          </schema>
----------------------------------------------------

Changing this value to true, i.e. applying the following patch
works for me. Would you consider to add this?
(Well, I think it is preferable to make external display on
 by default...)
Comment 16 Kamil Páral 2010-10-12 12:08:10 EDT
Bug 639144 is a possible duplicate of this one.
Comment 17 Adam Williamson 2010-10-12 16:15:54 EDT
*** Bug 639144 has been marked as a duplicate of this bug. ***
Comment 18 Adam Williamson 2010-10-12 16:17:48 EDT
given Mamoru's diagnosis this obviously isn't single-system; those of us who don't have this problem obviously have stored configs which pre-date it.

So I re-propose this for NTH status; I don't think this counts as a blocker but I *do* think we should make sure the dual-head policy we have in the release is actually the one we want, and if it's not, we should take a fix for it through the freeze, since it's just a gconf key change and logically *can't* cause new blockers since multi-head configuration isn't a blocker issue.

I'll flag this issue up for the desktop team to look at, CCing mclasen.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 19 Adam Williamson 2010-10-15 13:03:32 EDT
Discussed at the 2010-10-15 review meeting. We agreed that if the desktop team decides to change this setting to match our previous default behaviour, we would take the fix, so this is accepted as an NTH bug.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 20 Mamoru TASAKA 2010-10-19 03:36:52 EDT
FYI:
Ubuntu bug:
https://bugs.launchpad.net/ubuntu/+source/gnome-settings-daemon/+bug/640807
and upstreamed bug into GNOME site:
https://bugzilla.gnome.org/show_bug.cgi?id=631388
especially:
https://bugzilla.gnome.org/show_bug.cgi?id=631388#c2
http://bugzilla-attachments.gnome.org/attachment.cgi?id=171747

Ubuntu introduced a new key "use_xorg_monitor_settings" which
disables gnome-settings-daemon to touch monitor settings and
set this key (use_xorg_monitor_settings) as true.

With this patch applied and with the key "use_xorg_monitor_settings"
set to true, now I get "spanned" mode on gdm (as was in F-13)
instead of "clonned" mode (with turn_on_external_monitors_at_startup
set as true).
Comment 21 Adam Williamson 2010-10-19 14:07:21 EDT
note that today is the deadline for RC1, if we want to change this behaviour for F14 you need to submit the build to implement this to Bodhi today and have it reach the karma threshold. After that this can only be changed if we hit blocker bugs that require further RCs to be built.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 22 Mamoru TASAKA 2010-10-27 05:28:10 EDT
Adam, can this issue be the candidate for "Common bug"?
http://fedoraproject.org/wiki/Common_F14_bugs
Comment 23 Adam Williamson 2010-10-27 14:14:18 EDT
Yup, indeed, we should document it there now it hasn't been changed. To propose an issue for a common bugs note, add the CommonBugs keyword.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 24 Adam Williamson 2010-11-01 19:00:11 EDT
Removing F14 NTH status as F14 is now out.

Remaining open nice-to-have issues do NOT automatically become nice-to-have issues for Fedora 15. If you believe a Fedora 14 issue which was accepted as
nice-to-have but not resolved in time for release should also qualify for
nice-to-have status for Fedora 15, please re-propose it as nice-to-have for
Fedora 15.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 25 Adam Williamson 2010-11-01 19:50:09 EDT

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 26 Fedora Update System 2010-11-05 12:23:23 EDT
gnome-settings-daemon-2.32.0-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/gnome-settings-daemon-2.32.0-2.fc14
Comment 27 Mamoru TASAKA 2010-11-06 10:59:20 EDT
(In reply to comment #26)
> gnome-settings-daemon-2.32.0-2.fc14 has been submitted as an update for Fedora
> 14.
> https://admin.fedoraproject.org/updates/gnome-settings-daemon-2.32.0-2.fc14

As I wrote in bodhi, this rpm fixes the issue, thank you.
Adam, if this new gnome-settings-daemon hits testing, would you update
F14 common bug wiki? (Or, as g-s-d is in critpath and as I already put
+1 vote, another +1 vote by proventester will make this g-s-d go into
stable directly, if I am correct)
Comment 28 Fedora Update System 2010-11-06 19:47:33 EDT
gnome-settings-daemon-2.32.0-2.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gnome-settings-daemon'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/gnome-settings-daemon-2.32.0-2.fc14
Comment 29 Kamil Páral 2010-11-08 02:48:49 EST
gnome-settings-daemon-2.32.0-2.fc14 fixes this issue.
Comment 30 Fedora Update System 2010-11-08 17:36:47 EST
gnome-settings-daemon-2.32.0-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 31 Matěj Cepl 2010-11-09 09:59:04 EST
*** Bug 651378 has been marked as a duplicate of this bug. ***
Comment 32 Matěj Cepl 2010-11-10 03:38:48 EST
*** Bug 651706 has been marked as a duplicate of this bug. ***
Comment 33 Matěj Cepl 2010-11-10 04:22:05 EST
*** Bug 651378 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.