Bug 639809 - install from usb pen drive using dvd iso fails
install from usb pen drive using dvd iso fails
Status: CLOSED DUPLICATE of bug 627789
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-04 01:14 EDT by Tim Fenn
Modified: 2010-10-04 09:57 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-04 09:57:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Fenn 2010-10-04 01:14:33 EDT
Description of problem:

Following instructions outlined here:

http://fedoraproject.org/wiki/FedoraLiveCD/USBHowTo#How_to_Make_a_bootable_USB_Drive_to_Install_Fedora_instead_of_using_a_physical_DVD

using F14 beta DVD iso. Attempting to upgrade from F13 install, select hard drive as install target device and leave USB pendrive as data storage device. Select "boot loader" for hard drive. Then select "update boot loader," click next and install fails with "The following error occurred while setting up the installation directory: (16, 'Device or resource busy') Please provide the correct information for installing Fedora."

I'm guessing the USB pendrive is already mounted, and the installer is attempting to mount it again?

Version-Release number of selected component (if applicable):

F14beta:

http://download.fedoraproject.org/pub/fedora/linux/releases/test/14-Beta/Fedora/i386/iso/Fedora-14-Beta-i386-DVD.iso

using boot.iso derived from:

http://mirrors.kernel.org/fedora/releases/test/14-Beta/Fedora/i386/os/images/boot.iso

How reproducible:

always.

Steps to Reproduce:
1. boot F14beta installer from USB pendrive
2. select pendrive as "data storage device."
  
Actual results:

installer fails when attempting to mount pendrive

Expected results:

installer should realize pendrive is already mounted (?)

Additional info:

hardware: ASUS 1000HE
Comment 1 Mike C 2010-10-04 03:32:29 EDT
There is a way to get a usb pendrive to work for the install - I have been testing it this weekend. Make sure you are using a machine running f12 or f13 and have the DVD install iso available as a file.

1) Use gparted to format the usb key with a single fat32 partition, and mark the partition bootable.

2) Plug in the drive and when it automounts then do not use the desktop icon to eject it but become root in a terminal and issue the following:
umount /dev/sdb1

3) Make sure you have the package livecd-tools installed and then on the same machine use:
livecd-iso-to-disk --reset-mbr /path-to/Fedora-14-DVD.iso /dev/sdb1

This will make a bootable usbkey that will boot directly into the install/upgrade for f14, if you have the key plugged in and select the usb key as the boot device.  I have tried this and it works for me.

One vital watchpoint if you are doing an install rather than an upgrade is as follows concerning the section where the selection of where to write the bootloader is made:

At this point it is vital to click "Switch device", since by default grub is written to the mbr on the usbkey since the key is the source of the iso! - So it is vital to make sure that that you set the first bios drive as (typically) /dev/sda and 2nd bios drive is /dev/sdb (if that is the usbkey device). i.e. this reverses the default selected by the system. Then ensure that the installer will write grub to the mba of /dev/sda. 

If this is not done then grub gets written to the mbr of the usbkey by default and the resulting installed system will not boot (though it can be fixed post
install using a rescue disk). 

It would be nice if anaconda made the correct section and I will write a BZ about this - maybe it can be fixed by f14 final! Either way provided the uskbey is prepared with the correct method then it will work!
Comment 2 Tim Fenn 2010-10-04 03:57:29 EDT
(In reply to comment #1)
> There is a way to get a usb pendrive to work for the install - I have been
> testing it this weekend. Make sure you are using a machine running f12 or f13
> and have the DVD install iso available as a file.
> 
> 1) Use gparted to format the usb key with a single fat32 partition, and mark
> the partition bootable.
> 
> 2) Plug in the drive and when it automounts then do not use the desktop icon to
> eject it but become root in a terminal and issue the following:
> umount /dev/sdb1
> 
> 3) Make sure you have the package livecd-tools installed and then on the same
> machine use:
> livecd-iso-to-disk --reset-mbr /path-to/Fedora-14-DVD.iso /dev/sdb1
> 
> This will make a bootable usbkey that will boot directly into the
> install/upgrade for f14, if you have the key plugged in and select the usb key
> as the boot device.  I have tried this and it works for me.
> 

Doesn't that accomplish something similar to the steps outlined in:

http://fedoraproject.org/wiki/FedoraLiveCD/USBHowTo#How_to_Make_a_bootable_USB_Drive_to_Install_Fedora_instead_of_using_a_physical_DVD

?

I'm able to boot into the install/upgrade, thats not the problem. Or am I missing something? 

> One vital watchpoint if you are doing an install rather than an upgrade is as
> follows concerning the section where the selection of where to write the
> bootloader is made:
> 

Yeah, I learned this the hard way with my F13 upgrade.  >.<

Now, I use the BBS to select the pendrive to boot from, which keeps the internal drive as /dev/sda. I also checked this in the grub bootloader update options to be sure.

To me, the problem seemed to be that anaconda was attempting to mount the pendrive via the hard drive installation method, but it was already mounted - giving me the failure.  Or maybe I'm just a moron (which is entirely likely).
Comment 3 Mike C 2010-10-04 07:09:37 EDT
I think that the f13 documentation is not at all clear but the method I outlined is in principle easier and simpler and should work without the tricks needed for the boot record if anaconda was amended to do that.  The install guide is being re-written by the docs beats author at the moment and I believe that a new draft should be out in a few days in preparation for the f14 documentation.

Also I am hoping that anaconda may be fixed to accommodate this (well hoping so anyway!)
Comment 4 Mike C 2010-10-04 07:12:14 EDT
By the way - with my method you don't need both the boot.iso and the DVD iso - you just use the DVD iso directly - the key boots and goes straight into the install that way. Then you can select upgrade or clean install as you wish from that point.
Comment 5 Chris Lumens 2010-10-04 09:57:50 EDT

*** This bug has been marked as a duplicate of bug 627789 ***

Note You need to log in before you can comment on or make changes to this bug.