Bug 63988 - tcpdump does a Segmentation fault
Summary: tcpdump does a Segmentation fault
Status: CLOSED DUPLICATE of bug 62397
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: tcpdump (Show other bugs)
(Show other bugs)
Version: skipjack-beta2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-04-23 10:03 UTC by Adrian Reber
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-23 10:03:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Adrian Reber 2002-04-23 10:03:45 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020401

Description of problem:
tcpdump exits with a segmentation fault

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.start tcpdump
2.
3.
	

Actual Results:  Segmentation fault

Additional info:

(gdb) r
Starting program: /usr/sbin/tcpdump 
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...
Program received signal SIGSEGV, Segmentation fault.
0x420f6cbf in __nss_ethers_lookup () from /lib/i686/libc.so.6
(gdb) br
Breakpoint 1 at 0x420f6cbf
(gdb) bt
#0  0x420f6cbf in __nss_ethers_lookup () from /lib/i686/libc.so.6
#1  0x420fba3d in ether_ntohost () from /lib/i686/libc.so.6
#2  0x08061957 in strcpy ()
#3  0x08061a44 in strcpy ()
#4  0x0804a976 in strcpy ()
#5  0x420174d9 in __libc_start_main () from /lib/i686/libc.so.6

Probably this is a glibc bug. But tcpdump is the only program triggering it on
my system.

Comment 1 Harald Hoyer 2002-04-23 10:43:39 UTC

*** This bug has been marked as a duplicate of 62397 ***


Note You need to log in before you can comment on or make changes to this bug.