Bug 62397 - tcpdump segfaults in ether_ntohost
tcpdump segfaults in ether_ntohost
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: glibc (Show other bugs)
1.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
: 62343 63122 63683 63988 64424 (view as bug list)
Depends On:
Blocks: 61590
  Show dependency treegraph
 
Reported: 2002-03-30 22:58 EST by Bill Crawford
Modified: 2007-04-18 12:41 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-10 16:38:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of "ltrace tcpdump > /tmp/tcpdump.ltrace 2>&1" (5.21 KB, text/plain)
2002-03-30 22:59 EST, Bill Crawford
no flags Details
output of "strace tcpdump > /tmp/tcpdump.strace 2>&1" (4.76 KB, text/plain)
2002-03-30 23:00 EST, Bill Crawford
no flags Details

  None (edit)
Description Bill Crawford 2002-03-30 22:58:01 EST
Description of Problem:
Since updating to current glibc from Raw Hide, tcpdump no longer works.

Version-Release number of selected component (if applicable):
glibc-2.2.5-30
tcpdump-3.6.2-12

How Reproducible:
Run tcpdump from the command line, no arguments.

Actual Results:
[root@pikachu RPMS]# tcpdump
Segmentation fault

Expected Results:
Well, not that :o)
Usually it's something more like (from a box with older stuff on it):

[root@togepi root]# tcpdump not port 22
tcpdump: listening on eth0
04:56:33.241627 802.1d config 8000.00:03:a0:a0:b4:00.804d root
8000.00:03:a0:a0:b4:00 pathcost 0 age 0 max 20 hello 2 fdelay 15 

1 packets received by filter
0 packets dropped by kernel

Additional Information:
This was working yesterday :o)
I have the .i686.rpm, I don't know if this is relevant.
Comment 1 Bill Crawford 2002-03-30 22:59:56 EST
Created attachment 51505 [details]
output of "ltrace tcpdump > /tmp/tcpdump.ltrace 2>&1"
Comment 2 Bill Crawford 2002-03-30 23:00:35 EST
Created attachment 51506 [details]
output of "strace tcpdump > /tmp/tcpdump.strace 2>&1"
Comment 3 Bill Nottingham 2002-04-01 16:13:24 EST

*** This bug has been marked as a duplicate of 62343 ***
Comment 4 Harald Hoyer 2002-04-02 04:09:56 EST
This is definetly a glibc bug, as it worked with the glibc releases before..
Comment 5 Harald Hoyer 2002-04-02 04:10:49 EST
*** Bug 62343 has been marked as a duplicate of this bug. ***
Comment 6 Jakub Jelinek 2002-04-02 04:38:33 EST
Found the bug, will fix today.
Comment 7 Harald Hoyer 2002-04-10 05:37:40 EDT
*** Bug 63122 has been marked as a duplicate of this bug. ***
Comment 8 Jay Turner 2002-04-11 07:40:44 EDT
tcpdump (3.6.2-12) is working again with the installation of glibc-2.2.5-32. 
Closing out.
Comment 9 Harald Hoyer 2002-04-17 10:06:27 EDT
*** Bug 63683 has been marked as a duplicate of this bug. ***
Comment 10 Harald Hoyer 2002-04-23 06:43:35 EDT
*** Bug 63988 has been marked as a duplicate of this bug. ***
Comment 11 Harald Hoyer 2002-05-06 05:23:55 EDT
*** Bug 64424 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.