Bug 639905 - No command line help available.
No command line help available.
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Krzysztof Daniel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-04 06:10 EDT by Mads Kiilerich
Modified: 2014-01-12 19:26 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-01 03:06:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Eclipse Project 25334 None None None Never

  None (edit)
Description Mads Kiilerich 2010-10-04 06:10:41 EDT
Fedora eclipse doesn't have a man page and recognizes neither -h, -help nor --help.

I would expect something like the content of http://help.eclipse.org/galileo/topic/org.eclipse.platform.doc.isv/reference/misc/runtime-options.html to be easily available.

IIRC -h used to work.

eclipse-platform-3.6.0-3.fc14.i686
Comment 1 Alexander Kurtakov 2010-10-06 04:31:51 EDT
Hmm, I don't remember -h working. When was this?
According to upstream there is no man page because eclipse executable can be used to start different applications.
Comment 2 Severin Gehwolf 2010-10-06 09:17:52 EDT
With respect to man page, here are some related bugs:

https://bugzilla.redhat.com/show_bug.cgi?id=622925

https://bugs.eclipse.org/bugs/show_bug.cgi?id=291988 (It would be good if you could +1 on this)
Comment 3 Mads Kiilerich 2010-10-06 09:37:23 EDT
(In reply to comment #1)
> Hmm, I don't remember -h working. When was this?

Ok, I guess you know, so that must be a combination of my bad memory and hopeful thinking ;-)

So please take this as a request from a naive user.

I think it is a fair expection that options like -debug -console -clean (taken from memory) should be available as man or in -h (or on an info page if you don't like your users ;-) )

(FWIW /me don't like "closed upstream" as long as there is an unresolved issue.)
Comment 4 Alexander Kurtakov 2010-10-06 09:53:43 EDT
I'm not closing bugs like this but I can't promise that I'll work on it too.
Comment 5 Alexander Kurtakov 2012-04-30 11:17:46 EDT
Chris, would you please check upstream and if there isn't such bug open one and close this one after that as we would definetely not work on this as part of fedora. The new Equinox console might have opened some possibilities for better user help.
Comment 6 Andrew Overholt 2012-04-30 14:22:31 EDT
The issue is that the upstream binary launcher can be used for RCP apps and many things so it's next to impossible to put IDE-specific information in there.  A upstream bug is:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=291988

Other related information is the list of bugs open with the launcher (none which contain a request to add "--help" output AFAICT):

https://bugs.eclipse.org/bugs/buglist.cgi?list_id=1434740;classification=RT;query_format=advanced;component=Launcher;product=Equinox

and the list of runtime options:

http://help.eclipse.org/indigo/index.jsp?topic=%2Forg.eclipse.platform.doc.isv%2Freference%2Fmisc%2Fruntime-options.html

Note You need to log in before you can comment on or make changes to this bug.