Bug 64007 - Mishandling of white space in directory paths
Summary: Mishandling of white space in directory paths
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 7.3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-04-23 17:49 UTC by Robert Nichols
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-23 17:49:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Robert Nichols 2002-04-23 17:49:17 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.9-31.rkn-01 i586; Nav)

Description of problem:
The command "rpm -q -p <directory-path>/<some_pkg>.rpm" fails if the
directory-path contains any white space characters.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. $ mkdir "/tmp/a b c"
2. $ cp -a diffutils-2.7-23.i386.rpm "/tmp/a b c/"
3. $ rpm -q -p "/tmp/a b c/diffutils-2.7-23.i386.rpm"

	

Actual Results:  error: open of /tmp/a failed: No such file or directory


Expected Results:  diffutils-2.7-23


Additional info:

rpm-4.0.4-7x

Comment 1 Jeff Johnson 2002-05-09 16:17:48 UTC
If you *must* query filenames with embedded spaces,
then you will need to add an extra level of escaping
to get past rpm's globbing and reparsing of CLI
arguments.

Here's what will "work" for your example:
  rpm -q -p /tmp/a\\\ b\\\ c/diffutils-2.7-23.i386.rpm

Comment 2 Jeff Johnson 2002-05-16 22:48:51 UTC
*** Bug 65070 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.