Bug 65070 - spaces in filepath not passed to gzip
Summary: spaces in filepath not passed to gzip
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm-build (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-05-16 22:45 UTC by Neil Prockter
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-29 21:46:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Neil Prockter 2002-05-16 22:45:20 UTC
Description of Problem:    
rpm -bb fails to work if there is a space in the current    
working directory and the file is located there or if the   
filename contains a space   
    
Version-Release number of selected component (if    
applicable):    
 4.0.4   
    
How Reproducible:    
everytime   
   
    
Steps to Reproduce:    
1.  mkdir /a dir   
2.  cd /a dir   
3.  cp package.tar.gz .   
4.  rpm -bb package.tar.gz   
    
Actual Results:    
  Executing(%prep): /bin/sh -e /var/tmp/rpm-tmp.93492  
+ umask 022  
+ cd /usr/src/redhat/BUILD  
+ cd /usr/src/redhat/BUILD  
+ rm -rf File-Scan-0.26  
+ /bin/gzip -dc /a dir/package.tar.gz  
gzip: /a.gz: No such file or directory  
gzip: dir/package.tar.gz: No such file or directory  
  
    
Expected Results:    
 fine package build   
    
Additional Information:    
  also fails if called as rpm -bb /a\ dir/package.tar.gz   
i suppose this is related to 64007

Comment 1 Jeff Johnson 2002-05-16 22:48:57 UTC
Should be the same deal as queries.

*** This bug has been marked as a duplicate of 64007 ***

Comment 2 Neil Prockter 2002-05-16 22:56:18 UTC
but how do i quote the current working directory? 
 
rpm -bb package.tar.gz fails if the cwd has a space in it, 
how do I quote that? 
 
I know I could type rpm -bb /lots/of/dirs/down/in/here\\\ 
somewhere/oh/here/it/is/carpel/syndrome/time/package.tar.gz 
 
so can I have this a feature request?

Comment 3 Bill Nottingham 2005-09-29 21:46:33 UTC
Closing bugs on older, no longer supported, releases. Apologies for any lack of
response.

For RPM issues, please try a current release such as Fedora Core 4; if bugs
persist, please open a new issue.


Note You need to log in before you can comment on or make changes to this bug.