Bug 640607 - [te_IN] Text cut on left hand side for some composite characters
Summary: [te_IN] Text cut on left hand side for some composite characters
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: lohit-telugu-fonts
Version: 14
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Pravin Satpute
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 640610 714557 714560 714561 714562 714563
TreeView+ depends on / blocked
 
Reported: 2010-10-06 13:04 UTC by Krishna Babu K
Modified: 2012-05-26 07:48 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 714557 714560 714561 714562 714563 (view as bug list)
Environment:
Last Closed: 2011-08-19 10:49:08 UTC


Attachments (Terms of Use)
File contains the characters list for which problem exist (1.39 KB, application/octet-stream)
2010-10-06 13:04 UTC, Krishna Babu K
no flags Details
Overlapping glyphs issue (9.04 KB, image/jpeg)
2010-12-23 09:25 UTC, Arjuna Rao Chavala
no flags Details

Description Krishna Babu K 2010-10-06 13:04:44 UTC
Created attachment 451886 [details]
File contains the characters list for which problem exist

Description of problem:

Some part on Left hand side missing for these combinations. Please go through the attachment.
Version-Release number of selected component (if applicable):

lohit-telugu-fonts-2.4.5-5.fc14.noarch

How reproducible:
Every time.
Steps to Reproduce:
1. Open gedit and input the combinations mentioned in the attachment using input method.
2. Or else open the attachment in gedit.
3. Observe the left hand side of every combination which is not appearing properly.
  
Actual results:

Text does not appear completely.

Expected results:

Text should appear completely.

Additional info:

Please go through the attachment.

Comment 1 Pravin Satpute 2010-10-07 05:07:51 UTC
in attached gedit file it looks proper, please attach application image where characters are cutting, its version etc

Comment 2 Krishna Babu K 2010-10-12 06:49:44 UTC
Hi,

Please follow the version number, the problem still exist. And when we open the attached file in gedit we can identify the problem.

Comment 3 Pravin Satpute 2010-10-22 07:32:42 UTC
yeah, saw it, glyphs are cutting from left sides 
as per we discussed last time we should reduce below based shape, so that they can accommodate properly below the base shape.

need to change many shape, will work on it

Comment 4 Arjuna Rao Chavala 2010-12-23 09:25:25 UTC
Created attachment 470391 [details]
Overlapping glyphs issue

Many of these combinations  mentioned in this bug,   do not usually occur as first character on  aline. Hence the problem  may not be that severe. I show below a  test case,  where I have noticed  somewhat critical  overlapping of glyphs, which can  be looked into first.
Overlapping Glyphs  for Telugu Font Needing Correction
1. ర్యక్ర  (ryakra)
2. ప్టు     (ptu)

Pl. see the attached   image.

Comment 5 Krishna Babu K 2010-12-23 12:27:07 UTC
(In reply to comment #4)
> Created attachment 470391 [details]
> Overlapping glyphs issue
> 
> Many of these combinations  mentioned in this bug,   do not usually occur as
> first character on  aline. Hence the problem  may not be that severe. I show
> below a  test case,  where I have noticed  somewhat critical  overlapping of
> glyphs, which can  be looked into first.
> Overlapping Glyphs  for Telugu Font Needing Correction
> 1. ర్యక్ర  (ryakra)
> 2. ప్టు     (ptu)
> 
> Pl. see the attached   image.

some more problems need attention:

  స్టైల్ = problem in స్టై (sty)
  స్మైల్ = problem in స్మై (smy)
  వక్తృత్వము = problem in క్తృ (kthru)
  భ్రాహ్మణ = problem in భ్రా (bhrA)

Thanks,
krishna.

Comment 6 Pravin Satpute 2010-12-27 04:48:06 UTC
Arjun, yes thanks for point the must one
i will try to resolve those soon

Comment 7 Krishna Babu K 2011-02-14 09:55:28 UTC
(In reply to comment #6)
> Arjun, yes thanks for point the must one
> i will try to resolve those soon

Hi Pravin,

>some more problems need attention:

  >స్టైల్ = problem in స్టై (sty)
  >స్మైల్ = problem in స్మై (smy)
  >వక్తృత్వము = problem in క్తృ (kthru)
  >భ్రాహ్మణ = problem in భ్రా (bhrA)

 In the above examples, if we consider the fourth one it has half 'ra' as below
base. When ever we use this half 'ra' with vowel sign 'aA' on any consonant it
has some problem, the below base half 'ra' moving towards right side which
should stay exactly below the consonant. Since this usage is more in locale
'te_IN' we should fix this soon. 

 As a whole, these issues need to be fixed because most of them are frequent in
te_IN usage.

Thanks,
Krishna.

Comment 8 Pravin Satpute 2011-06-19 18:41:59 UTC
Hi Krishna,

 presently this looks very generic bug i.e. "improve telugu fonts" and so many different kinds of bugs are mentioned regarding Lohit Telugu in this bug.

 It will be nice if we can make this as a tracker bug and report new bugs for each type of combination problems

i.e.

1)  >స్టైల్ = problem in స్టై (sty) :- This is problem regarding below base matra merging with below base half form of consonant. There are so many other such combination please mentioned few more like these.
2)  >స్మైల్ = problem in స్మై (smy) :- 
  >వక్తృత్వము = problem in క్తృ (kthru)

In this matra is merging with next part of half form of consonant

3)   >భ్రాహ్మణ = problem in భ్రా (bhrA):- This is different kind of problem and there are so many combination affecting this.

4)  1. ర్యక్ర  (ryakra) :- This is as well
5) ప్టు     (ptu)  : This as well

Fixing all together is big change, i think better if we can fix single category of bugs test it and then move for next bug.

Comment 9 Pravin Satpute 2011-06-20 07:10:51 UTC
thanks Aman for splitting bugs !!

Comment 10 A S Alam 2011-08-19 10:49:08 UTC
All dependent bugs are closed in Fedora 15
Closing this bug as 'NEXTRELEASE'

Comment 11 Fedora Update System 2012-02-22 11:44:29 UTC
lohit-telugu-fonts-2.5.0-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/lohit-telugu-fonts-2.5.0-3.fc17

Comment 12 Fedora Update System 2012-04-25 17:34:16 UTC
lohit-telugu-fonts-2.5.1-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/lohit-telugu-fonts-2.5.1-2.fc17

Comment 13 Fedora Update System 2012-05-26 07:48:53 UTC
lohit-telugu-fonts-2.5.1-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.