Bug 714561 - [te_IN] Positioning is improper in భ్రా and similar combinations
Summary: [te_IN] Positioning is improper in భ్రా and similar combinations
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: lohit-telugu-fonts
Version: 15
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Pravin Satpute
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 640607
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-06-20 05:08 UTC by A S Alam
Modified: 2013-07-03 01:08 UTC (History)
6 users (show)

Fixed In Version: lohit-telugu-fonts-2.4.5-14.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of: 640607
Environment:
Last Closed: 2011-08-19 10:45:15 UTC
Type: ---


Attachments (Terms of Use)
List of combinations those having same positioning problem (9.30 KB, application/octet-stream)
2011-06-30 11:27 UTC, Krishna Babu K
no flags Details
Fixed Screenshot (75.40 KB, image/png)
2011-08-19 10:43 UTC, A S Alam
no flags Details

Description A S Alam 2011-06-20 05:08:20 UTC
THIS BUG IS CLONE FOR FOLLOWING ISSUE [3]:
---
3)   >భ్రాహ్మణ = problem in భ్రా (bhrA):- This is different kind of problem and
there are so many combination affecting this.
---

+++ This bug was initially created as a clone of Bug #640607 +++

Created attachment 451886 [details]
File contains the characters list for which problem exist

Description of problem:

Some part on Left hand side missing for these combinations. Please go through the attachment.
Version-Release number of selected component (if applicable):

lohit-telugu-fonts-2.4.5-5.fc14.noarch

How reproducible:
Every time.
Steps to Reproduce:
1. Open gedit and input the combinations mentioned in the attachment using input method.
2. Or else open the attachment in gedit.
3. Observe the left hand side of every combination which is not appearing properly.
  
Actual results:

Text does not appear completely.

Expected results:

Text should appear completely.

Additional info:

Please go through the attachment.

--- Additional comment from psatpute@redhat.com on 2010-10-07 10:37:51 IST ---

in attached gedit file it looks proper, please attach application image where characters are cutting, its version etc

--- Additional comment from kkrothap@redhat.com on 2010-10-12 12:19:44 IST ---

Hi,

Please follow the version number, the problem still exist. And when we open the attached file in gedit we can identify the problem.

--- Additional comment from psatpute@redhat.com on 2010-10-22 13:02:42 IST ---

yeah, saw it, glyphs are cutting from left sides 
as per we discussed last time we should reduce below based shape, so that they can accommodate properly below the base shape.

need to change many shape, will work on it

--- Additional comment from arjunaraoc@googlemail.com on 2010-12-23 14:55:25 IST ---

Created attachment 470391 [details]
Overlapping glyphs issue

Many of these combinations  mentioned in this bug,   do not usually occur as first character on  aline. Hence the problem  may not be that severe. I show below a  test case,  where I have noticed  somewhat critical  overlapping of glyphs, which can  be looked into first.
Overlapping Glyphs  for Telugu Font Needing Correction
1. ర్యక్ర  (ryakra)
2. ప్టు     (ptu)

Pl. see the attached   image.

--- Additional comment from kkrothap@redhat.com on 2010-12-23 17:57:07 IST ---

(In reply to comment #4)
> Created attachment 470391 [details]
> Overlapping glyphs issue
> 
> Many of these combinations  mentioned in this bug,   do not usually occur as
> first character on  aline. Hence the problem  may not be that severe. I show
> below a  test case,  where I have noticed  somewhat critical  overlapping of
> glyphs, which can  be looked into first.
> Overlapping Glyphs  for Telugu Font Needing Correction
> 1. ర్యక్ర  (ryakra)
> 2. ప్టు     (ptu)
> 
> Pl. see the attached   image.

some more problems need attention:

  స్టైల్ = problem in స్టై (sty)
  స్మైల్ = problem in స్మై (smy)
  వక్తృత్వము = problem in క్తృ (kthru)
  భ్రాహ్మణ = problem in భ్రా (bhrA)

Thanks,
krishna.

--- Additional comment from psatpute@redhat.com on 2010-12-27 10:18:06 IST ---

Arjun, yes thanks for point the must one
i will try to resolve those soon

--- Additional comment from kkrothap@redhat.com on 2011-02-14 15:25:28 IST ---

(In reply to comment #6)
> Arjun, yes thanks for point the must one
> i will try to resolve those soon

Hi Pravin,

>some more problems need attention:

  >స్టైల్ = problem in స్టై (sty)
  >స్మైల్ = problem in స్మై (smy)
  >వక్తృత్వము = problem in క్తృ (kthru)
  >భ్రాహ్మణ = problem in భ్రా (bhrA)

 In the above examples, if we consider the fourth one it has half 'ra' as below
base. When ever we use this half 'ra' with vowel sign 'aA' on any consonant it
has some problem, the below base half 'ra' moving towards right side which
should stay exactly below the consonant. Since this usage is more in locale
'te_IN' we should fix this soon. 

 As a whole, these issues need to be fixed because most of them are frequent in
te_IN usage.

Thanks,
Krishna.

--- Additional comment from psatpute@redhat.com on 2011-06-20 00:11:59 IST ---

Hi Krishna,

 presently this looks very generic bug i.e. "improve telugu fonts" and so many different kinds of bugs are mentioned regarding Lohit Telugu in this bug.

 It will be nice if we can make this as a tracker bug and report new bugs for each type of combination problems

i.e.

1)  >స్టైల్ = problem in స్టై (sty) :- This is problem regarding below base matra merging with below base half form of consonant. There are so many other such combination please mentioned few more like these.
2)  >స్మైల్ = problem in స్మై (smy) :- 
  >వక్తృత్వము = problem in క్తృ (kthru)

In this matra is merging with next part of half form of consonant

3)   >భ్రాహ్మణ = problem in భ్రా (bhrA):- This is different kind of problem and there are so many combination affecting this.

4)  1. ర్యక్ర  (ryakra) :- This is as well
5) ప్టు     (ptu)  : This as well

Fixing all together is big change, i think better if we can fix single category of bugs test it and then move for next bug.

Comment 1 Krishna Babu K 2011-06-30 11:27:09 UTC
Created attachment 510639 [details]
List of combinations those having same positioning problem

Hi Praveen,

  The list contains the combinations those have "half 'ra'" positioning problem.
The "half 'ra'" is positioning wrongly when applying some vowel signs on conjuncts.

Regards,
Krishna.

Comment 2 Fedora Update System 2011-07-01 08:11:13 UTC
lohit-telugu-fonts-2.4.5-11.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/lohit-telugu-fonts-2.4.5-11.fc15

Comment 3 Fedora Update System 2011-07-01 18:59:45 UTC
Package lohit-telugu-fonts-2.4.5-11.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing lohit-telugu-fonts-2.4.5-11.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/lohit-telugu-fonts-2.4.5-11.fc15
then log in and leave karma (feedback).

Comment 4 Fedora Update System 2011-07-18 08:17:30 UTC
lohit-telugu-fonts-2.4.5-12.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/lohit-telugu-fonts-2.4.5-12.fc15

Comment 5 Fedora Update System 2011-07-20 11:35:31 UTC
lohit-telugu-fonts-2.4.5-13.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/lohit-telugu-fonts-2.4.5-13.fc15

Comment 6 Fedora Update System 2011-07-27 14:34:23 UTC
lohit-telugu-fonts-2.4.5-14.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/lohit-telugu-fonts-2.4.5-14.fc15

Comment 7 A S Alam 2011-08-19 10:43:28 UTC
Created attachment 519010 [details]
Fixed Screenshot

Comment 8 A S Alam 2011-08-19 10:45:15 UTC
This is fixed, tested with following package:
lohit-telugu-fonts-2.4.5-14.fc15.noarch

Comment 9 Fedora Update System 2011-09-02 05:32:05 UTC
lohit-telugu-fonts-2.4.5-14.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.