Bug 6409 - NS 4.7 and/or GNOME - 2 problems.
NS 4.7 and/or GNOME - 2 problems.
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: netscape (Show other bugs)
6.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
:
: 5053 6218 7659 11438 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-26 23:42 EDT by mathew_2000
Modified: 2014-03-16 22:10 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-01 22:07:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mathew_2000 1999-10-26 23:42:29 EDT
NS 4.7  and/or GNOME
running RH 6.0 with latest GNOME and NS 4.7 patches...

problem 1)
summary: ability to enter info, and use alt-N, and use
         arrow keys fails if you encounter a multi-column
         pull-down form.

to reproduce:
a) (re)start NS browser. (one window only)
b) entire www.autotrader.com
c) select a make from column 2 - say MG
d) attempt to fill in zip code. FAILURE.

noticed the following behaviour -
when I changed windows (even to another NS window, or
xterm) and then returned to the 'stuck' window
the functionality returned.

thus uncertain if the problem is in NS or GNOME.

problem 2)
summary: open numerous NS windows, and when shutting
         individual windows down (with the X in upper
         right corner of GNOME window.) sometimes
         destroying (deconstructing) a child window
         will deconstruct ALL NS windows.

unable to reporduce at will.
wonder if the problem maybe memory related....

THIS is VERY annoying to new linux users -
can be enough to turn them away.

thanks
Comment 1 Bill Nottingham 1999-10-27 10:46:59 EDT
I can't reproduce this here.

Going to the specified URL, and picking something in the form,
I can still use alt-n to open new windows, use the arrow keys to
scroll the window, and I can click on the zip code box to enter
text.

As for the second one, netscape is most likely exiting with a
bus error; I've seen it before, but it's fairly hard to reproduce.
Comment 2 Chris Siebenmann 1999-10-28 01:00:59 EDT
The close-a-window-and-Netscape-explodes bug seems to have first
appeared after the latest round of XFree86 updates for Redhat 5.2.
(Indeed, I have a perfectly stable NS 4.7 that is pointed to a
private copy of the old X libraries, and libc5 versions don't seem
to have the problem either, although of course they have other ones.)

 I theorize that Netscape has built Navigator and Communicator
against old X libraries and there is some subtle compatability
problem, or a subtle bug in their code that is being exposed by
the upgrade. (I have strace/ltrace/gdb output of a crash under
NS 4.61 and Redhat 5.1+new libraries, for any interested parties.)
Comment 3 Bill Nottingham 1999-10-28 11:46:59 EDT
Sure, send the traces. (please, don't cut and paste them. ;) )
Comment 4 Bill Nottingham 1999-11-01 13:58:59 EST
*** Bug 6218 has been marked as a duplicate of this bug. ***

The keyboard locks up in Netscape 4.7 after choosing an item
from a <SELECT> drop down box with a long list of items.
I created an example demonstration of the bug at
http://www.taco.org/foo.html .  This makes it impossible to
fill out a whole bunch of forms out there!

------- Additional Comments From notting@redhat.com  10/29/99 17:20 -------
Can't reproduce this here.

There is a known problem with the focus in regard to
some select lists under some window managers; try focusing
a different window, and then reselecting netscape.
Comment 5 Bill Nottingham 2000-02-01 22:01:59 EST
*** Bug 7659 has been marked as a duplicate of this bug. ***
Comment 6 Bill Nottingham 2000-02-01 22:07:59 EST
The problems with crashing (most likely with the Motif code) have
been reported to Netscape. No fixes yet.
Comment 7 Bill Nottingham 2000-02-01 22:12:59 EST
*** Bug 5053 has been marked as a duplicate of this bug. ***
Comment 8 Bill Nottingham 2000-05-16 12:09:59 EDT
*** Bug 11438 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.