Bug 640977 - RFE: systemtap-runtime inclusion
RFE: systemtap-runtime inclusion
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.1
All Linux
low Severity medium
: rc
: ---
Assigned To: Mike Burns
Virtualization Bugs
: FutureFeature
: 676515 (view as bug list)
Depends On: 634995
Blocks: 698469
  Show dependency treegraph
 
Reported: 2010-10-07 08:27 EDT by Frank Ch. Eigler
Modified: 2011-08-19 11:25 EDT (History)
10 users (show)

See Also:
Fixed In Version: ovirt-node-1.9.3-17.el6
Doc Type: Enhancement
Doc Text:
Key systemtap-runtime parts such as /usr/bin/staprun and /usr/bin/stapio are now included in the Red Hat Enterprise Virtualization Hypervisor image to allow remote invocation of systemtap probing.
Story Points: ---
Clone Of:
: 698469 (view as bug list)
Environment:
Last Closed: 2011-08-19 11:25:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch (625 bytes, patch)
2011-02-03 15:14 EST, Mike Burns
no flags Details | Diff

  None (edit)
Description Frank Ch. Eigler 2010-10-07 08:27:19 EDT
Please include key parts of systemtap-runtime in the RHEV-H image, to
permit remotely invoked systemtap probing.  As of systemtap-1.3, these
parts would be:

/usr/bin/staprun
/usr/bin/stapio

By RHEL6.1, systemtap-1.4 should be available, and may include an 
additional small binary to help smoothen the remote probing task.
Comment 1 Frank Ch. Eigler 2010-10-07 08:28:54 EDT
Bug #634995 covers the future stap-1.4 rebase.
Comment 4 Frank Ch. Eigler 2010-10-07 10:31:26 EDT
The way this would work with current-day code is that a development/management
machine, with all the debuginfo / compilers goo installed, would have a stap
user run 

   stap -p4 FOO.stp
   scp FOOBAR.ko root@rhev-host:FOOBAR.ko
   ssh root@rhev-host staprun FOOBAR.ko

basically according to the 'cross-compilation' pattern of operation.  There
is currently no man page that spells out this sequence, but is outlined on
our wiki:

http://sourceware.org/systemtap/wiki/TipCrossCompiling

With systemtap 1.4, these steps will be automated (with a proper man page
blurb).
Comment 5 Mike Burns 2011-02-03 15:14:37 EST
Created attachment 476867 [details]
Patch

Note:  bug asks for /usr/bin/stapio, but rpm adds /usr/libexec/systemtap/stapio instead

Testing:  
rpm -qa systemtap-runtime
ls /usr/bin/staprun
ls /usr/libexec/systemtap/stapio
Comment 6 Alan Pevec 2011-02-10 03:53:42 EST
*** Bug 676515 has been marked as a duplicate of this bug. ***
Comment 8 Mohua Li 2011-03-07 02:22:37 EST
rhevh 6.1-8

[root@intel-x5550-12-2 ~]# rpm -ql systemtap-runtime | grep staprun
/usr/bin/staprun
/usr/share/man/man8/staprun.8.gz
[root@intel-x5550-12-2 ~]# rpm -ql  systemtap-runtime | grep stapio
/usr/libexec/systemtap/stapio
[root@intel-x5550-12-2 ~]#
Comment 9 Mark Huth 2011-04-20 18:39:00 EDT
Is it possible to get systemtap in the RHEVH 5.x as well?
Comment 13 Misha H. Ali 2011-05-06 03:03:54 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Key systemtap-runtime parts such as /usr/bin/staprun and /usr/bin/stapio are now included in the Red Hat Enterprise Virtualization Hypervisor image to allow remote invocation of systemtap probing.

Note You need to log in before you can comment on or make changes to this bug.