Bug 64166 - xscreensaver's blaster locks up requiring reboot
xscreensaver's blaster locks up requiring reboot
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: xscreensaver (Show other bugs)
skipjack-beta2
All Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
:
: 64419 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-26 22:45 EDT by windonstewart
Modified: 2014-03-16 22:27 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-12 03:18:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to repair xscreensaver's blaster (1.26 KB, patch)
2002-04-26 22:48 EDT, windonstewart
no flags Details | Diff

  None (edit)
Description windonstewart 2002-04-26 22:45:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020408

Description of problem:
Code in blaster generates invalid coordinates for XDrawLine function calls
causing a freeze that requires reboot at least for savage4.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Select blaster in xscreensaver with either no parameters or combination that
allows laser fire among robots.
2. Let it run for a few seconds.


Actual Results:  Screen freezes and will not respond to <CTRL><ALT><BACKSPACE>
or terminal switching. At least, it will generate some laser fire from robots
with random coordinates (extremely large positive and negative int values).

Expected Results:  Screensaver should continue until terminated.

Additional info:

I have created a patch that fixes this problem.
Comment 1 windonstewart 2002-04-26 22:48:07 EDT
Created attachment 55584 [details]
Patch to repair xscreensaver's blaster
Comment 2 petrosyan 2002-04-28 01:34:09 EDT
this bug is very close to your bug:
http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=63916

that laptop also has S3 Savage videocard.

to you see any freezes with the critical screensaver ?
Comment 3 windonstewart 2002-04-30 02:12:39 EDT
hayastan132, you are not going to believe this, but after posting my blaster
patch here, I did a query for other xscreensaver stuff and found bug 63916
before you posted under mine. LOL. I tried critical right after reading it and
it locked up my desktop just as you described it did on your laptop.

So it prompted me to create a patch for critical as well.

The connection I found was that the individual screensavers didn't initialize a
coordinate for XDrawLine which caused savage (or maybe others) drivers to crash.
Regardless of the driver used, the screensavers need to be corrected so it will
display properly with the correct coordinates, but something needs fixing in X
itself to keep it from crashing.

I'll post my critical patch and my findings under 63916.

 Windon Stewart
Comment 4 Bill Nottingham 2002-06-12 02:42:08 EDT
*** Bug 64419 has been marked as a duplicate of this bug. ***
Comment 5 Bill Nottingham 2002-06-12 02:50:26 EDT
This appears to be fixed in 4.05-1.

Note You need to log in before you can comment on or make changes to this bug.