Bug 641861 - Interactive install results in multiple root vg groups
Summary: Interactive install results in multiple root vg groups
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda
Version: 6.0
Hardware: All
OS: Linux
high
urgent
Target Milestone: rc
: ---
Assignee: Chris Lumens
QA Contact: Release Test Team
URL:
Whiteboard:
: 718318 743378 813403 (view as bug list)
Depends On:
Blocks: GSS_6_2_PROPOSED 705163
TreeView+ depends on / blocked
 
Reported: 2010-10-11 10:46 UTC by lgillesp
Modified: 2018-11-14 17:01 UTC (History)
10 users (show)

Fixed In Version: anaconda-13.21.134-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 10:27:11 UTC
Target Upstream Version:


Attachments (Terms of Use)
Firsts boot can't mount root file systems (142.82 KB, image/pjpeg)
2010-10-11 10:46 UTC, lgillesp
no flags Details
Parition review showing multiple rootvg's (94.54 KB, image/pjpeg)
2010-10-11 10:47 UTC, lgillesp
no flags Details
anaconda.log, storage.log from miniroot /tmp fs (90.00 KB, application/octet-stream)
2010-10-11 10:52 UTC, lgillesp
no flags Details
screenshot of partitions (136.36 KB, image/png)
2011-08-25 14:24 UTC, Alexander Todorov
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Legacy) 55935 None None None Never
Red Hat Product Errata RHBA-2011:1565 normal SHIPPED_LIVE anaconda bug fix and enhancement update 2011-12-06 00:39:12 UTC

Internal Links: 813403

Description lgillesp 2010-10-11 10:46:00 UTC
Created attachment 452687 [details]
Firsts boot can't mount root file systems

Description of problem:

I am using the following kickstart file to install a system. With the
interactive keyword commented out the install completes successfully and the
system partitioning is created as expected.

If I use the interactive keyword in the kickstart file and perform the install
and then select "Basic Storage Devices", "Replace Existing Linux System(s)" and
"review and modify partitioning layout". The installation will be performed, however two sets of system volume groups have been created on the disk and the subsequent first boot will fail. 

-----------------------
# Kickstart file automatically generated by anaconda.

#version=RHEL6
install
cdrom
interactive
reboot
lang en_GB.UTF-8
keyboard uk
rootpw  --iscrypted $6$8KyTfVTUV6v9zcTP$aRBMbuS7b65XjwZAI6pjkqW4kPO8wwp5nK1npQ2.WJoK.z/Bt0z26ZP6klhTSaJ0Iw02IgynCLHf.H7UibS9D.
firewall --service=ssh
authconfig --enableshadow --passalgo=sha512 --enablefingerprint
selinux --enforcing
timezone --utc Europe/London
bootloader --location=mbr --driveorder=sda --append="crashkernel=auto rhgb quiet"
# The following is the partition information you requested
# Note that any partitions you deleted are not expressed
# here so unless you clear all partitions first, this is
# not guaranteed to work
clearpart --linux --drives=sda
ignoredisk --only-use=sda
part /boot --fstype=ext4 --asprimary --size=500
part pv.0lGfcW-iiiP-NN0w-fjLc-1SHE-YIKj-ctuItT --size=51200
volgroup VolGroup --pesize=4096 pv.0lGfcW-iiiP-NN0w-fjLc-1SHE-YIKj-ctuItT
logvol /kickstart --fstype=ext4 --name=lv_kickstart --vgname=VolGroup --size=22024
logvol / --fstype=ext4 --name=lv_root --vgname=VolGroup --size=8192
logvol swap --name=lv_swap --vgname=VolGroup --size=2048
logvol /var --fstype=ext4 --name=lv_var --vgname=VolGroup --size=4096

%packages
@base
@console-internet
@core
@debugging
@directory-client
@hardware-monitoring
@java-platform
@large-systems
@network-file-system-client
@performance
@perl-runtime
@server-platform
pax
python-dmidecode
oddjob
sgpio
certmonger
pam_krb5
krb5-workstation
nscd
pam_ldap
nss-pam-ldapd
perl-DBD-SQLite
%end
-----------------------------

Version-Release number of selected component (if applicable):

anaconda 13.21.56


How reproducible:

1. Boot Redhat Enterprise Linux 6 Beta 2 Refresh cdrom and use the kickstart
file above.

2. In the anaconda screens select "Basic Storage Devices" and then later
"Replace Existing Linux System(s) and "review and modify partitioning layout".
(see attachment fixed-partition-view.jpg

The installation will be performed, however two sets of system volume groups have been created on the disk and the subsequent first boot will fail. 
(see attachment cant_mount_rootfs.jpg)

Expected results:

Partition configuration as defined in the kickstart file is displayed correctly
on screen and could be modified if required. 

Additional info:

This is the error with the fix suggested for my original bugzilla # 632181.

Comment 1 lgillesp 2010-10-11 10:47:02 UTC
Created attachment 452688 [details]
Parition review showing multiple rootvg's

Comment 2 lgillesp 2010-10-11 10:52:52 UTC
Created attachment 452690 [details]
anaconda.log, storage.log from miniroot /tmp fs

Comment 4 lgillesp 2010-10-11 10:56:11 UTC
As a Global IT Outsourcing Company we use the Kickstart file to allow us to
create a standard build for all our systems. Many kickstart elements are used
to that end, which include custom scripts in the anaconda pre and post sections
as well as files and scripts that copied and used during the first boot of the
installed system. This allows us to take many tasks that are routinely
performed by our system engineers worldwide to be automated resulting in a time
saving to us and a cost reduction to our clients. The "interactive" key word is
used and allows site specific tayloring in terms of package selection and disk
layout to be performed whilst maintaining a single standard build for all our
systems.

If the disk and partitioning information is removed from the kickstart file the
paritition screen appears and a manual disk partition can be created. However,
the Basic or Specialised screen is not displayed and if you are installing to 
iSCSI or SAN attached disks the install will fail as the installation has
assumed Basic disk setup.

Comment 8 Chris Lumens 2011-08-03 14:54:15 UTC
*** Bug 718318 has been marked as a duplicate of this bug. ***

Comment 10 Alexander Todorov 2011-08-25 14:24:20 UTC
Created attachment 519877 [details]
screenshot of partitions

I wasn't able to reproduce the original issue where there are duplicate partitions. However I was able to reproduce the issue in the duplicate bug where anaconda ignored the partitioning scheme and selected the default when run with ks.cfg in interactive mode. 

Then tested with anaconda-13.21.136-1.el6.x86_64 / 0825.n.0 and 

interactive

zerombr
bootloader --location=mbr
clearpart --linux --drives=vda
ignoredisk --only-use=vda

part /boot --fstype=ext4 --asprimary --size=500
part pv.01 --size=19979
volgroup VolGroup --pesize=4096 pv.01

logvol /kickstart --fstype=ext4 --name=lv_kickstart --vgname=VolGroup --size=1024
logvol / --fstype=ext4 --name=lv_root --vgname=VolGroup --size=4096
logvol swap --name=lv_swap --vgname=VolGroup --size=1024
logvol /var --fstype=ext4 --name=lv_var --vgname=VolGroup --size=4096




The screenshot is after selecting Review the selected partitioning.

Comment 11 lgillesp 2011-08-26 09:03:16 UTC
Can you confirm that this has also been fixed:

"If the disk and partitioning information is removed from the kickstart file the
paritition screen appears and a manual disk partition can be created. However,
the Basic or Specialised screen is not displayed and if you are installing to 
iSCSI or SAN attached disks the install will fail as the installation has
assumed Basic disk setup."

You may want to try this with and without the interactive keyword.

Comment 12 David Cantrell 2011-10-04 18:18:39 UTC
*** Bug 743378 has been marked as a duplicate of this bug. ***

Comment 13 errata-xmlrpc 2011-12-06 10:27:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1565.html

Comment 14 David Cantrell 2012-07-05 15:28:57 UTC
*** Bug 813403 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.