Bug 813403 - Partitioning exception with kickstart "interactive" mode and LVM disk
Partitioning exception with kickstart "interactive" mode and LVM disk
Status: CLOSED DUPLICATE of bug 641861
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.2
All Linux
unspecified Severity low
: rc
: ---
Assigned To: David Lehman
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-17 12:31 EDT by Greg Edwards
Modified: 2012-07-05 11:28 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-05 11:28:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda log from failed install attempt (8.14 KB, text/x-log)
2012-04-17 12:31 EDT, Greg Edwards
no flags Details
demo kickstart file (758 bytes, text/plain)
2012-04-17 12:31 EDT, Greg Edwards
no flags Details
proposed patch (1.49 KB, patch)
2012-04-17 12:32 EDT, Greg Edwards
no flags Details | Diff

  None (edit)
Description Greg Edwards 2012-04-17 12:31:03 EDT
Created attachment 578096 [details]
anaconda log from failed install attempt

Description of problem:

A divide by zero exception can be triggered in anaconda when performing a kickstart install with the "interactive" kickstart option enabled, to a disk with existing LVM volumes, and choosing "Create Custom Layout" partitioning option.

With the above on RHEL 6.2, if you click on any of the LVM volumes in the subsequent pane, you will trigger a python exception.


Version-Release number of selected component (if applicable):

RHEL 6.2, anaconda-13.21.149-1.el6


How reproducible:

always


Steps to Reproduce:
1. Disk with existing LVM volumes
2. Kickstart install
3. Kickstart "interactive" option enabled
4. Select "Create Custom Layout"
5. Click on one of the existing LVM volumes

  
Actual results:

Python exception occurs:

09:33:58,926 CRITICAL: anaconda 13.21.149 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.6/decimal.py", line 3778, in _raise_error
    raise error(explanation)
  File "/usr/lib64/python2.6/decimal.py", line 1248, in __truediv__
    return context._raise_error(DivisionByZero, 'x / 0', sign)
  File "/usr/lib/anaconda/iw/partition_gui.py", line 495, in _createStripe
    xlength = Decimal(str(lv.size)) / Decimal(str(vg.size))
  File "/usr/lib/anaconda/iw/partition_gui.py", line 301, in setDisplayed
    self.stripe = self._createStripe(obj)
  File "/usr/lib/anaconda/iw/partition_gui.py", line 476, in __init__
    self.setDisplayed(vg)
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1285, in treeSelectCB
    dcCB = self.barviewActivateCB)
DivisionByZero: x / 0


Expected results:

No exception.

Additional info:

For background info, see RH BZ#641861 and upstream anaconda commit d826ef84e22a4dba55850d8232229275617bfd61.
Comment 1 Greg Edwards 2012-04-17 12:31:39 EDT
Created attachment 578097 [details]
demo kickstart file
Comment 3 Greg Edwards 2012-04-17 12:32:07 EDT
Created attachment 578098 [details]
proposed patch
Comment 4 David Cantrell 2012-07-05 11:28:57 EDT
Fixed in RHEL 6.2 and later.

*** This bug has been marked as a duplicate of bug 641861 ***

Note You need to log in before you can comment on or make changes to this bug.