Bug 64193 - Gtkam terminates with broken pipe error message
Gtkam terminates with broken pipe error message
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gphoto2 (Show other bugs)
7.3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Tim Waugh
:
: 64493 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-28 13:12 EDT by W. Michael Petullo
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-09 15:44:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Gzipped output of "strace -f gtkam 2>logfile" (230k uncompressed) (23.30 KB, application/octet-stream)
2002-05-09 13:54 EDT, Matthias Saou
no flags Details

  None (edit)
Description W. Michael Petullo 2002-04-28 13:12:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.0 (X11; Linux i686; U;) Gecko/20020314

Description of problem:
This bug belongs in the gtkam category, not gphoto2.  However, I could not find
gtkam in the component listing.

If a user selects the gtkam Camera->Select Camera... menu item, the program
terminates with a "Broken pipe" error.

My custom built gtkam worked fine until I upgraded to skipjack 2.  Re-compiling
the gtkam source code I used before does not work, implying the problem may lie
in a shared library (see backtrace in additional information field).

Version-Release number of selected component (if applicable):
0.1.3-0.cvs20020225.2

How reproducible:
Always

Steps to Reproduce:
1.  Load gtkam
2.  Select the Camera->Select Camera... menu item
	

Actual Results:  Gtkam terminates with a "Broken pipe" error.

Expected Results:  A dialog box should open, allowing me to select my Canon
Digital IXUS camera.

Additional info:

The following gdb backtrace seems to imply the fault lies in X, gtk+, or the
improper use of either:

Program received signal SIGPIPE, Broken pipe.
0x420dadc4 in write () from /lib/i686/libc.so.6
(gdb) ba
#0  0x420dadc4 in write () from /lib/i686/libc.so.6
#1  0x40295d44 in _XlcPublicMethods () from /usr/X11R6/lib/libX11.so.6
#2  0x4020f617 in _X11TransWrite () from /usr/X11R6/lib/libX11.so.6
#3  0x401f2a1d in _XFlush () from /usr/X11R6/lib/libX11.so.6
#4  0x401f3ec7 in _XReply () from /usr/X11R6/lib/libX11.so.6
#5  0x401e2253 in XInternAtom () from /usr/X11R6/lib/libX11.so.6
#6  0x4016d4c3 in gdk_atom_intern () from /usr/lib/libgdk-1.2.so.0
#7  0x40082e01 in gtk_editable_init () from /usr/lib/libgtk-1.2.so.0
#8  0x4010fb14 in gtk_type_new () from /usr/lib/libgtk-1.2.so.0
#9  0x4008495f in gtk_entry_new () from /usr/lib/libgtk-1.2.so.0
#10 0x4006a6f7 in gtk_combo_init () from /usr/lib/libgtk-1.2.so.0
#11 0x4010fb70 in gtk_type_new () from /usr/lib/libgtk-1.2.so.0
#12 0x4006ad1f in gtk_combo_new () from /usr/lib/libgtk-1.2.so.0
#13 0x08060cf0 in gtkam_chooser_new () at gtkam-chooser.c:608
#14 0x080543c1 in on_select_camera_activate (item=0x809dff4, m=0x80949c8)
    at gtkam-main.c:322
#15 0x400b2de1 in gtk_marshal_NONE__NONE () from /usr/lib/libgtk-1.2.so.0
#16 0x400e6436 in gtk_handlers_run () from /usr/lib/libgtk-1.2.so.0
#17 0x400e576d in gtk_signal_real_emit () from /usr/lib/libgtk-1.2.so.0
#18 0x400e3525 in gtk_signal_emit () from /usr/lib/libgtk-1.2.so.0
#19 0x4011dcd0 in gtk_widget_activate () from /usr/lib/libgtk-1.2.so.0
#20 0x400bbc39 in gtk_menu_shell_activate_item () from /usr/lib/libgtk-1.2.so.0
#21 0x400bad92 in gtk_menu_shell_button_release ()
#22 0x400b2aec in gtk_marshal_BOOL__POINTER () from /usr/lib/libgtk-1.2.so.0
#23 0x400e57ad in gtk_signal_real_emit () from /usr/lib/libgtk-1.2.so.0
#24 0x400e3525 in gtk_signal_emit () from /usr/lib/libgtk-1.2.so.0
#25 0x4011db89 in gtk_widget_event () from /usr/lib/libgtk-1.2.so.0
#26 0x400b2a45 in gtk_propagate_event () from /usr/lib/libgtk-1.2.so.0
#27 0x400b1a6f in gtk_main_do_event () from /usr/lib/libgtk-1.2.so.0
#28 0x40163d7f in gdk_event_dispatch () from /usr/lib/libgdk-1.2.so.0
#29 0x40196773 in g_main_dispatch () from /usr/lib/libglib-1.2.so.0
#30 0x40196d39 in g_main_iterate () from /usr/lib/libglib-1.2.so.0
#31 0x40196eec in g_main_run () from /usr/lib/libglib-1.2.so.0
#32 0x400b1333 in gtk_main () from /usr/lib/libgtk-1.2.so.0
#33 0x08058a27 in main (argc=1, argv=0xbffff804) at main.c:183
#34 0x420174d9 in __libc_start_main () from /lib/i686/libc.so.6
Comment 1 Tim Waugh 2002-04-29 03:33:28 EDT
I can't reproduce this; it works for me.  How exactly are you invoking gtkam?  
Is it on a remote display?  Does gphoto2 work from the command line?
Comment 2 W. Michael Petullo 2002-05-01 11:51:11 EDT
I am invoking gtkam from the command line (or from gdb) with `gtkam.`  Gphoto2
works fine from the command line.  I am running gtkam on a local display.  I
will try to debug this a little more when I find the time, but I can't think of
anything odd about my setup.
Comment 3 Tim Waugh 2002-05-07 03:32:22 EDT
*** Bug 64493 has been marked as a duplicate of this bug. ***
Comment 4 Matthias Saou 2002-05-07 04:37:38 EDT
Same for me : Nothing strange about my setup either, and my own gtkam/gphoto2
packages worked fine before on this same laptop running Red Hat Linux 7.2, but I
get this exact same "Broken pipe" message with a completely new reinstalled 7.3
system.

I've tried to update gtkam to today's CVS tree, and now I get the "Broken pipe"
message right after running "gtkam", not only once I go to the "Camera" menu and
choose "Select camera".

Haven't tried gphoto2 directly from the command line though, as I never used it
yet, and thus don't really know how to use it ;-)
Comment 5 W. Michael Petullo 2002-05-09 12:16:29 EDT
I upgraded to 7.3's XFree86-libs-4.2.0-8.i386.rpm and everything started to
work.  I have no more problems with gtkam.  Hmm...
Comment 6 Tim Waugh 2002-05-09 12:21:43 EDT
Matthias: can you confirm that you already have that version of XFree86-libs, 
from your 7.3 installation?
Comment 7 Matthias Saou 2002-05-09 12:58:50 EDT
Yup, I'm already running that one ever since the computer was installed :-(
Could it be that something else was modified at the same time that lib was
updated to the 7.3 one on redhat@flyn.org's system?

[dude@python dude]$ rpm -q gphoto2 gtkam XFree86-libs
gphoto2-2.0-4
gtkam-0.1.3-0.cvs20020225.2
XFree86-libs-4.2.0-8

Since lat time, I've tried many things :
- Rawhide gphoto3 packages -> same error
- Rebuilding the current CVS gtkam tree -> Error even earlier (as mentionned in
my last post)
- Rebuilding the previous gtkam I was using (Nov 2001) -> Doesn't compile with
current gphoto2

I still haven't emptied my camera since I upgraded to 7.3, but it's getting kind
of urgent now ;-)
Comment 8 Matthias Saou 2002-05-09 13:34:38 EDT
Sorry for being so tired. I bet I got some of you wondering for a moment.
There is of course no such thing as gphoto3 in Rawhide, my finger just got out
of hand (so to speak) and hit 3 instead of 3... errr, 2 that is ;-) Sorry!

BTW, other precision : I tried both as a regular user with a brand new ~/
directory and as root on my new system (so near to nothing in /root), and same
error. I also thought of using my old ~/.gphoto2 directory to see, but as I used
console-helper with my prevous gtkam package, it was always run as root, thus
the files were in /root/ that I didn't backup from my 7.2 system.
Comment 9 Tim Waugh 2002-05-09 13:47:03 EDT
Okay.  Please try the following: 
 
  strace -f gtkam 2>logfile 
 
and make it fail.  Then attach the logfile to this report.  Thanks.
Comment 10 Tim Waugh 2002-05-09 13:47:52 EDT
Changing product to Red Hat Linux.
Comment 11 Matthias Saou 2002-05-09 13:54:14 EDT
Created attachment 56824 [details]
Gzipped output of "strace -f gtkam 2>logfile" (230k uncompressed)
Comment 12 Tim Waugh 2002-05-09 14:21:46 EDT
Aha.  Do you have 'lockdev' installed?  There seems to be a missing dependency 
on this package in the gphoto2 package.
Comment 13 Matthias Saou 2002-05-09 15:44:09 EDT
Aha indeed! That was it! It's working perfectly now, got all my pictures
transfered within seconds, and I must say that this more recent version of gtkam
has improved a lot.

Thanks a lot for your help,
Matthias
Comment 14 Tim Waugh 2002-05-09 16:32:04 EDT
Thanks for helping debug it.  Fixed package is gphoto2-2.0-7.

Note You need to log in before you can comment on or make changes to this bug.