Bug 641936 - spacewalk-create-channel, man page typos
spacewalk-create-channel, man page typos
Status: CLOSED ERRATA
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Usability (Show other bugs)
540
All Linux
low Severity medium
: ---
: ---
Assigned To: Miroslav Suchý
Šimon Lukašík
:
: 681235 (view as bug list)
Depends On:
Blocks: sat541-triage
  Show dependency treegraph
 
Reported: 2010-10-11 10:57 EDT by Petr Sklenar
Modified: 2012-03-08 04:06 EST (History)
5 users (show)

See Also:
Fixed In Version: spacewalk-remote-utils-1.0.2-12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-05 07:12:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Petr Sklenar 2010-10-11 10:57:42 EDT
Description of problem:
man typos

Version-Release number of selected component (if applicable):
spacewalk-remote-utils-1.0.2-3.el5sat

How reproducible:
always

Steps to Reproduce:
1. man spacewalk-remote-utils
  
Actual results:
1.
SYNOPSIS
       spaceawlk-create-channel [ options ... ] [ -lUSER ] [ --username=USER ]
2.
EXAMPLES should start on the new line. Now its messed

3.there is './create-channel-update' in usage message.

spacewalk-create-channel --help
usage: ./create-channel-update  -l USER  -s SERVER [-p PASSWORD]  -v VERSION -r RELEASE
                -u UPDATE -a ARCH -e EXTRA  [ -D DATAFILE]  [-c SRCCHAN] -d DESTCHAN [-N DESTNAME]  [-P PARENT]
                [-C | --clear] [-n | --nossl]


Expected results:
no typos, no create-channel-update

Additional info:
Comment 1 Petr Sklenar 2010-10-15 06:29:03 EDT
there is wrong example in man,  please place working one:

# spacewalk-create-channel  -l admin -s `hostname` -d psklenar-rhel6-test -D /usr/share/rhn/channel-data/4-U3-AS-i386
Password: 
Error: data file '4-U3-AS-i386' does not exist

I would recommend to use data file for rhel5 :
/usr/share/rhn/channel-data/5-u5-server-x86_64
Comment 2 Petr Sklenar 2010-10-15 07:29:39 EDT
another typo is:

spacewalk-create-channel  -l admin -s `hostname` -d psklenar-rhel6-test -D /usr/share/rhn/channel-data/5-u1-server-x86_64
Password: 
You have not specified a source channel, we will try to determine it from inputs
Trying with source channel: rhel-x86_64-server-5
Creating channel, psklenar-rhel6-test, with arch x86_64 2857 packages in source file to push.
Pushing 2857 packages, please wait.
Sucessfully pushed 2857 packages out of 2857
^^
s/Sucessfully/Successfully/
Comment 4 Miroslav Suchý 2011-12-08 04:13:23 EST
Fixed in spacewalk.git in commits:
* d8b72dd 641936 - update example to RHEL6
* af3fef3 641936 - fix typo
* 15c8555 641936 - make man page consistent with --help option
* 86ce45e 641936 - fix typo in man page
* 91ca947 641936 - fix typo in man page

The Example section was fixed some times ago by justin in commits:

d0f25a1198bd2234f2ef9134189dc77b301235ea
fa020bc01749d67c19a0954c52ed7e40d7c458d3
Comment 5 Miroslav Suchý 2011-12-08 04:37:06 EST
*** Bug 681235 has been marked as a duplicate of this bug. ***
Comment 6 Miroslav Suchý 2011-12-08 04:52:24 EST
another spacewalk.git commit  753a8dd
Comment 7 Miroslav Suchý 2011-12-08 09:45:32 EST
spacewalk.git commit f11ef65
Comment 8 Miroslav Suchý 2011-12-09 10:01:52 EST
cherrypicked to satellite.git as:
* 9af8316 (HEAD, satellite-5.4) 641936 - another typo and fix --help page (cherry picked from commit f11ef65dbac24e94b1200524
* b9407e6 641936 - s|./create-channel-update|create-channel-update| in --help (cherry picked from commit 753a8ddea29a6747d404
* aca5923 641936 - update example to RHEL6 (cherry picked from commit d8b72dd62dba8fbbae2182c098bbc09d6b9e201e)
* 5578d43 641936 - fix typo (cherry picked from commit af3fef390d75a0bb9d5d8b4ac7d6083a8a6b5270)
* 6a1c7c0 641936 - make man page consistent with --help option (cherry picked from commit 15c855572211b8f7aa78ab203817ce2bc77
* c974fc3 man page formatting fix (cherry picked from commit d0f25a1198bd2234f2ef9134189dc77b301235ea)
* 490f059 641936 - fix typo in man page (cherry picked from commit 86ce45e745bfcf0e47a0d705401479e266153725)
* dbd465a 641936 - fix typo in man page (cherry picked from commit 91ca947eb3a2a09ce59ba11403c27f36e4301347)
Comment 10 Šimon Lukašík 2011-12-12 04:21:31 EST
Flipping back to assigned:

# rpm -q spacewalk-remote-utils
spacewalk-remote-utils-1.0.2-9.el6sat.noarch
# spacewalk-create-channel --help | grep spacewalk-channel-update
Usage: spacewalk-channel-update  -l USER  -s SERVER [-p PASSWORD]  -v VERSION -r RELEASE

There is no such tool as spacewalk-channel-update.
Comment 11 Miroslav Suchý 2011-12-12 05:25:18 EST
fixed in spacewalk.git:
0da6c20de1d7f7134e7edd0e2743156d47554119
7bfae1dd0ffaa6a58830ea92e665b5c557946858

cherry picked to satellite.git as:
* 7bd4231 641936 - fix grammar in man page (cherry picked from commit 7bfae1dd0ffaa6a58830ea92e665b5c557946858)
* 66f6566 641936 - correct script name in --help output (cherry picked from commit 0da6c20de1d7f7134e7edd0e2743156d47554119)
Comment 13 Šimon Lukašík 2011-12-19 05:02:12 EST
Moving back to assigned:

(In reply to comment #1)
> there is wrong example in man,  please place working one:
> 

The last example has incorrect option. There should be upper '-P' instead.

# spacewalk-create-channel  -l  admin -s myserver.example.com \
    -v 6 -u u1 -r Server -a x86_64 -e Supplementary \
    -p my-stable-channel -d my-stable-extras
You have not specified a source channel, we will try to determine it from inputs
Trying with source channel: rhel-x86_64-server-supplementary-6
Traceback (most recent call last):
  File "/usr/bin/spacewalk-create-channel", line 454, in <module>
    main()
  File "/usr/bin/spacewalk-create-channel", line 175, in main
    auth = client.auth.login(user, password)
  File "/usr/lib64/python2.6/xmlrpclib.py", line 1199, in __call__
    return self.__send(self.__name, args)
  File "/usr/lib64/python2.6/xmlrpclib.py", line 1489, in __request
    verbose=self.__verbose
  File "/usr/lib64/python2.6/xmlrpclib.py", line 1253, in request
    return self._parse_response(h.getfile(), sock)
  File "/usr/lib64/python2.6/xmlrpclib.py", line 1392, in _parse_response
    return u.close()
  File "/usr/lib64/python2.6/xmlrpclib.py", line 838, in close
    raise Fault(**self._stack[0])
xmlrpclib.Fault: <Fault 2950: 'redstone.xmlrpc.XmlRpcFault: Either the password or username is incorrect.'>
Comment 14 Miroslav Suchý 2011-12-19 08:29:35 EST
spacewalk.git:
3e8a50bc58093f2bc70be90cbc07af2b58c635c8
cherrypicked to satellite.git as:
29089d59851bce2db395ed144dc553d4c2256bd5
Comment 15 Šimon Lukašík 2012-01-02 05:10:24 EST
Moving to Verified:

Testing procedure:
 - from comment 0:
    - synopsis in manpage
    - examples in manpage are structured
    - usage
 - from comment 1:
    - all the examples works
 - from comment 2:
    - spelling of successfully
 - from comment 3:
    - upper P for parent_channel
    - examples of update levels

Verified against:
spacewalk-remote-utils-1.0.2-12
Comment 16 errata-xmlrpc 2012-01-05 07:12:29 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0003.html

Note You need to log in before you can comment on or make changes to this bug.