Bug 64214 - a2ps isn't working on RH 7.2, output PS files does not print and can not be viewed with gs or gh
a2ps isn't working on RH 7.2, output PS files does not print and can not be v...
Status: CLOSED DUPLICATE of bug 40532
Product: Red Hat Linux
Classification: Retired
Component: a2ps (Show other bugs)
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Tim Waugh
Depends On:
  Show dependency treegraph
Reported: 2002-04-29 09:40 EDT by Werner Becker
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-04-29 09:40:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Werner Becker 2002-04-29 09:40:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [de] (X11; U; Linux 2.4.7-10 i686)

Description of problem:

Description of your problem:

I have RH 7.2 installed and a2ps does not work, i.e. it does not produce a
working ps-file in output.I have installed  a2ps-4.13b-15.

The same version working in a Debian distribution is working, from what I
conclude that it is not a problem with the a2ps software itself. The error
mesage using gs to show th e ps-file on the display is:

GNU Ghostscript 6.51 (2001-03-28)
Copyright (C) 2001 artofcode LLC, Benicia, CA.  All rights reserved.
This software comes with NO WARRANTY: see the file COPYING for details.
Loading NimbusRomNo9L-Regu font from
/usr/share/fonts/default/Type1/n021003l.pfb... 2362024 982797 1622424 328124 0
Loading NimbusSanL-Regu font from 
2639936 1238472 1642520 335588 0 done.
Error: /undefined in 15,000000
Operand stack:
Execution stack: ..........
GNU Ghostscript 6.51: Unrecoverable error, exit code 1

Producing a ps-file on the Debian distribution and RH 7.2 with a2ps and making 
diff on the file results in

< /th 15,000000 def
> /th 15.000000 def
< /bfs 8,005733 def
< /cw 4,803440 def
> /bfs 8.005733 def
> /cw 4.803440 def
<    cw 81,400000 mul
>    cw 81.400000 mul
<    501,959430 th add
>    501.959430 th add
< /x0 x v get 3,362408 add sx cw mul add store
> /x0 x v get 3.362408 add sx cw mul add store
< (test.txt) (Seite 1/1) (Apr 25, 02 10:02) title
> (test.txt) (Page 1/1) (Apr 25, 02 10:02) title
< (Gedruckt von Werner Becker) rhead
< (test.txt) (1/1) (Donnerstag April 25, 2002) footer
> (Printed by Werner Becker) rhead
> (test.txt) (1/1) (Thursday April 25, 2002) footer

From this and the error message it seems that on RH the number is expressed as
15,000000 whereas on Debian it is 15.00000, i.e. RH uses a "," whereas on 
they use "." for the digit. I wonder if this could cause the error ??

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.a2ps -o test.ps test.txt on an example test.txt file (arbitrary ascii content)

Actual Results:  file test.ps is created. Prinitng it with lpr -P test.ps or 
using ghostscript/ghostview does not print the file but crahes the 

Expected Results:  the file should be print fine on a ps-printer

Additional info:

see log of description above
Comment 1 Tim Waugh 2002-04-29 10:00:47 EDT
Already fixed in a2ps-4.13b-16, in rawhide. 

*** This bug has been marked as a duplicate of 40532 ***

Note You need to log in before you can comment on or make changes to this bug.