Bug 64236 - Konqueror unable to delete RHN system profiles
Konqueror unable to delete RHN system profiles
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
7.3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: wdovlrrw
Ben Levenson
:
: 64928 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-29 21:36 EDT by Warren Togami
Modified: 2007-04-18 12:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-07 07:02:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2002-04-29 21:36:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020412

Description of problem:
When I attempt to delete a RHN system profile using Konqueror as my web browser,
it fails to delete the profile at the "System Deletion Confirmation Page."

When I click the red button "Confirm Deletion of This System Profile", the same
page re-loads rather than deleting the profile.  Mozilla subsequently
successfully deleted this system profile.

Version-Release number of selected component (if applicable):
Skipjack beta 2
KDE 3.0.0-9

How reproducible:
Always

Steps to Reproduce:
1. Login to RHN with Konqueror.
2. Attempt to Delete a System Profile.
3. Click "Confirm Deletion of this System Profile"

Actual Results:  
Page reloads and nothing has changed.

Expected Results:  
System profile should be deleted.
Comment 1 Warren Togami 2002-05-09 04:28:10 EDT
Re-tested: Still exists in Red Hat Linux 7.3.
Comment 2 Bernhard Rosenkraenzer 2002-05-19 12:20:56 EDT
*** Bug 64928 has been marked as a duplicate of this bug. ***
Comment 3 Bret McMillan 2002-05-20 09:13:54 EDT
Something to note:

On the RHN side of things, we're seeing formvars getting submitted to completely
different pages than they're intended for.

I.e., the "delete a server" page might get the formvars from archiving scheduled
actions...
Comment 4 Warren Togami 2002-05-25 08:05:02 EDT
Found another good testcase showing Konqueror messing up real bad... 
http://www.icrontic.com/index.php?page=public/hardware&hardwareId=364 
 
Try clicking through the pages of this review, then trying the links on the 
left side of the page.  Very often with Konqueror you end up at a page showing 
MySQL login errors.  You never see those errors in Mozilla. 
 
(It seems that their PHP code depends on client submitted data... tsk tsk.) 
Comment 5 Greg DeKoenigsberg 2002-07-01 12:24:24 EDT
On RHN, we are still seeing dozens of tracebacks a day from Konqueror users due
to formvar manglement -- and whomever has classified this bug as "low" hasn't
fully considered the potentially ugly ramifications of passing an incorrect
server ID to a "delete server" request page; therefore, I've moved the priority
back to "high".  If someone decides to set it back to "low" again, please
explain the rationale to me.

Is there any relief in sight to this issue?  It's now two months old.
Comment 6 Bernhard Rosenkraenzer 2002-07-01 13:17:00 EDT
This has been fixed (at least it works perfectly here with 
3.0.2-0.cvs20020624.1). 
 
Please let me know if you can still see this problem with current versions.
Comment 7 Warren Togami 2002-07-13 10:20:37 EDT
I haven't seen any problems like this in Limbo either.  Safe to close?
Comment 8 Warren Togami 2002-08-07 07:02:13 EDT
Can errata be issued for KDE fixing this issue in Valhalla?  Many people will 
still be using 7.3 for a long time, and I would hate for them to use a 
dangerously broken browser with this bad behavior. 

Note You need to log in before you can comment on or make changes to this bug.