Bug 64928 - Konqueror for 7.3 can't delete machines, and other random bugs...
Konqueror for 7.3 can't delete machines, and other random bugs...
Status: CLOSED DUPLICATE of bug 64236
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
7.3
All Linux
high Severity high
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Fanny Augustin
http://webapp.rwc-colo.redhat.com/net...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-14 13:59 EDT by Steve Taylor
Modified: 2005-10-31 17:00 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-19 08:19:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Taylor 2002-05-14 13:59:15 EDT
How Reproducible: 
 
 
Steps to Reproduce: 
1. Go to 
http://webapp.rwc-colo.redhat.com/network/system/delete_brb_confirm.pxt and 
login as chatak 
2. try to delete a system. 
3. 
 
Actual Results: 
Takes you right back to the same page. 
 
Expected Results: 
System gets deleted. 
 
Additional Information: 
 
Also clicking on login in the upper left does nothing in konqueror.
Comment 1 David M. Cook 2002-05-14 14:08:17 EDT
Confirmed.
Comment 2 Greg DeKoenigsberg 2002-05-14 14:09:14 EDT
Welcome to the party, pal.

It's our contention that this is a (major) Konqueror 3.0 bug.  We've got a
workaround in the pipe that will redirect users logging in to RHN via Konqueror
3.0 to a "so sorry, please use another browser" page.

I add the body of the text from Chip's email to Bero on the subject:

*****

Hey Bero,

We're seeing a serious problem in Konqueror 3.0, to the point of making RHN
unusable.  It has to do with caching of page results intermixing with
redirects.  You can reproduce it by doing the following:

1. Log into RHN (https://rhn.redhat.com/)
2. Click system list, pick a system.  Bookmark the detail page of that system.
3. Log out.
4. Click on the bookmark, log in.
5. Click system list, select the same system again.
6. Click the modify button.  You get an internal server error.

You can verify this with tcpdump, but what is happening is that konq is
resubmitting the very old formvars from the login page onto this page.  This is,
of course, very broken.  Frequently it mis-submits form variables as well,
sending none when it should send something.

For instance:

1. Click on a system in the system list.
2. Change its entitlements, click "Modify"
3. The change worked.  You're brought back to the same page.
4. Change entitlement again, click "Modify" again.
5. Change did not work; it submitted the same formvars as the first time.

Has this been reported?  It's pretty much making RHN unusable.  No other browser
exhibits these issues.  We can try workarounds, if need be; it's causing us a
huge number of tracebacks.
Comment 3 Warren Togami 2002-05-19 08:19:19 EDT
This bug is a duplicate of Bug 64236.

Bero,
Based upon gdk@redhat.com's description, could this be somehow related to Bug 62196?
Comment 4 Bernhard Rosenkraenzer 2002-05-19 12:21:02 EDT
Possibly related to 62196... Though I can't reproduce that one with the 
current version. 

*** This bug has been marked as a duplicate of 64236 ***

Note You need to log in before you can comment on or make changes to this bug.