Bug 642598 - JON241: [apache] Apache resource upgraded from RHQ 1.3.1 to RHQ 3 stops collecting data on the vhost corresponding to the main server configuration
JON241: [apache] Apache resource upgraded from RHQ 1.3.1 to RHQ 3 stops colle...
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Plugins (Show other bugs)
3.0.0
All Linux
low Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Corey Welton
:
Depends On: 642591
Blocks: jon241-bugs 643563
  Show dependency treegraph
 
Reported: 2010-10-13 08:22 EDT by Lukas Krejci
Modified: 2011-05-23 21:11 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-23 21:11:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Lukas Krejci 2010-10-13 08:22:42 EDT
Description of problem:
The summary says it all.

This is also reproducible without the full server upgrade by installing RHQ 3 and replacing its apache plugin with the version from RHQ 1.3.1. Therefore an upgrade in the steps below can be replaced by a simply copying the RHQ 3 version of the plugin back and doing "plugins update" on the agent.
 
Version-Release number of selected component (if applicable):
3.0.0

How reproducible:
always

Steps to Reproduce:
1. Enable and configure the SNMP module in some apache instance
2. With RHQ 1.3.1, inventory that apache instance
3. Upgrade RHQ 1.3.1 to RHQ 3
  
Actual results:
$SUMMARY

Expected results:
The metrics should still be collected

Additional info:
Comment 1 Charles Crouch 2010-11-01 23:41:22 EDT
This looks like a good candidate for inclusion into the jon2.4.1. 
Since its currently ON_QA I presume is committed into master, though there is no git hash, so lets test it in jon2.4.1
Comment 2 Lukas Krejci 2010-11-10 08:32:53 EST
This bug only tracks a different manifestation of the same underlying cause as the bug 642591.
Comment 3 Sunil Kondkar 2010-11-16 04:12:32 EST
Verified on Build #23 (jon241-release/23)

-Enabled and configured the SNMP module in apache instance
-Started apache
-Installed jon241 build
-Replaced its apache plugin with the version from RHQ 1.3.1 (rhq-apache-plugin-1.3.1.GA.jar)
-Started rhq server and agent
-Copied rhq-apache-plugin-3.0.1-SNAPSHOT.jar to plugins directory
-At agent command prompt:
> plugins update
The plugin container has been stopped.
Updating plugins to their latest versions.
The plugin [Apache] has been updated at [rhq-apache-plugin-3.0.1-SNAPSHOT.jar].
Completed updating the plugins to their latest versions.
The plugin container has been started.

-Observed that the metrics are collected on the vhost corresponding to the main server configuration.
Comment 4 Corey Welton 2011-05-23 21:11:15 EDT
Bookkeeping - closing bug - fixed in recent release.
Comment 5 Corey Welton 2011-05-23 21:11:15 EDT
Bookkeeping - closing bug - fixed in recent release.

Note You need to log in before you can comment on or make changes to this bug.