Bug 642603 - JON241: [apache] Confusing metrics collection behavior on main server vhost after SNMP enabled
JON241: [apache] Confusing metrics collection behavior on main server vhost a...
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Plugins (Show other bugs)
3.0.0
All Linux
low Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Corey Welton
:
Depends On: 642591
Blocks: jon241-bugs 643563
  Show dependency treegraph
 
Reported: 2010-10-13 08:27 EDT by Lukas Krejci
Modified: 2011-05-23 21:13 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Lukas Krejci 2010-10-13 08:27:30 EDT
Description of problem:
After SNMP is enabled on the inventoried apache instance, the "Main" vhost gets duplicated in the inventory.

The original resource starts collecting metrics, while the new duplicate doesn't.

Version-Release number of selected component (if applicable):
3.0.0

How reproducible:
always

Steps to Reproduce:
1. Inventory an apache instance that doesn't have SNMP module configured
2. Configure SNMP module in apache, update the connection properties of the resource to reflect that
3. Stay confused
  
Actual results:
$DESCRIPTION

Expected results:
No duplicate vhosts and metrics start to be collected

Additional info:
Comment 1 Charles Crouch 2010-11-01 23:47:36 EDT
This sounds like a duplicate of 642591. If there is a seperate fix then this looks like a good candidate for inclusion into the jon2.4.1, although I'm not seeing a separate commit into the release3.0 branch for this. If there is no separate fix then this should be closed as a duplicate
Comment 2 Sunil Kondkar 2010-11-15 05:12:24 EST
Verified on Build #23 (jon241-release/23)

1. Installed apache 2.2.17. Configured snmp module in apache
(Followed instructions from
'http://www.rhq-project.org/display/JOPR2/Apache+2.x+SNMP+Config')

2. Commented below lines in config file:

#LoadModule snmpcommon_module modules/libsnmpcommon.so
#LoadModule snmpagt_module modules/libsnmpmonagt.so

#SNMPConf conf
#SNMPVar var

3. Included virtual host in config file.

4. Started apache:
[root@sunillaptop apache2]# /usr/local/apache2/bin/apachectl -k start
[root@sunillaptop apache2]# netstat -na | grep 1610
[root@sunillaptop apache2]#

5. Inventoried apache instance into RHQ. Main virtual host is discovered. 

The Connection properties display below:

SNMP Agent Host  127.0.0.1
SNMP Agent Port  1610
SNMP Agent Community  public

6. Configured the SNMP module in apache:
(Removed comments from below lines:

LoadModule snmpcommon_module modules/libsnmpcommon.so
LoadModule snmpagt_module modules/libsnmpmonagt.so

SNMPConf conf
SNMPVar var)

7. Restarted apache:

[root@sunillaptop apache2]# /usr/local/apache2/bin/apachectl -k restart
[root@sunillaptop apache2]# netstat -na | grep 1610
udp        0      0 0.0.0.0:1610                0.0.0.0:*


After SNMP is enabled on the inventoried apache instance, the "Main" vhost does not get duplicated in the inventory and no duplicate vhosts are discovered.
Comment 3 Corey Welton 2011-05-23 21:13:41 EDT
Bookkeeping - closing bug - fixed in recent release.
Comment 4 Corey Welton 2011-05-23 21:13:41 EDT
Bookkeeping - closing bug - fixed in recent release.
Comment 5 Corey Welton 2011-05-23 21:13:44 EDT
Bookkeeping - closing bug - fixed in recent release.

Note You need to log in before you can comment on or make changes to this bug.