Bug 64262 - Valhalla: initrd-everything.img: unresolved symbols in airo_cs.o
Valhalla: initrd-everything.img: unresolved symbols in airo_cs.o
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: anaconda-images (Show other bugs)
7.3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-30 17:03 EDT by Aleksey Nogin
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-17 14:35:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aleksey Nogin 2002-04-30 17:03:06 EDT
Just tried to do 7.2->7.3 upgrade on my laptop, but it failed to initialize my
Aironet card:

cardmgr[41]: socket 1: Aironet PC4800
cardmgr[41]: executing: 'modprobe airo_cs.o'
cardmgr[41]: + /tmp/airo-cs.o: unresolved symbol reset_airo_card
cardmgr[41]: + /tmp/airo-cs.o: unresolved symbol init_airo_card
cardmgr[41]: + /tmp/airo-cs.o: unresolved symbol stop_airo_card
...
(copied by hand, so may contain typos).

I used vmlinuz and initrd-everything.img from images/pxeboot (by downloading
them and sticking them into my grub.conf).
Comment 1 Michael Fulbright 2002-05-01 11:29:20 EDT
What is a aironet card?
Comment 2 Aleksey Nogin 2002-05-01 12:04:04 EDT
Aironet PC4800. (Aironet Wireless Communications, Inc was bought by Cisco, so
it's also known as Cisco PC4800, I guess). In short, it's the card that the
airo_cs driver is supposed to work with (aironet4500_cs too, but according to
bug #40552 for 4800 (as opposed to 4500 cards), airo_cs works better).

Anyway, this bug is more about airo_cs driver failing to load because of
unresolved symbols, is it really important what card caused it to be loaded?
Comment 3 Michael Fulbright 2002-07-17 14:35:45 EDT
Jeremy we don't support wireless network cards in the install do we?
Comment 4 Jeremy Katz 2002-07-17 22:56:07 EDT
No, wireless cards aren't supported for installing because we have no way to set
up the wireless tools parameters.

Note You need to log in before you can comment on or make changes to this bug.