Bug 642943 - missing necessary meego allow for OpenSessionWithParameters from org.freedesktop.ConsoleKit.Manager
Summary: missing necessary meego allow for OpenSessionWithParameters from org.freedesk...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: ConsoleKit
Version: 14
Hardware: All
OS: Linux
low
urgent
Target Milestone: ---
Assignee: Lennart Poettering
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 645074 (view as bug list)
Depends On:
Blocks: MeeGo12
TreeView+ depends on / blocked
 
Reported: 2010-10-14 09:14 UTC by Ingvar Hagelund
Modified: 2011-10-11 10:06 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-11 10:06:37 UTC
Type: ---


Attachments (Terms of Use)
Patch for OpenSessionWithParameters (680 bytes, patch)
2010-12-06 15:42 UTC, Peter Robinson
no flags Details | Diff
Patch for aspec to add OpenSessionWithParameters patch to build (1.35 KB, patch)
2010-12-06 15:43 UTC, Peter Robinson
no flags Details | Diff


Links
System ID Private Priority Status Summary Last Updated
FreeDesktop.org 32244 0 None None None Never

Description Ingvar Hagelund 2010-10-14 09:14:39 UTC
Description of problem:
When trying to run the meego environment, it fails to start because org.freedesktop.ConsoleKit.Manager is not allowed to send OpenSessionWithParameters (or something like that, I'm no dbus guru).

Version-Release number of selected component (if applicable):
ConsoleKit-0.4.2-2.fc14.1.i686

How reproducible:
Always

Steps to Reproduce:
1. yum groupinstall "MeeGo NetBook UX Environment"
2. Log in from gdm, selecting a "Fedora Netbook" session
3. meego wont start, find dbus related messages in uxlaunch.log
  
Actual results:

[00.046981] [11976] Error: Unable to open session with                ConsoleKit: org.freedesktop.CkConnector.Error: Unable to open                session: Rejected send message, 2 matched rules;                type="method_call", sender=":1.331" (uid=500 pid=11976 comm="/usr/sbin/uxlaunch) interface="org.freedesktop.ConsoleKit.Manager" member="OpenSessionWithParameters" error name="(unset)" requested_reply=0 destination="org.freedesktop.ConsoleKit" (uid=0 pid=1287 comm="/usr/sbin/console-kit-daemon))

Expected results:
No dbus/consolekit related errors

Additional info:

Adding these lines to /etc/dbus-1/system.d/ConsoleKit.conf makes the problem disappear. I put them around line 42, together with OpenSession.

    <allow send_destination="org.freedesktop.ConsoleKit"
           send_interface="org.freedesktop.ConsoleKit.Manager"
           send_member="OpenSessionWithParameters"/>

This does not fix meego, but gets me a bit further. 

Ingvar

Comment 1 Peter Robinson 2010-10-20 19:37:34 UTC
*** Bug 645074 has been marked as a duplicate of this bug. ***

Comment 2 Matthew Booth 2010-10-20 19:57:48 UTC
Just bumping the Severity on this one. There's nothing much more important to a user interface than the ability to display it :)

Comment 3 Ingvar Hagelund 2010-10-21 06:10:25 UTC
Just for the record: Fixing the dbus rights does not make the meego session work. It is still just a white screen.

Comment 4 Valent Turkovic 2010-10-22 07:01:11 UTC
So new Meego won't be in Fedora 14 release? Will it be added later as an update?

Comment 5 Ingvar Hagelund 2010-10-22 07:29:19 UTC
Valent, that's a definition question :-)

Looks to me like most packages are in, but the session doesn't start properly.

Comment 6 Peter Robinson 2010-12-06 15:37:22 UTC
(In reply to comment #4)
> So new Meego won't be in Fedora 14 release? Will it be added later as an
> update?

Work in progress. I ran out of free time due to work. Its moving slowly forward in rawhide atm, and once its working there I'll be looking at back porting fixes.

Comment 7 Peter Robinson 2010-12-06 15:42:16 UTC
Created attachment 465003 [details]
Patch for OpenSessionWithParameters

A patch for the addition of OpenSessionWithParameters to the conf file

Comment 8 Peter Robinson 2010-12-06 15:43:22 UTC
Created attachment 465004 [details]
Patch for aspec to add OpenSessionWithParameters patch to build

A patch to the spec file to add the previous patch to the build.

Comment 9 Peter Robinson 2010-12-06 15:44:17 UTC
Lennart: Any issues if I apply the patch to ConsoleKit?

Comment 10 Anil Seth 2011-01-20 14:10:51 UTC
Comparing with Smeegol, I found that in startmoblin, the following line is commented:
#export GCONF_DEFAULT_SOURCE_PATH=/etc/gconf/2/moblin.path

The related configuration files are also missing. This results in the default plugin being used by mutter and the screen being white.

Creating the needed files, the uxlaunch.log shows that mutter tries but fails to load moblin-netbook.so. The reason:

(mutter:2603): mutter-WARNING **: Could not load library [/usr/lib64/mutter/plugins/moblin-netbook.so (/usr/lib64/mutter/plugins/moblin-netbook.so: undefined symbol: mutter_plugin_effect_completed)]

Downgraded mutter to mutter-mbl-2.29.1_1.0-1.fc14 as searching for the error seemed to indicate that this may be the resulof of an API breakage. The plugin error disappears but various applications are unable to open the display and the session dies. 

This could be a caused by the warning:
(mutter:1691): GLib-GObject-WARNING **: specified class size for type `MoblinNetbookPlugin' is smaller than the parent type's `MutterPlugin' class size

followed by errors like:
gnome-screensaver: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.0.
moblin-panel-myzone: Fatal IO error 2 (No such file or directory) on X server :0.0.

Comment 11 Peter Robinson 2011-01-20 14:18:19 UTC
(In reply to comment #10)
> Comparing with Smeegol, I found that in startmoblin, the following line is
> commented:
> #export GCONF_DEFAULT_SOURCE_PATH=/etc/gconf/2/moblin.path
> 
> The related configuration files are also missing. This results in the default
> plugin being used by mutter and the screen being white.

I have meego working locally on rawhide. We have forward movement. Aiming for f-15 at the moment, not decided whether it will be pushed back to f-14.

Comment 12 Valent Turkovic 2011-02-16 10:34:48 UTC
Great news for Fedora and Meego! Hope it also gets into F14.

Comment 13 Lennart Poettering 2011-02-18 12:58:00 UTC
Hmm, nope, this policy change is not unproblematic, since clients can pass whatever they want. In fact the documentation explcitly says that OpenSessionWithParameters() is privileged:

http://www.freedesktop.org/software/ConsoleKit/doc/ConsoleKit.html#Manager.OpenSessionWithParameters

There must be another way to fix this. The client asking for this, is it running as normal user?

Comment 14 Peter Robinson 2011-02-19 10:13:02 UTC
> There must be another way to fix this. The client asking for this, is it
> running as normal user?

Yes, its a UX just as gnome 3 is (it uses mutter too)

Comment 15 Ingvar Hagelund 2011-04-28 08:27:48 UTC
Since the necessary parts may appear, and over time even work together in f15, but will be hard to backport to f14, I suggest to just close this ticket as WONTFIX.

Ingvar


Note You need to log in before you can comment on or make changes to this bug.