Bug 643185 - Add location parameter to mirrorlist URIs
Add location parameter to mirrorlist URIs
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mirrormanager (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Matt Domsch
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-14 16:54 EDT by Garrett Holmstrom
Modified: 2013-04-01 13:57 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 643186 (view as bug list)
Environment:
Last Closed: 2013-03-19 23:02:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Garrett Holmstrom 2010-10-14 16:54:58 EDT
Description of problem:
Part of the Cloud SIG's overall effort to get Fedora on Amazon EC2 involves directing users' VM instances to yum mirrors inside Amazon's S3 storage service.  Since the usual IP block-based decisions don't work with EC2 instances, the preferred solution involves passing a "location" parameter to MirrorManager that contains the VM's location so MirrorManager to tell it where to go.

The code to support this exists in both Yum and MirrorManager, so to make it possible for VMs to use this Fedora's yum repo definitions need to be set up to pass MirrorManager this additional information by appending "&location=$location" to Fedora's stock yum repo files.

Additional info:

The whole process is documented in the wiki page for the EC2 mirror proposal[1].  Also relevant are the rel-eng ticket [2], a recent Cloud SIG discussion on the topic [3], and a brief FESCo discussion on the topic [4].

[1] https://fedoraproject.org/wiki/User:Gholms/EC2_Mirror_Proposal#Client_Access
[2] https://fedorahosted.org/rel-eng/ticket/4149
[3] http://meetbot.fedoraproject.org/fedora-meeting/2010-09-30/cloud.2010-09-30-21.01.log.html
[4] http://meetbot.fedoraproject.org/fedora-meeting/2010-10-05/fesco.2010-10-05-19.30.log.html
Comment 1 Jesse Keating 2010-10-14 19:02:04 EDT
re-assigning to rawhide, pretty much too late for F14, just days away from
change freeze and months past feature freeze.  This could get backported to F14
once it has been fleshed out in rawhide.
Comment 2 Fedora Admin XMLRPC Client 2010-11-24 17:44:14 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 3 Matt Domsch 2011-05-01 10:53:33 EDT
The location code in mirrormanager is in the 1.4 branch not yet released or in production for Fedora.  I don't think it'll be released before F15 launch.  Hopefully soon thereafter though.
Comment 4 Matt Domsch 2011-11-17 20:49:26 EST
reminder that I haven't done this yet for MM 1.3 in production, and 1.4 has been far slower in coming than I would have thought.
Comment 5 Garrett Holmstrom 2011-11-18 01:07:29 EST
The original reason for this request was to reduce the (monetary) cost of running updates on Fedora instances in EC2.  Since then Amazon has stopped charging for inbound data, ending the Cloud SIG's push for Fedora-sponsored mirrors inside Amazon.
Comment 6 Matt Domsch 2013-03-19 23:02:12 EDT
We have Fedora Infrastructure-managed mirrors in S3 now in several regions, and Amazon now publishes the list of IP address blocks for each region, so we don't really need location=foo anymore.  Closing.

Note You need to log in before you can comment on or make changes to this bug.