Bug 643186 - Add location parameter to mirrorlist URIs
Add location parameter to mirrorlist URIs
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: generic-release (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F14Target
  Show dependency treegraph
 
Reported: 2010-10-14 16:57 EDT by Garrett Holmstrom
Modified: 2013-01-10 01:16 EST (History)
2 users (show)

See Also:
Fixed In Version: generic-release-14-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 643185
Environment:
Last Closed: 2010-11-04 19:41:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Garrett Holmstrom 2010-10-14 16:57:38 EDT
+++ This bug was initially created as a clone of Bug #643185 +++

Description of problem:
Part of the Cloud SIG's overall effort to get Fedora on Amazon EC2 involves directing users' VM instances to yum mirrors inside Amazon's S3 storage service.  Since the usual IP block-based decisions don't work with EC2 instances, the preferred solution involves passing a "location" parameter to MirrorManager that contains the VM's location so MirrorManager to tell it where to go.

The code to support this exists in both Yum and MirrorManager, so to make it possible for VMs to use this Fedora's yum repo definitions need to be set up to pass MirrorManager this additional information by appending "&location=$location" to Fedora's stock yum repo files.

Additional info:

The whole process is documented in the wiki page for the EC2 mirror proposal[1].  Also relevant are the rel-eng ticket [2], a recent Cloud SIG discussion on the topic [3], and a brief FESCo discussion on the topic [4].

[1] https://fedoraproject.org/wiki/User:Gholms/EC2_Mirror_Proposal#Client_Access
[2] https://fedorahosted.org/rel-eng/ticket/4149
[3] http://meetbot.fedoraproject.org/fedora-meeting/2010-09-30/cloud.2010-09-30-21.01.log.html
[4] http://meetbot.fedoraproject.org/fedora-meeting/2010-10-05/fesco.2010-10-05-19.30.log.html
Comment 1 Jesse Keating 2010-10-14 19:00:34 EDT
re-assigning to rawhide, pretty much too late for F14, just days away from change freeze and months past feature freeze.  This could get backported to F14 once it has been fleshed out in rawhide.
Comment 2 Fedora Update System 2010-10-20 14:28:15 EDT
generic-release-14-1 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/generic-release-14-1
Comment 3 Fedora Update System 2010-10-28 02:03:55 EDT
generic-release-14-1 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update generic-release'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/generic-release-14-1
Comment 4 Fedora Update System 2010-11-04 19:41:43 EDT
generic-release-14-1 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.