Bug 643580 - Fedora 14 TC1 DVD Graphical Install Fails
Fedora 14 TC1 DVD Graphical Install Fails
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
14
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
AcceptedNTH
:
: 643742 (view as bug list)
Depends On:
Blocks: F14-accepted/F14FinalFreezeExcept
  Show dependency treegraph
 
Reported: 2010-10-16 01:02 EDT by John Watzke
Modified: 2013-01-10 01:17 EST (History)
9 users (show)

See Also:
Fixed In Version: anaconda-14.20-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-21 12:03:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Contents of /tmp folder after install failure (30.39 KB, application/x-bzip)
2010-10-16 01:02 EDT, John Watzke
no flags Details
syslog from installation (99.49 KB, text/plain)
2010-10-17 12:43 EDT, Matěj Cepl
no flags Details
X.log from installation (85.74 KB, text/plain)
2010-10-17 12:43 EDT, Matěj Cepl
no flags Details
lspci (1.79 KB, text/plain)
2010-10-17 14:07 EDT, Flóki Pálsson
no flags Details
result of lspci command (2.06 KB, text/plain)
2010-10-18 10:53 EDT, Gilles J. Seguin
no flags Details

  None (edit)
Description John Watzke 2010-10-16 01:02:28 EDT
Created attachment 453834 [details]
Contents of /tmp folder after install failure

Description of problem:
I'm trying to install the F14 DVD through the graphical install.  I did a disk test and the disk is fine.  However, when anaconda tries to launch stage two, the screen goes black as it tries to start X, I see the mouse cursor, the screen blinks a bit, and then it fails back out to the text console stating that the install failed and press ctrl-alt-delete to restart the system.  I am able to launch stage 2 using the basic vesa video driver.

Version-Release number of selected component (if applicable):
Fedora 14 TC1 DVD

How reproducible:
Always

Additional info:
01:00.0 VGA compatible controller: ATI Technologies Inc Mobility Radeon HD 3650

Also attaching the contents of /tmp.
Comment 1 Matěj Cepl 2010-10-17 12:43:13 EDT
Created attachment 453933 [details]
syslog from installation
Comment 2 Matěj Cepl 2010-10-17 12:43:21 EDT
Created attachment 453934 [details]
X.log from installation
Comment 3 Flóki Pálsson 2010-10-17 14:06:01 EDT
Me too.  Installing from F14 TC1.1 DVD.  
I think this bug has been in f14 all the time.
Installation works with second option, that is VESA.
After installing then resolution is reduced.    See bug 633565.  I will file new one.
Comment 4 Flóki Pálsson 2010-10-17 14:07:10 EDT
Created attachment 453942 [details]
lspci

 lspci
Comment 5 Gilles J. Seguin 2010-10-18 10:53:11 EDT
Created attachment 454138 [details]
result of lspci command

"linux text" install succeed
Comment 6 Adam Williamson 2010-10-18 11:22:09 EDT
Can we get the program.log from /tmp after install fails? Thanks!



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 7 Adam Williamson 2010-10-18 11:23:09 EDT
n/m, it's in John's attachment; it does *not* have the same error that 643742 has.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 8 Adam Jackson 2010-10-18 11:31:31 EDT
This should be papered over by the fix to #609245.

What's happening here is that the first client to connect is terminating before metacity connects, and then metacity (or whatever's next) is failing to connect to the X server during the regeneration process.  So it fails and anaconda bombs out.  The fix for #609245 tells the server never to regenerate.
Comment 9 Adam Williamson 2010-10-18 11:50:29 EDT
Thanks. What are the circumstances required to hit this? How confident are we of the fix? (I guess very confident since it's gone into RHEL 6...)



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 10 Adam Williamson 2010-10-18 12:10:25 EDT
*** Bug 643742 has been marked as a duplicate of this bug. ***
Comment 11 Adam Williamson 2010-10-18 12:12:40 EDT
ajax votes for this bug to be nice-to-have - take the 609245 fix in the hopes that it solves this issue, if it doesn't, document the use of vesa as a workaround.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 12 Sandro Mathys 2010-10-18 12:17:32 EDT
will we see the #609245 fix in the F14 Final RC1 already?
Comment 13 Adam Williamson 2010-10-18 13:07:49 EDT
The fix for 609245 is in anaconda 14.20.

ajax, you say that 'papers over' the problem, suggesting it's not really a fix for the underlying bug; would you prefer this report stays open for whatever the 'real' problem is here, or am I misunderstanding?

Discussed at 2010-10-18 blocker review meeting, accepted as nice-to-have.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 14 Adam Williamson 2010-10-18 13:08:07 EDT

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 15 Adam Williamson 2010-10-18 13:20:03 EDT
note for reporters: the fix being in anaconda 14.20 means it will be in RC1, so please re-test with RC1 when it's out. Thanks!



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 16 Jesse Keating 2010-10-21 12:03:58 EDT
14.22 went stable.
Comment 17 John Watzke 2010-10-23 09:11:18 EDT
I tested the RC1 DVD and stage 2 comes up just fine with the graphical install option.
Comment 18 Gilles J. Seguin 2010-10-24 06:07:30 EDT
(In reply to comment #5)
> Created attachment 454138 [details]
> result of lspci command
> 
> "linux text" install succeed

I tested the RC1 DVD and stage 2 comes up just fine with the graphical install
option.

Note You need to log in before you can comment on or make changes to this bug.