Bug 643742 - blank screen on dvd install, working on livecd
blank screen on dvd install, working on livecd
Status: CLOSED DUPLICATE of bug 643580
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
14
All Linux
low Severity high
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F14Blocker/F14FinalBlocker
  Show dependency treegraph
 
Reported: 2010-10-17 14:50 EDT by Sandro Mathys
Modified: 2010-10-18 12:10 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-18 12:10:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anaconda.log from when the screen is blank (3.75 KB, text/plain)
2010-10-17 14:51 EDT, Sandro Mathys
no flags Details
lsmod output from when the screen is blank (1.59 KB, text/plain)
2010-10-17 14:51 EDT, Sandro Mathys
no flags Details
program.log from when the screen is blank (1.05 KB, text/plain)
2010-10-17 14:52 EDT, Sandro Mathys
no flags Details
syslog from when the screen is blank (85.19 KB, text/plain)
2010-10-17 14:52 EDT, Sandro Mathys
no flags Details
X.log from when the screen is blank (36.35 KB, text/plain)
2010-10-17 14:52 EDT, Sandro Mathys
no flags Details

  None (edit)
Description Sandro Mathys 2010-10-17 14:50:41 EDT
Description of problem:
With Fedora 14 Final TC1.1, I get a blank screen when entering stage 2 on the DVD. To make things weird, the KDE LiveCD works just fine.

The blank screen persists when changing to another tty, but the system doesn't freeze. With sshd and networking enabled I can login remotely just fine.

Version-Release number of selected component (if applicable):
Fedora 14 Final TC1.1 i386 DVD

How reproducible:
Always

Steps to Reproduce:
1. boot install dvd
2. wait for stage2 to start
3. experience blank screen
  
Actual results:
blank screen

Expected results:
graphical stage2

Additional info:
Graphics card is an ATI HD 5850.

When I add the nomodeset option my monitor says the input is out of range and goes to sleep - not sure if that's better or not. Might be better but then hit bug 624523, except it doesn't show red pixels...but still the wrong resolution. Not sure though.
Comment 1 Sandro Mathys 2010-10-17 14:51:35 EDT
Created attachment 453950 [details]
anaconda.log from when the screen is blank
Comment 2 Sandro Mathys 2010-10-17 14:51:56 EDT
Created attachment 453952 [details]
lsmod output from when the screen is blank
Comment 3 Sandro Mathys 2010-10-17 14:52:14 EDT
Created attachment 453953 [details]
program.log from when the screen is blank
Comment 4 Sandro Mathys 2010-10-17 14:52:36 EDT
Created attachment 453954 [details]
syslog from when the screen is blank
Comment 5 Sandro Mathys 2010-10-17 14:52:54 EDT
Created attachment 453955 [details]
X.log from when the screen is blank
Comment 6 Sandro Mathys 2010-10-18 10:46:54 EDT
Adding F14Blocker as the following test case fails:
https://fedoraproject.org/wiki/QA:Testcase_Anaconda_User_Interface_Graphical
Comment 7 Adam Williamson 2010-10-18 11:18:03 EDT
[   134.776] (--) RADEON(0): Chipset: "ATI Radeon HD 5800 Series" (ChipID = 0x6899)

does it work with VESA?



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 8 Adam Williamson 2010-10-18 11:21:48 EDT
from program.log :

20:22:37,911 ERR program: Window manager error: Unable to open X display :1
20:22:37,911 ERR program: Error running /usr/bin/metacity: SIGCHLD caught when trying to start the X server.




-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 9 Sandro Mathys 2010-10-18 11:25:37 EDT
(In reply to comment #7)
> 
> does it work with VESA?

yes - sorry, forgot to mention that. Except that my eyes might segfault eventually when looking at the screen for too long ;)
Comment 10 Adam Jackson 2010-10-18 12:03:54 EDT
Program log indicates that this is hitting the same regeneration race as bug #643580.  Man I'm glad I fixed that one.  Between that and comment #9 saying vesa works, I'm calling this not a blocker.

X log indicates that we're not picking up the EDID extension block and therefore possibly screwing up mode selection, but also maybe not.  Still if vesa works before the -noreset change it'll work after too.
Comment 11 Adam Williamson 2010-10-18 12:10:25 EDT
ajax says this is a dupe of 643580.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 643580 ***

Note You need to log in before you can comment on or make changes to this bug.