Bug 64412 - 7.3 GOLD: alien doesnt run
7.3 GOLD: alien doesnt run
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: alien (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
: 61288 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-03 18:33 EDT by Stephen John Smoogen
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-05 15:10:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen John Smoogen 2002-05-03 18:33:40 EDT
The alien package in 7.3 is 'broken' in many cases. The first problem is that
the package is built against the original 7.2 perl-5.6.0 versus the 7.3 perl-5.6.1

The second is that in trying to convert a deb package to an rpm I get the following:

smoogen:{temp}$ alien -r sourceforge_2.6-0+11_all.deb 
Warning: alien is not running as root!
Ownerships of files in the generated packages will probably be messed up.
--target=noarch: unknown option
package build failed at /usr/lib/perl5/5.6.1/Alien/Package/Rpm.pm line 356.
smoogen:{temp}$ sudo bash
Password:
root:{temp}# alien -r sourceforge_2.6-0+11_all.deb 
--target=noarch: unknown option
package build failed at /usr/lib/perl5/5.6.1/Alien/Package/Rpm.pm line 356.

Looking at the alien web page there is an 'additional' needed for non-debian
machines called 'alien-extras'. I am going to look at both of these packages and
see if I can come up with new RPM etc files for people.

Sorry for not testing this sooner.
Comment 1 Jeff Johnson 2002-06-05 15:10:20 EDT
*** Bug 61288 has been marked as a duplicate of this bug. ***
Comment 2 Jeff Johnson 2002-06-20 10:08:54 EDT
alien is being dropped.

Note You need to log in before you can comment on or make changes to this bug.