This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 61288 - perl 5.6.1 breaks Alien package
perl 5.6.1 breaks Alien package
Status: CLOSED DUPLICATE of bug 64412
Product: Red Hat Linux
Classification: Retired
Component: alien (Show other bugs)
7.2
All Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Johnson
:
: 64265 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-15 22:01 EST by Joe Acosta
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-03 18:19:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joe Acosta 2002-03-15 22:01:49 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020310

Description of problem:
Installing the update for perkl 5.6.1 broke the alien package. 


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. upgrade to perl 5.6.1 a RH 7.2 system.  
2. run alien 
3.get output below
	

Actual Results:  Can't locate Alien/Package/Deb.pm in @INC (@INC contains:
/usr/lib/perl5/5.6.1/i386-linux /usr/lib/perl5/5.6.1
/usr/lib/perl5/site_perl/5.6.1/i386-linux /usr/lib/perl5/site_perl/5.6.1
/usr/lib/perl5/site_perl/5.6.0/i386-linux /usr/lib/perl5/site_perl/5.6.0
/usr/lib/perl5/site_perl .) at /usr/bin/alien line 212.
BEGIN failed--compilation aborted at /usr/bin/alien line 212.


Additional info:
Comment 1 Dax Kelson 2002-05-01 01:05:55 EDT
I can confirm this, it also effects SkipJack Beta 2.
Comment 2 Jeff Johnson 2002-05-02 16:58:22 EDT
*** Bug 64265 has been marked as a duplicate of this bug. ***
Comment 3 Stephen John Smoogen 2002-05-03 18:19:39 EDT
The easy fix for the package is to install the SRPM, add 1 to the sub-version
number (or whatever it is called), and rebuild RPM. 

The long term fix is to call it something to make it dependant on the specific
version of perl so that when PERL gets rebuilt in the main tree it is seen as
something that has to be rebuilt also.
Comment 4 Jeff Johnson 2002-06-05 15:10:26 EDT

*** This bug has been marked as a duplicate of 64412 ***

Note You need to log in before you can comment on or make changes to this bug.