Bug 644723 - Trying to install latest patch updates for RHEL 5.5, crashes everytime
Trying to install latest patch updates for RHEL 5.5, crashes everytime
Status: CLOSED DUPLICATE of bug 638922
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: pirut (Show other bugs)
5.8
i686 Linux
low Severity high
: rc
: ---
Assigned To: James Antill
Red Hat Satellite QA List
:
: 651077 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-19 23:34 EDT by David Stratman
Modified: 2013-01-10 05:45 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-20 09:35:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Dump from RHEL 5.5 updates - pirut crash (1.76 KB, application/octet-stream)
2010-10-19 23:34 EDT, David Stratman
no flags Details

  None (edit)
Description David Stratman 2010-10-19 23:34:50 EDT
Created attachment 454499 [details]
Dump from RHEL 5.5 updates - pirut crash

Description of problem:
Attempting to install latest patches for RHEL 5.5 and fails on pirut error or update immediately so 28 patches are unable to be installed.

Version-Release number of selected component (if applicable):
Unsure.

How reproducible:
Every attempt on my system produces the same results

Steps to Reproduce:
1. Right click on updates icon in to right of Gnome window.
2. Select "View Updates"
3. Wait for failure message to occur (pasted below) and dump attached.
  
Actual results:
Failure message (pasted below)

Expected results:
28 Updates displayed and then an option appears on whether or not to apply them all or not.

Additional info (error msg. pasted below):

Component: pirut
Summary: TB7d428655 rhnplugin.py:319:_getFile:RepoError: failed to retrieve repodata/fbf0e3871a550b908d4b96e26cc371f10745db73-updateinfo.xml.gz from rhel-i386-client-workstation-5
error was [Errno -1] Metadata file does not match checksum

Traceback (most recent call last):
  File "/usr/sbin/pup", line 617, in ?
    main()
  File "/usr/sbin/pup", line 613, in main
    pup.run()
  File "/usr/sbin/pup", line 451, in run
    self.doRefresh()
  File "/usr/sbin/pup", line 291, in doRefresh
    self.populateUpdates()
  File "/usr/sbin/pup", line 347, in populateUpdates
    self.updateMetadata.add(repo)
  File "/usr/lib/python2.4/site-packages/yum/update_md.py", line 367, in add
    md = obj.retrieveMD(mdtype)
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 1484, in retrieveMD
    return self._retrieveMD(mdtype)
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 1524, in _retrieveMD
    cache=self.http_caching == 'all')
  File "/usr/lib/yum-plugins/rhnplugin.py", line 319, in _getFile
    raise yum.Errors.RepoError, \
RepoError: failed to retrieve repodata/fbf0e3871a550b908d4b96e26cc371f10745db73-updateinfo.xml.gz from rhel-i386-client-workstation-5
error was [Errno -1] Metadata file does not match checksum

Local variables in innermost frame:
e: [Errno -1] Metadata file does not match checksum
url: None
text: rhel-i386-client-workstation-5/updateinfo
self: rhel-i386-client-workstation-5
cache: False
reget: None
relative: repodata/fbf0e3871a550b908d4b96e26cc371f10745db73-updateinfo.xml.gz
start: None
checkfunc: (<bound method RhnRepo.checkMD of <rhnplugin.RhnRepo object at 0x9ca8dcc>>, ('updateinfo',), {})
copy_local: 1
end: None
local: /var/cache/yum/rhel-i386-client-workstation-5/fbf0e3871a550b908d4b96e26cc371f10745db73-updateinfo.xml.gz
Comment 1 James Antill 2010-10-20 09:35:09 EDT

*** This bug has been marked as a duplicate of bug 638922 ***
Comment 2 James Antill 2010-11-09 13:53:15 EST
*** Bug 651077 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.