Bug 644739 - Thunderbird does not handle user defaults in applications
Thunderbird does not handle user defaults in applications
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: thunderbird (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Jan Horak
Fedora Extras Quality Assurance
RejectedBlocker, AcceptedNTH
: Triaged
: 661672 (view as bug list)
Depends On:
Blocks: F15-accepted/F15FinalFreezeExcept
  Show dependency treegraph
 
Reported: 2010-10-20 03:05 EDT by Pavel Alexeev
Modified: 2011-07-11 12:58 EDT (History)
6 users (show)

See Also:
Fixed In Version: gnome-vfs2-2.24.4-5.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-18 00:06:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Pavel Alexeev 2010-10-20 03:05:52 EDT
Description of problem:
Fresh installation of Fedora 14 beta.
Initial install of thunderbird. Links opened in firefox, regardless user defaults. My default browser is Google Chrome and it correctly opened through xdg-open call.

To handle user defaults in system, regardless of preferred desktop environment
there should be meta value xdg-open.

Off course also thunderbird must in this case require xdg-utils in spec (but may be it is ambigues, need futher investigation if it pulled through other requires).

Version-Release number of selected component (if applicable):
$ rpm -q thunderbird
thunderbird-3.1.4-1.fc14.i686

How reproducible:
Always
Comment 1 Adam Dingle 2011-04-04 14:28:44 EDT
I see this too.  I'm running Fedora 15 alpha.  In System Settings->System Info->Default Applications, I've set my default Web browser to Epiphany.  But when I click links in Thunderbird, it opens Firefox.
Comment 2 Matěj Cepl 2011-04-04 17:46:38 EDT
Correct. The problem seems to be that Thunderbird is still Gtk2 application so it uses gconf rather than dconf (which is what System Settings->System
Info->Default Applications sets).

What's the command

gconftool-2 -g /desktop/gnome/url-handlers/http/command

returns?

If you want something else you can set it up with

gconftool-2 -s /desktop/gnome/url-handlers/http/command -t string 'epiphany %s'
Comment 3 Pavel Alexeev 2011-04-04 17:56:53 EDT
I'm do not want epiphany.

$ gconftool-2 -g /desktop/gnome/url-handlers/http/command
returns "firefox %s" and I wondering why there by default not something similar xdg-open??

P.S. I use KDE and as user even do not want known about gconf.
Comment 4 Adam Dingle 2011-04-04 17:59:54 EDT
Matej: Ah, OK, I see.

$ gconftool-2 -g /desktop/gnome/url-handlers/http/command
firefox %s
$ 

Thanks for the workaround.
Comment 5 Christopher Aillon 2011-04-04 18:15:12 EDT
If you are seeing this problem, do you have xdg-utils installed (specifically, /usr/bin/xdg-open)?
Comment 7 Pavel Alexeev 2011-04-05 14:58:41 EDT
Off course!
I was wrote what it work correctly in my initial report! But thunderbird just does not use it.
Comment 8 Adam Dingle 2011-04-05 16:48:48 EDT
The workaround suggested above is not working for me, unfortunately.  I've set the GConf key as suggested:

$ gconftool-2 -g /desktop/gnome/url-handlers/http/command
epiphany %s
$ 

But Thunderbird still launches Firefox.

I do have /usr/bin/xdg-open installed, by the way.
Comment 9 Christopher Aillon 2011-04-11 01:48:42 EDT
*** Bug 661672 has been marked as a duplicate of this bug. ***
Comment 10 Jan Horak 2011-04-11 10:06:25 EDT
Seems to that Thunderbird is using gnomevfs to obtain preferred applications. We have to start using GIO for that.
Comment 11 Pavel Alexeev 2011-04-11 10:19:41 EDT
It must not depend from used De. I think xdg-open with honor many defaults is good candidate here.
Comment 12 Christopher Aillon 2011-04-11 14:33:42 EDT
gio is part of glib2, which thunderbird already depends on.
Comment 13 Fedora Update System 2011-04-12 19:38:26 EDT
gnome-vfs2-2.24.4-5.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/gnome-vfs2-2.24.4-5.fc15
Comment 14 Fedora Update System 2011-04-13 00:54:07 EDT
Package gnome-vfs2-2.24.4-5.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-vfs2-2.24.4-5.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/gnome-vfs2-2.24.4-5.fc15
then log in and leave karma (feedback).
Comment 15 Pavel Alexeev 2011-04-13 06:39:55 EDT
Is it possible push updates also for Fedora 14? Or there may be side effect and dependencies?
Comment 16 Fedora Update System 2011-04-18 00:05:57 EDT
gnome-vfs2-2.24.4-5.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 Tim Flink 2011-04-25 11:49:37 EDT
Discussed at the 2011-04-15 blocker bug review meeting (update to bz delayed).

This bug does not keep any apps from functioning at all, so it does not hit any of the release criteria - RejectedBlocker.

However, this is not ideal functionality and is a polish issue. AcceptedNTH

Note You need to log in before you can comment on or make changes to this bug.