Bug 64507 - dhcp timeout
Summary: dhcp timeout
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
(Show other bugs)
Version: 9
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
: 66283 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-05-06 22:33 UTC by Joshua Jensen
Modified: 2014-03-17 02:27 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-28 23:45:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joshua Jensen 2002-05-06 22:33:14 UTC
Description of Problem:

When waiting for a dhcp server, a timeout of 60 seconds is too long.  Could we
get the next version of Red Hat Linux to have an /etc/sysconfig/network file
that has:


DHCPCDARGS="-t 20"

inside?

Thank you,

Joshua

Comment 1 Need Real Name 2002-05-09 16:04:27 UTC
Another nice feature is a possibility to have alternative network configuration when 
DHCPc doesn't get an answer.

Best regards,

Josi

Comment 2 Elliot Lee 2002-06-20 15:43:45 UTC
I believe initscripts has some sort of alarm for dhcpcd now...

Comment 3 Elliot Lee 2002-06-20 16:53:57 UTC
*** Bug 66283 has been marked as a duplicate of this bug. ***

Comment 4 Brian "netdragon" Bober 2002-07-04 22:53:44 UTC
http://www.linuxquestions.org/questions/history/19491

I altered the /sbin/ifup file to allow you to add DHCP_CLIENT_TIMEOUT to any 
ifcfg-eth* file (such as /etc/sysconfig/network-scripts/ifcfg-eth0

Can you please build this into the Redhat distribution (and possibly add this 
to the kernel for all distributions)? (I'm not entirely sure if its 100% 
correctly done, but it works for me ;-)

excerpt /sbin/ifup

if [ -n "${DYNCONFIG}" ]; then
PUMPARGS=$PUMPARGS
#--------------------------------------
# Brian Bober
# Hacked to add ability for DHCP_CLIENT_TIMEOUT (in seconds)
# variable to /etc/sysconfig/network-scripts/ifcfg-eth* scripts
#--------------------------------------
if [ -n "${DHCP_CLIENT_TIMEOUT}" ]; then
DHCPCDARGS="${DHCPCDARGS} -t ${DHCP_CLIENT_TIMEOUT}"
fi
#--------------------------------------
# End Hack
#--------------------------------------
DHCPCDARGS="$DHCPCDARGS -n"
if [ -n "${DHCP_HOSTNAME}" ]; then
PUMPARGS="${PUMPARGS} -h ${DHCP_HOSTNAME}"
DHCPCDARGS="${DHCPCDARGS} -h ${DHCP_HOSTNAME}"
fi
if [ -n "${NEEDHOSTNAME}" ]; then
PUMPARGS="${PUMPARGS} --lookup-hostname"

Comment 5 Brian "netdragon" Bober 2002-10-21 05:43:30 UTC
Why hasn't anyone replied with a statement like... "I am adding this into the
new Linux Kernel"? ;-)

Comment 6 Brian "netdragon" Bober 2002-12-06 00:50:10 UTC
I was actually wondering in my previous comment if it was adequate or needs 
work. I didn't mean to sound rude. I was assuming it wasn't adequate because 
no one has responded.

Comment 7 Brian "netdragon" Bober 2002-12-06 00:51:30 UTC
It worked for me, but might not work 100% of the time.

Comment 8 Bill Nottingham 2002-12-09 17:52:25 UTC
Can't you just add it to DHCPCDARGS (or the equivalent for your client of choice?)
It inherits any *ARGS settings from the environment.

Comment 9 Joshua Jensen 2003-01-03 17:52:28 UTC
Yes... it could be added to DHCPCDARGS.

But it seems like this is -such- a big complaint... that the timeout is
unbearably long when sitting in front of a booting machine.

I guess the question is:  Is it worth adding something like "DHCPTIMEOUT="30" to
ifup and /etc/sysconfig/network by default?  I would vote "yes", but I'm sure
you already have a lot on your plate.

Comment 10 Joshua Jensen 2004-06-11 23:22:43 UTC
Please close this ticket if you don't want to add the feature.

Comment 11 Bill Nottingham 2004-06-28 19:48:46 UTC
How often is this normally run into? With the link check, the only
places where it should currently time out would be where there's no
DHCP server available. I suppose a shorter return could help there,
but it should really be rare.


Comment 12 Joshua Jensen 2004-06-28 23:45:27 UTC
I agree.  Now with the link check, this isn't a problem that is all
that important to address.


Note You need to log in before you can comment on or make changes to this bug.